Distribution sur plusieurs postes

Le
B
Bonsoir,
Une demande toute bête !
Habituellement, lorsque que je veux installer une nouvelle version de mon
appli, j'installe "manuellement" la version sur chacun des 5 postes que
comporte l'installation en réseau (Les tables étant sur un poste serveur et
l'appli sur les autres) et je lie les tables poste après poste.
Je me demande combien de temps cela prendrai si y'avait 199 postes répartis
sur 10 étages (surtout si l'ascenseur marche pas !!!).
Y doit bien y avoir une autre solution ?
Merci.
@ +

b(°!°)rbbu
(En privé, enlever les MAJUSCULES !)

*
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Raymond [mvp]
Le #5020781
Bonjour
il faut utiliser un disque réseau réservé à ta base, déclaré sur chaque
station.
ton appli frontale aura des tables liées vers le disque réseau. après copie
de la frontale tu n'as pas besoin de lier tes tables car elles sont
automatiquement liées vers le même disque réseau.

--
@+
Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"" news:%
Bonsoir,
Une demande toute bête !
Habituellement, lorsque que je veux installer une nouvelle version de mon
appli, j'installe "manuellement" la version sur chacun des 5 postes que
comporte l'installation en réseau (Les tables étant sur un poste serveur
et

l'appli sur les autres) et je lie les tables poste après poste.
Je me demande combien de temps cela prendrai si y'avait 199 postes
répartis

sur 10 étages (surtout si l'ascenseur marche pas !!!).
Y doit bien y avoir une autre solution ?
Merci.
@ +

b(°!°)rbbu
(En privé, enlever les MAJUSCULES !)

*





bipbipcoyote
Le #5020771
une piste .....
http://access.developpez.com/faq/?page=TablesAndFields#ModifConTablLie
macro à lancer au démarrage de l'application


"" news:%
Bonsoir,
Une demande toute bête !
Habituellement, lorsque que je veux installer une nouvelle version de mon
appli, j'installe "manuellement" la version sur chacun des 5 postes que
comporte l'installation en réseau (Les tables étant sur un poste serveur
et

l'appli sur les autres) et je lie les tables poste après poste.
Je me demande combien de temps cela prendrai si y'avait 199 postes
répartis

sur 10 étages (surtout si l'ascenseur marche pas !!!).
Y doit bien y avoir une autre solution ?
Merci.
@ +

b(°!°)rbbu
(En privé, enlever les MAJUSCULES !)

*





B
Le #5020741
Quelle rapidité d'execution !

il faut utiliser un disque réseau réservé à ta base, déclaré sur chaque
station.
OK ça c'est fait, j'ai le "disque F" qui correspond à l'endroi ou sont mes

tables.

ton appli frontale aura des tables liées vers le disque réseau. après
copie

de la frontale tu n'as pas besoin de lier tes tables car elles sont
automatiquement liées vers le même disque réseau.
Donc, ça veut dire que je fais l'opération de liaison une première fois, et

j'ai plus qu'à la pomper et la coller sur les autres postes !
Oui, mais actuellement faut que j'aille pédibus-jambus d'un poste à
l'autre...
En fait le réseau est ainsi fait (c'est pas moi le responsable réseau) :
A partir de chaque poste frontal on "voit" le disque réseau F ; mais aucun
poste frontal n'est "visible" à partir d'aucun autre poste ! ! !
Merci.


--
@+
Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"" news:%
Bonsoir,
Une demande toute bête !
Habituellement, lorsque que je veux installer une nouvelle version de
mon


appli, j'installe "manuellement" la version sur chacun des 5 postes que
comporte l'installation en réseau (Les tables étant sur un poste serveur
et

l'appli sur les autres) et je lie les tables poste après poste.
Je me demande combien de temps cela prendrai si y'avait 199 postes
répartis

sur 10 étages (surtout si l'ascenseur marche pas !!!).
Y doit bien y avoir une autre solution ?
Merci.
@ +

b(°!°)rbbu
(En privé, enlever les MAJUSCULES !)




Raymond [mvp]
Le #5020711
Pour copier ta base, tu ne fais rien.
place ta base frontale à diffuser sur le disque F:
lors du login windows de chaque utilisateur, tu copies la base frontale à
jour du serveur sur le poste:
si tu as un fichier .bat qui s'exécute au login, tu rajoutes une ligne
copy f:frontale.mde c:monrépertoirefrontale.mde
ainsi chaque matin, chaque poste copie la dernière version de ta frontale
sur son poste. en cas d'urgence de mise à jour tu leur demandes de fermer la
session et de la réouvrir et la copie va se relancer.
tu n'as même pas à te soucier si c'est à jour, dès le login la bonne version
est copiée ( ça prend 5 secondes) sur le poste.
--
@+
Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"" news:
Quelle rapidité d'execution !

il faut utiliser un disque réseau réservé à ta base, déclaré sur chaque
station.
OK ça c'est fait, j'ai le "disque F" qui correspond à l'endroi ou sont mes

tables.

ton appli frontale aura des tables liées vers le disque réseau. après
copie

de la frontale tu n'as pas besoin de lier tes tables car elles sont
automatiquement liées vers le même disque réseau.
Donc, ça veut dire que je fais l'opération de liaison une première fois,

et

j'ai plus qu'à la pomper et la coller sur les autres postes !
Oui, mais actuellement faut que j'aille pédibus-jambus d'un poste à
l'autre...
En fait le réseau est ainsi fait (c'est pas moi le responsable réseau) :
A partir de chaque poste frontal on "voit" le disque réseau F ; mais
aucun

poste frontal n'est "visible" à partir d'aucun autre poste ! ! !
Merci.



B
Le #5034271
Bonsoir,

Pour copier ta base, tu ne fais rien.
place ta base frontale à diffuser sur le disque F:
lors du login windows de chaque utilisateur, tu copies la base frontale à
jour du serveur sur le poste:
si tu as un fichier .bat qui s'exécute au login, tu rajoutes une ligne
copy f:frontale.mde c:monrépertoirefrontale.mde


OK, j'ai déjà essayé ça en manuel.
Le problème c'est que la liaison des tables n'est pas reconnue !
C'est pour cela que je fais tout manu-pédibu-jambus !

J'essaye d'expliquer ce que j'ai fait qui marche pas :
1. Je me met sur un poste et je fais manuellement mes liaisons de tables.
2. Je copie ce frontal.mdb sur le disque F.
3. A partir de chacun des autres postes, je copie ce frontal.mdb.
4. Je lance l'appli par ce frontal.mdb.
5. ça marche pas ! Message d'erreur de liaison de tables non trouvées
patin-couffin !

Merci.
@+


Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"" news:
Quelle rapidité d'execution !

il faut utiliser un disque réseau réservé à ta base, déclaré sur
chaque



station.
OK ça c'est fait, j'ai le "disque F" qui correspond à l'endroi ou sont

mes


tables.

ton appli frontale aura des tables liées vers le disque réseau. après
copie

de la frontale tu n'as pas besoin de lier tes tables car elles sont
automatiquement liées vers le même disque réseau.
Donc, ça veut dire que je fais l'opération de liaison une première fois,

et

j'ai plus qu'à la pomper et la coller sur les autres postes !
Oui, mais actuellement faut que j'aille pédibus-jambus d'un poste à
l'autre...
En fait le réseau est ainsi fait (c'est pas moi le responsable réseau) :
A partir de chaque poste frontal on "voit" le disque réseau F ; mais
aucun

poste frontal n'est "visible" à partir d'aucun autre poste ! ! !
Merci.







Raymond [mvp]
Le #5034261
Ton disque F: est-il bien déclaré sur tous les postes ?
ta liaison manuelle des tables est-elle bien faite sur le disque F: et non
sur le réseau ?

--
@+
Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"" news:
Bonsoir,

Pour copier ta base, tu ne fais rien.
place ta base frontale à diffuser sur le disque F:
lors du login windows de chaque utilisateur, tu copies la base frontale
à


jour du serveur sur le poste:
si tu as un fichier .bat qui s'exécute au login, tu rajoutes une ligne
copy f:frontale.mde c:monrépertoirefrontale.mde


OK, j'ai déjà essayé ça en manuel.
Le problème c'est que la liaison des tables n'est pas reconnue !
C'est pour cela que je fais tout manu-pédibu-jambus !

J'essaye d'expliquer ce que j'ai fait qui marche pas :
1. Je me met sur un poste et je fais manuellement mes liaisons de tables.
2. Je copie ce frontal.mdb sur le disque F.
3. A partir de chacun des autres postes, je copie ce frontal.mdb.
4. Je lance l'appli par ce frontal.mdb.
5. ça marche pas ! Message d'erreur de liaison de tables non trouvées
patin-couffin !

Merci.
@+




B
Le #5033661
Salut,
Je vais voir tout ça demain sur le site d'instal...
Merci.
@ +
b(°!°)rbbu
(En privé, enlever les MAJUSCULES !)

*

"Raymond [mvp]" news: #
Ton disque F: est-il bien déclaré sur tous les postes ?
ta liaison manuelle des tables est-elle bien faite sur le disque F: et non
sur le réseau ?

--
@+
Raymond Access MVP
http://access.seneque.free.fr/
http://access2003.free.fr/
http://users.skynet.be/mpfa/ pour débuter sur le forum


"" news:
Bonsoir,

Pour copier ta base, tu ne fais rien.
place ta base frontale à diffuser sur le disque F:
lors du login windows de chaque utilisateur, tu copies la base
frontale



à
jour du serveur sur le poste:
si tu as un fichier .bat qui s'exécute au login, tu rajoutes une ligne
copy f:frontale.mde c:monrépertoirefrontale.mde


OK, j'ai déjà essayé ça en manuel.
Le problème c'est que la liaison des tables n'est pas reconnue !
C'est pour cela que je fais tout manu-pédibu-jambus !

J'essaye d'expliquer ce que j'ai fait qui marche pas :
1. Je me met sur un poste et je fais manuellement mes liaisons de
tables.


2. Je copie ce frontal.mdb sur le disque F.
3. A partir de chacun des autres postes, je copie ce frontal.mdb.
4. Je lance l'appli par ce frontal.mdb.
5. ça marche pas ! Message d'erreur de liaison de tables non trouvées
patin-couffin !

Merci.
@+









Publicité
Poster une réponse
Anonyme