DNS encore et toujours, ca commence à bien faire :-( SOS

Le
Yann
Bonjour,

J'en fait appelle aux Jedi 5ème DAN d'Active Directory parceque là je
dois avouer que je sèche.
Je suis confronté à un problème de lenteur lors du demarrage de mon
second DC.
J'ai constaté ce problème que lorsque je m'appuie sur lui-même comme
serveur DNS mais pas
lorsque j'utilise le premier DC .

Un petit historique :

Migration de mon domaine NT4 (1PDC et 1BDC) en AD2003 :

1/ Promotion de DC01 (BDC NT4) en PDC
2/ Sorti du réseau et mise à jour en Windows 2003 Active Directory
3/ Installation d'un serveur DNS avec les zones intégrées AD sur
celui-ci
3/ Branchement de DC01 et synchronisation des comptes avec le BDC

quelques jours passent (dont un week end)

4/ Aujourd'hui application du SP1 sur ce DC Windows 2003
5/ Je fait rentrer un serveur (Win2003SP1) fraichement acheté dans mon
domaine en tant que serveur membre.
6/ Promotion de celui-ci en DC et installation du service DNS et aprés
réplication,
je vois les enregistrements de mon autres DNS.


Et voila, lorsque je tente de m'appuyer sur lui-même au niveau du DNS,
mon
nouveau DC (le tout neuf) mets une éternité à démarrer alors que si je
m'appuie
sur celui ayant servi à la transition : pas de problème.

C'est à n'y rien comprendre, les zones sont intégrées Active Directory
(sur les 2 DC)
avec autorisations des mises à jour sécurisées. Les deux serveurs DNS
possèdent
les mêmes enregistrements.

Merci par avance de votre aide car je suis dans la panade car ce DC de
transition
doit trés bientôt disparaitre
Vos réponses
Trier par : date / pertinence
Jonathan Bismuth
Le #539096
Hello Yann,

sur le DC qui pose problème, as tu essayé un netdiag /fix pour voir?

Cordialement,
--
Jonathan BISMUTH
MVP Windows Server - Directory Services
MCSE 2000/ADSI-AutoIT Scripter
Transcript (ID: 691839, code: MCSE2000)
www.portail-mcse.net
pour me contacter http://cerbermail.com/?fCeVUi7Icd


"Yann"
Bonjour,

J'en fait appelle aux Jedi 5ème DAN d'Active Directory parceque là je
dois avouer que je sèche.
Je suis confronté à un problème de lenteur lors du demarrage de mon
second DC.
J'ai constaté ce problème que lorsque je m'appuie sur lui-même comme
serveur DNS mais pas
lorsque j'utilise le premier DC .

Un petit historique :

Migration de mon domaine NT4 (1PDC et 1BDC) en AD2003 :

1/ Promotion de DC01 (BDC NT4) en PDC
2/ Sorti du réseau et mise à jour en Windows 2003 Active Directory
3/ Installation d'un serveur DNS avec les zones intégrées AD sur
celui-ci
3/ Branchement de DC01 et synchronisation des comptes avec le BDC

...quelques jours passent (dont un week end)...

4/ Aujourd'hui application du SP1 sur ce DC Windows 2003
5/ Je fait rentrer un serveur (Win2003SP1) fraichement acheté dans mon
domaine en tant que serveur membre.
6/ Promotion de celui-ci en DC et installation du service DNS et aprés
réplication,
je vois les enregistrements de mon autres DNS.


Et voila, lorsque je tente de m'appuyer sur lui-même au niveau du DNS,
mon
nouveau DC (le tout neuf) mets une éternité à démarrer alors que si je
m'appuie
sur celui ayant servi à la transition : pas de problème.

C'est à n'y rien comprendre, les zones sont intégrées Active Directory
(sur les 2 DC)
avec autorisations des mises à jour sécurisées. Les deux serveurs DNS
possèdent
les mêmes enregistrements.

Merci par avance de votre aide car je suis dans la panade car ce DC de
transition
doit trés bientôt disparaitre




Yann
Le #538837
Bonjour Jonathan et merci de ton aide,

oui j'ai essayé le netdiag /fix.
D'ailleurs c'est marrant mon problème et exactement le même que celui
expliqué là : http://www.pcreview.co.uk/forums/thread-1476091.php .

La réponse finale de cette page, comme quoi c'est normal que le DC
mettent du temps à demarrer car le DNS et l'Active Directory ont
besoin mutuellement l'un de l'autre et que ca se mords la queue, ne me
convient pas car le premier DC (celui ayant servi à migrer de NT4 vers
2003) y arrive bien alors qu'il pointe bien sur lui-même au niveau DNS
!!

Merci encore de ton aide,si t'as une idée ...

Je suis ouvert à toute proposition, même paranormale car pour le
rationnel je vois plus :-(

Si quelqu'un peut trouver la solution je lui en serais eternellement
reconnaissant ...



On Tue, 14 Feb 2006 13:48:57 +0100, "Jonathan Bismuth"

Hello Yann,

sur le DC qui pose problème, as tu essayé un netdiag /fix pour voir?

Cordialement,


Jonathan Bismuth
Le #538579
Hello,

le fameux truc du serpent qui se mord la queue :p

Un truc que je ne comprends pas, il ne va te rester qu'un seul DC au final?
rien en backup?
As tu au moins moyen de monter un DNS secondaire sur un serveur membre

--
Jonathan BISMUTH
MVP Windows Server - Directory Services
MCSE 2000/ADSI-AutoIT Scripter
Transcript (ID: 691839, code: MCSE2000)
www.portail-mcse.net
pour me contacter http://cerbermail.com/?fCeVUi7Icd


"Yann"
Bonjour Jonathan et merci de ton aide,

oui j'ai essayé le netdiag /fix.
D'ailleurs c'est marrant mon problème et exactement le même que celui
expliqué là : http://www.pcreview.co.uk/forums/thread-1476091.php .

La réponse finale de cette page, comme quoi c'est normal que le DC
mettent du temps à demarrer car le DNS et l'Active Directory ont
besoin mutuellement l'un de l'autre et que ca se mords la queue, ne me
convient pas car le premier DC (celui ayant servi à migrer de NT4 vers
2003) y arrive bien alors qu'il pointe bien sur lui-même au niveau DNS
!!

Merci encore de ton aide,si t'as une idée ...

Je suis ouvert à toute proposition, même paranormale car pour le
rationnel je vois plus :-(

Si quelqu'un peut trouver la solution je lui en serais eternellement
reconnaissant ...



On Tue, 14 Feb 2006 13:48:57 +0100, "Jonathan Bismuth"

Hello Yann,

sur le DC qui pose problème, as tu essayé un netdiag /fix pour voir?

Cordialement,




Yann
Le #538348
Bonjour Jonathan,

Ben en fait non il ne se mord la queue que s'il sait qu'il n'est pas
seul, bizarre bizarre !!! Je m'explique :

Effectivement si je parametre mes deux serveur DC pour qu'ils pointent
chacun vers eux-même au niveau DNS (zones intégrés AD) , le demarrage
est tres long environ 6min sur "preparation des connexions reseau"
contre 20 secondes s'ils pointent l'un sur l'autre !

Pour continuer, j'ai "dépromu" mon DC de migration puis sorti du
domaine.Et du coup mon seul (temporairement) DC pointe de nouveau
vers lui-même (cas de figure ou le premier et seul DC de l'AD est
monté).

Et bien là,vu qu'il est le seul DC en place mon démarrage est aussi
rapide que s'il s'appuyait sur le DNS d'un autre DC.

Je ne trouve aucune documentation la-dessus,mais y a doit bien y avoir
qqchose !!

Par contre je suis actuellement entrain de rentrer un nouveau DC dans
mon domaine et ainsi avoiraussi une redondance AD et DNS ...

Si qqu'un a une doc sur ce phénomène, j'suis preneur ...

Par contre une autre questio npendant que j'y suis sinon j'vais faire
un nouveau thead :

Je dépromu un DC tout s'est bien passé au niveau AD
Seul 1ou2 enregistrement à retirer à la main sur le DNS,mais par
contre, j'ai encore mon ancien serveur dans Site & Service :-(

Normal ? (pense pas)

Que faire , le retirer à la mano ou existe-t-il une manip plus
élégante ?

Merci par avance de toute aide.


Yann


On Wed, 15 Feb 2006 12:38:28 +0100, "Jonathan Bismuth"

Hello,

le fameux truc du serpent qui se mord la queue :p

Un truc que je ne comprends pas, il ne va te rester qu'un seul DC au final?
rien en backup?
As tu au moins moyen de monter un DNS secondaire sur un serveur membre


Jonathan Bismuth
Le #538347
Excellent!
Quand je penses qu'à mes débuts, on m'assurait que le phénomène "d'island"
n'était plus présent sous 2003. Pour infos, tu subit une variation de ceci :
http://support.microsoft.com/kb/275278/en-us

réponses sous tes questions :

Effectivement si je parametre mes deux serveur DC pour qu'ils pointent
chacun vers eux-même au niveau DNS (zones intégrés AD) , le demarrage
est tres long environ 6min sur "preparation des connexions reseau"
contre 20 secondes s'ils pointent l'un sur l'autre !


Chacun sur lui même est une mauvais eidée, le fameux serpent qui se mord la
queue. Assure toi de pointer un seul DC comme DNS (même si les autres le
sont aussi pour les clients) et fais pointer tous tes DC sur celui-ci.

Pour continuer, j'ai "dépromu" mon DC de migration puis sorti du
domaine.Et du coup mon seul (temporairement) DC pointe de nouveau
vers lui-même (cas de figure ou le premier et seul DC de l'AD est
monté).

Et bien là,vu qu'il est le seul DC en place mon démarrage est aussi
rapide que s'il s'appuyait sur le DNS d'un autre DC.


Normal, il est seul, il se trouve tout seul

Je ne trouve aucune documentation la-dessus,mais y a doit bien y avoir
qqchose !!


Voir au dessus

Par contre je suis actuellement entrain de rentrer un nouveau DC dans
mon domaine et ainsi avoiraussi une redondance AD et DNS ...

Si qqu'un a une doc sur ce phénomène, j'suis preneur ...


Pas de soucis :
- ajoute le serveur membre dans le domaine
- dans ses paramètres TCP-IP, fait le pointer sur le DNS du DC1
- dcpromo sur ce DC, spécifie lui que c'est un nouveau DC pour un domaine
existant
- une fois la mise en place faite, rend le catalogue global
- installe le service DNS (sans ajouter de zone! Elle va apparaître toute
seule)
- terminé :)

Par contre une autre questio npendant que j'y suis sinon j'vais faire
un nouveau thead :

Je dépromu un DC tout s'est bien passé au niveau AD
Seul 1ou2 enregistrement à retirer à la main sur le DNS,mais par
contre, j'ai encore mon ancien serveur dans Site & Service :-(

Normal ? (pense pas)

Que faire , le retirer à la mano ou existe-t-il une manip plus
élégante ?
Si le DCPROMO (donc pas un dcpromo /forceremoval) est bien passé et qu'il

n'existe plus de traces dans l'AD, tu peux virer à la main les
enregistrements dans Sites & services AD.

Cordialement ,

--
Jonathan BISMUTH
MVP Windows Server - Directory Services
MCSE 2000/ADSI-AutoIT Scripter
Transcript (ID: 691839, code: MCSE2000)
www.portail-mcse.net
pour me contacter http://cerbermail.com/?fCeVUi7Icd


"Yann"
Bonjour Jonathan,

Ben en fait non il ne se mord la queue que s'il sait qu'il n'est pas
seul, bizarre bizarre !!! Je m'explique :

Effectivement si je parametre mes deux serveur DC pour qu'ils pointent
chacun vers eux-même au niveau DNS (zones intégrés AD) , le demarrage
est tres long environ 6min sur "preparation des connexions reseau"
contre 20 secondes s'ils pointent l'un sur l'autre !

Pour continuer, j'ai "dépromu" mon DC de migration puis sorti du
domaine.Et du coup mon seul (temporairement) DC pointe de nouveau
vers lui-même (cas de figure ou le premier et seul DC de l'AD est
monté).

Et bien là,vu qu'il est le seul DC en place mon démarrage est aussi
rapide que s'il s'appuyait sur le DNS d'un autre DC.

Je ne trouve aucune documentation la-dessus,mais y a doit bien y avoir
qqchose !!

Par contre je suis actuellement entrain de rentrer un nouveau DC dans
mon domaine et ainsi avoiraussi une redondance AD et DNS ...

Si qqu'un a une doc sur ce phénomène, j'suis preneur ...

Par contre une autre questio npendant que j'y suis sinon j'vais faire
un nouveau thead :

Je dépromu un DC tout s'est bien passé au niveau AD
Seul 1ou2 enregistrement à retirer à la main sur le DNS,mais par
contre, j'ai encore mon ancien serveur dans Site & Service :-(

Normal ? (pense pas)

Que faire , le retirer à la mano ou existe-t-il une manip plus
élégante ?

Merci par avance de toute aide.


Yann


On Wed, 15 Feb 2006 12:38:28 +0100, "Jonathan Bismuth"

Hello,

le fameux truc du serpent qui se mord la queue :p

Un truc que je ne comprends pas, il ne va te rester qu'un seul DC au
final?
rien en backup?
As tu au moins moyen de monter un DNS secondaire sur un serveur membre




Yann
Le #538153
On Wed, 15 Feb 2006 16:52:08 +0100, "Jonathan Bismuth"

Excellent!
Quand je penses qu'à mes débuts, on m'assurait que le phénomène "d'island"
n'était plus présent sous 2003. Pour infos, tu subit une variation de ceci :
http://support.microsoft.com/kb/275278/en-us



Tout à fait sauf que cela ne se produit que lorsque le DC sait qu'il
n'est pas le seul dans le domaine !
S'il est le seul DC du domaine le phénomène disparait !!


Je dépromu un DC tout s'est bien passé au niveau AD
Seul 1ou2 enregistrement à retirer à la main sur le DNS,mais par
contre, j'ai encore mon ancien serveur dans Site & Service :-(

Normal ? (pense pas)

Que faire , le retirer à la mano ou existe-t-il une manip plus
élégante ?
Si le DCPROMO (donc pas un dcpromo /forceremoval) est bien passé et qu'il

n'existe plus de traces dans l'AD, tu peux virer à la main les
enregistrements dans Sites & services AD.

Cordialement ,


Oui mon dcpromo s'est bien passé (sans avoir à utiliser le
forceremoval). Je ne sais pas si des reférences existe encore ou pas
dans l'Active Directory.Y aurait-il un moyen sachant que je ne suis
pas un pro de ldp.exe et que je crois savoir que nous ne voyons pas
toutes les partitions et objets AD dans Utilisateurs et Ordinateurs AD
(même en affichage avancé)


En tout cas merci milles fois de ton support.

Sincèrement.


Yann


Jonathan Bismuth
Le #538150
re,

Tout à fait sauf que cela ne se produit que lorsque le DC sait qu'il
n'est pas le seul dans le domaine !
S'il est le seul DC du domaine le phénomène disparait !!
logique, s'il est le seul il n'y a pas cumul et il ne se pose pas de

questions.

Oui mon dcpromo s'est bien passé (sans avoir à utiliser le
forceremoval). Je ne sais pas si des références existe encore ou pas
dans l'Active Directory.Y aurait-il un moyen sachant que je ne suis
pas un pro de ldp.exe et que je crois savoir que nous ne voyons pas
toutes les partitions et objets AD dans Utilisateurs et Ordinateurs AD
(même en affichage avancé)
Sans passer par un ldp, un check des metadata depuis un ntdsutil devrait

suffire.
S'il n'existe pas d'entrée pour ce DC quand tu suis cette procédure :
http://support.microsoft.com/?id!6498
C'est que tu peux concrètement terminer ton nettoyage en supprimant l'objet
de sites & services

Cordialement,
--
Jonathan BISMUTH
MVP Windows Server - Directory Services
MCSE 2000/ADSI-AutoIT Scripter
Transcript (ID: 691839, code: MCSE2000)
www.portail-mcse.net
pour me contacter http://cerbermail.com/?fCeVUi7Icd


"Yann"
On Wed, 15 Feb 2006 16:52:08 +0100, "Jonathan Bismuth"

Excellent!
Quand je penses qu'à mes débuts, on m'assurait que le phénomène "d'island"
n'était plus présent sous 2003. Pour infos, tu subit une variation de ceci
:
http://support.microsoft.com/kb/275278/en-us



Tout à fait sauf que cela ne se produit que lorsque le DC sait qu'il
n'est pas le seul dans le domaine !
S'il est le seul DC du domaine le phénomène disparait !!


Je dépromu un DC tout s'est bien passé au niveau AD
Seul 1ou2 enregistrement à retirer à la main sur le DNS,mais par
contre, j'ai encore mon ancien serveur dans Site & Service :-(

Normal ? (pense pas)

Que faire , le retirer à la mano ou existe-t-il une manip plus
élégante ?
Si le DCPROMO (donc pas un dcpromo /forceremoval) est bien passé et qu'il

n'existe plus de traces dans l'AD, tu peux virer à la main les
enregistrements dans Sites & services AD.

Cordialement ,


Oui mon dcpromo s'est bien passé (sans avoir à utiliser le
forceremoval). Je ne sais pas si des reférences existe encore ou pas
dans l'Active Directory.Y aurait-il un moyen sachant que je ne suis
pas un pro de ldp.exe et que je crois savoir que nous ne voyons pas
toutes les partitions et objets AD dans Utilisateurs et Ordinateurs AD
(même en affichage avancé)


En tout cas merci milles fois de ton support.

Sincèrement.


Yann




Publicité
Poster une réponse
Anonyme