driver ATI proprio et kernel 2.6.17

Le
C. Mourad Jaber
Bonjour,

Je viens d'installer le kernel 2.6.17 et j'aimerai installer les drivers
proprio ATI

La compilation se termine sur une erreur :
[SNIP]
/usr/src/modules/fglrx/firegl_public.c:3943: warning: passing argument 3
of 'im_fglrx_agp_stub->allocate_memory_phys_list' makes integer from
pointer without a cast
/usr/src/modules/fglrx/firegl_public.c: In function '__ke_agp_bind_memory':
/usr/src/modules/fglrx/firegl_public.c:3982: warning: passing argument 1
of 'im_fglrx_agp_stub->bind_memory' from incompatible pointer type
/usr/src/modules/fglrx/firegl_public.c: In function
'__ke_agp_unbind_memory':
/usr/src/modules/fglrx/firegl_public.c:3995: warning: passing argument 1
of 'im_fglrx_agp_stub->unbind_memory' from incompatible pointer type
/usr/src/modules/fglrx/firegl_public.c: In function
'__ke_smp_call_function':
/usr/src/modules/fglrx/firegl_public.c:4224: warning: passing argument 1
of 'smp_call_function' from incompatible pointer type
make[3]: *** [/usr/src/modules/fglrx/firegl_public.o] Erreur 1
make[2]: *** [_module_/usr/src/modules/fglrx] Erreur 2
make[2]: quittant le répertoire « /usr/src/linux-headers-2.6.17-1-686 »
make[1]: *** [kmod_build] Erreur 2
make[1]: quittant le répertoire « /usr/src/modules/fglrx »
build failed with return value 2
make: *** [build] Erreur 1

Y'a-t-il un patch pour que cette compilation se passe correctement avec
le noyau 2.6.17 ?

Merci

Mourad


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
C. Mourad Jaber
Le #9277371
On 09.07.2006 18:46, bruynooghe wrote:
C. Mourad Jaber a écrit :
...



Moi, j'ai suivi ce tuto et ça marche impec avec le 2.6.17-1 sous debian :
http://www.quebecos.com/modules/weblog/details.php?blog_id00
Voilà. Pierre


Merci, je pense que ça viens du paquet fglrx-kernel-src debian qui est
un peu vieux (8.24.8-1)...
@ +

Mourad


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
bruynooghe
Le #9277361
C. Mourad Jaber a écrit :

On 09.07.2006 18:46, bruynooghe wrote:

C. Mourad Jaber a écrit :

...



Moi, j'ai suivi ce tuto et ça marche impec avec le 2.6.17-1 sous
debian :
http://www.quebecos.com/modules/weblog/details.php?blog_id00
Voilà. Pierre



Merci, je pense que ça viens du paquet fglrx-kernel-src debian qui est
un peu vieux (8.24.8-1)...
@ +

Mourad




Tu me diras si ça a marché pour toi. Salut. Bonne finale


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
C. Mourad Jaber
Le #9277241
On 09.07.2006 19:01, bruynooghe wrote:
C. Mourad Jaber a écrit :

On 09.07.2006 18:46, bruynooghe wrote:

C. Mourad Jaber a écrit :

...



Moi, j'ai suivi ce tuto et ça marche impec avec le 2.6.17-1 sous
debian :
http://www.quebecos.com/modules/weblog/details.php?blog_id00
Voilà. Pierre



Merci, je pense que ça viens du paquet fglrx-kernel-src debian qui
est un peu vieux (8.24.8-1)...
@ +

Mourad




Tu me diras si ça a marché pour toi. Salut. Bonne finale




Bah impec, j'ai suivit pas à pas le tutoriel et ça marche sans pb.

@ +

Mourad


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Poster une réponse
Anonyme