[DW 2004] Mise ? jour 2 enregistrements en ASP

Le
PP
Bonjour,
je suis tomb? sur un probl?me de DW MX 2004 (qui ?tait d?j? pr?sent dans la
version DW MX 6.)
Malgr? la mise ? jour en version 7.0.1, le probl?me persiste et est tr?s
simple ? reproduire avec la marche ? suivre suivante :

Avec DW en mode ASP VBScript, on prend un base Access simple avec 2 tables par
exemple.
Dans un nouvelle page, avec Application Base de donn?e, on cr?e un connection.
On cr?e deux Recordset sur chaque table (Table1->RS1 et Table2->RS2).
On insert 2 formulaires form1 et form2.
On place dans chacun des formulaires, un champ provenant respectivement de RS1
et RS2.
On va ensuite dans Application / Comportement serveur / + / Mettre ? jour
l'enregistrement
On choisit la bonne connection, la table 1, le champ cl?, le form1, etc
On sauve, on test, la mise ? jour se fait, ?a marche nickel.

On retourne dans Application / Comportement serveur / + / Mettre ? jour
l'enregistrement,
On fait la m?me chose, mais on choisit la table2, le form2 et le bon
champs,etc
et Lorsqu'on fait ok, DW au lieu de nous mettre 2 lignes comme ceci :

Mettre ? jour l'enregistrement (RS1, formulaire "form1")
Mettre ? jour l'enregistrement (RS2, formulaire "form2")

Il se m?lange les pinceaux et nous fait 2 lignes comme ceci :
Mettre ? jour l'enregistrement (RS1, formulaire "form1")
Mettre ? jour l'enregistrement (formulaire "form1") avec un point
d'exclamation rouge devant :

J'ai d?j? fait reproduire ce probl?me ? plusieurs personnes sur des serveurs
et de base de donn?es diff?rentes

Par contre, le m?me processus fonctionne parfaitement avec PHP + MySql.

Est-ce que quelqu'un ? un solution pour contourner ce probl?me ?
Est-ce un probl?me connu de Macromedia ?

Merci pour votre aide.
Pascal Perret
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
STEPHAN LUDOVIC
Le #16856121
BOnjour,

Il me semble que je suis aussi confronté à des problèmes d'insertion d
'enregistrement ou de mise à jour ( comportement) en asp/access sur dwmx
7.01 (maj réalisée)...


Et impossible de résoudre ce problème...

Stephan L Brest

"" news:c6aju0$i7s$
Bonjour,
je suis tomb? sur un probl?me de DW MX 2004 (qui ?tait d?j? pr?sent dans


la
version DW MX 6.)
Malgr? la mise ? jour en version 7.0.1, le probl?me persiste et est tr?s
simple ? reproduire avec la marche ? suivre suivante :

Avec DW en mode ASP VBScript, on prend un base Access simple avec 2


tables par
exemple.
Dans un nouvelle page, avec Application Base de donn?e, on cr?e un


connection.
On cr?e deux Recordset sur chaque table (Table1->RS1 et Table2->RS2).
On insert 2 formulaires form1 et form2.
On place dans chacun des formulaires, un champ provenant respectivement


de RS1
et RS2.
On va ensuite dans Application / Comportement serveur / + / Mettre ? jour
l'enregistrement
On choisit la bonne connection, la table 1, le champ cl?, le form1,


etc...
On sauve, on test, la mise ? jour se fait, ?a marche nickel.

On retourne dans Application / Comportement serveur / + / Mettre ? jour
l'enregistrement,
On fait la m?me chose, mais on choisit la table2, le form2 et le bon
champs,etc...
et Lorsqu'on fait ok, DW au lieu de nous mettre 2 lignes comme ceci :

Mettre ? jour l'enregistrement (RS1, formulaire "form1")
Mettre ? jour l'enregistrement (RS2, formulaire "form2")

Il se m?lange les pinceaux et nous fait 2 lignes comme ceci :
Mettre ? jour l'enregistrement (RS1, formulaire "form1")
Mettre ? jour l'enregistrement (formulaire "form1") avec un point
d'exclamation rouge devant :

J'ai d?j? fait reproduire ce probl?me ? plusieurs personnes sur des


serveurs
et de base de donn?es diff?rentes...

Par contre, le m?me processus fonctionne parfaitement avec PHP + MySql.

Est-ce que quelqu'un ? un solution pour contourner ce probl?me ?
Est-ce un probl?me connu de Macromedia ?

Merci pour votre aide.
Pascal Perret




Publicité
Poster une réponse
Anonyme