Erreur "Fichier ou liaison hyperfile ... inconnu"

Le
VincentC
Bonjour,

J'utilise la syntaxe suivante sans aucun problème juqu'à aujourd'hui :

{Ma_Rubrique_Hyperfile, indFichier} = Ma_valeur

Or sur une fenêtre qui fonctionné, j'ai maintenant l'erreur

<Fichier ou liaison hyperfile "Client.RefClient" inconnu> alors que
j'ai bien un fichier "Client" dans mon analyse et un champ RefClient.

Une idée ?

Merci.
Vos réponses
Trier par : date / pertinence
Pascal F
Le #14672921
VincentC avait soumis l'idée :
Bonjour,

J'utilise la syntaxe suivante sans aucun problème juqu'à aujourd'hui :

{Ma_Rubrique_Hyperfile, indFichier} = Ma_valeur

Or sur une fenêtre qui fonctionné, j'ai maintenant l'erreur

RefClient.

Une idée ?

Merci.



il faut mettre {Ma_Rubrique_Hyperfile, indRubrique} puisqu'il s'agit d'une rubrique et non d'un fichier

--
Pascal

Ne garder que le prénom pour me joindre
VincentC
Le #14672911
Il se trouve que Pascal F a formulé :
VincentC avait soumis l'idée :
Bonjour,

J'utilise la syntaxe suivante sans aucun problème juqu'à aujourd'hui :

{Ma_Rubrique_Hyperfile, indFichier} = Ma_valeur

Or sur une fenêtre qui fonctionné, j'ai maintenant l'erreur

bien un fichier "Client" dans mon analyse et un champ RefClient.

Une idée ?

Merci.



il faut mettre {Ma_Rubrique_Hyperfile, indRubrique} puisqu'il s'agit d'une
rubrique et non d'un fichier



Effectivement, ça marche beaucoup mieux.

Ce qui m'épate c'est qu'avant ça fonctionné avec indfichier , ou bien
j'ai modifié le code sans faire attention ...


Merci pour ta réponse rapide.
Publicité
Poster une réponse
Anonyme