Erreur sur script ffmpeg ?

Le
ptilou
Slt,

Sur suse 15.2 open, j’ai ça comme erreur :
yudas@yudas-1:~/Vid̓©os> ./script-ffmpeg-jpg
ffmpeg version 3.4.4 Copyright (c) 2000-2018 the FFmpeg developers
built with gcc 7 (SUSE Linux)
configuration: --prefix=/usr --libdir=/usr/lib64 --shlibdir=/usr/lib64 --incdir=/usr/include/ffmpeg --extra-cflags='-fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g' --optflags='-fmessage-length=0 -grecord-gcc-switches -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector-strong -funwind-tables -fasynchronous-unwind-tables -fstack-clash-protection -g' --disable-htmlpages --enable-pic --disable-stripping --enable-shared --disable-static --enable-gpl --disable-openssl --enable-avresample --enable-libcdio --enable-gnutls --enable-ladspa --disable-cuda --disable-cuvid --enable-libass --enable-libbluray --enable-libcelt --enable-libcdio --enable-libdc1394 --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-libopus --enable-libpulse --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvorbis --enable-libvpx --enable-libwebp --enable-libzimg --enable-libzvbi --enable-vaapi --enable-vdpau --enable-muxers --enable-demuxers --disable-encoders --disable-decoders --disable-decoder='mpeg4,h263,h264,hevc,vc1' --enable-encoder='apng,ass,ayuv,bmp,ffv1,ffvhuff,flac,gif,huffyuv,jpegls,libgsm,libmp3lame,libopenjpeg,libopus,libschroedinger,libspeex,libtheora,libtwolame,libvorbis,libvpx_vp8,libvpx_vp9,libwebp,libwebp_anim,mjpeg,mp2,mp2fixed,opus,pam,pbm,pcm_alaw,pcm_f32be,pcm_f32le,pcm_f64be,pcm_f64le,pcm_mulaw,pcm_s16be,pcm_s16be_planar,pcm_s16le,pcm_s16le_planar,pcm_s24be,pcm_s24le,pcm_s24le_planar,pcm_s32be,pcm_s32le,pcm_s32le_planar,pcm_s8,pcm_s8_planar,pcm_u16be,pcm_u16le,pcm_u24be,pcm_u24le,pcm_u32be,pcm_u32le,pcm_u8,pcx,pgm,pgmyuv,png,ppm,sgi,srt,ssa,sunrast,targa,text,tiff,v210,v308,v408,v410,vorbis,xbm,xwd,y41p,yuv4,zlib,' --enable-decoder='ac3,ansi,apng,ass,ayuv,bmp,dirac,exr,ffv1,ffvhuff,ffwavesynth,flac,gif,gsm,huffyuv,libcelt,libgsm,libopenjpeg,libopus,libschroedinger,libspeex,libvorbis,libvpx_vp8,libvpx_vp9,mjpeg,mpeg1video,mpeg2video,,mp1,mp1float,mp2,mp2float,mp3,mp3float,opus,pam,pbm,pcm_alaw,pcm_bluray,pcm_dvd,pcm_f32be,pcm_f32le,pcm_f64be,pcm_f64le,pcm_mulaw,pcm_s16be,pcm_s16be_planar,pcm_s16le,pcm_s16le_planar,pcm_s24be,pcm_s24le,pcm_s24le_planar,pcm_s32be,pcm_s32le,pcm_s32le_planar,pcm_s8,pcm_s8_planar,pcm_u16be,pcm_u16le,pcm_u24be,pcm_u24le,pcm_u32be,pcm_u32le,pcm_u8,pcx,pgm,pgmyuv,pgssub,png,ppm,rawvideo,sgi,srt,ssa,sunrast,targa,text,theora,tiff,v210,v210x,v308,v408,v410,vorbis,vp3,vp5,vp6,vp6a,vp6f,vp8,vp9,webp,xbm,xwd,y41p,yuv4,zlib,'
libavutil 55. 78.100 / 55. 78.100
libavcodec 57.107.100 / 57.107.100
libavformat 57. 83.100 / 57. 83.100
libavdevice 57. 10.100 / 57. 10.100
libavfilter 6.107.100 / 6.107.100
libavresample 3. 7. 0 / 3. 7. 0
libswscale 4. 8.100 / 4. 8.100
libswresample 2. 9.100 / 2. 9.100
libpostproc 54. 7.100 / 54. 7.100

Alors que je lance ça comme commande
#test scrit
ffmpeg -i Clip Respire Mickey 3D.mov -r 24 -f image2 -qscale 1 photo-%0d.jpg


Une idée ?

Le ce a changer depuis que je suis rentré de Londres ..


Ptilou
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
David Larochette
Le #26563288
Le 20/12/2020 Í  10:31, ptilou a écrit :
[SNIP]
Alors que je lance ça comme commande
#test scrit
ffmpeg -i Clip Respire Mickey 3D.mov -r 24 -f image2 -qscale 1 photo-%0d.jpg

Il faut soit "échapper" les espaces dans le nom de fichier avec des
obliques inverses (), soit le mettre entre guillemets.
ptilou
Le #26563296
Le lundi 21 décembre 2020 Í  08:03:00 UTC+1, David Larochette a écrit :
Le 20/12/2020 Í  10:31, ptilou a écrit :
[SNIP]
Alors que je lance ça comme commande
#test scrit
ffmpeg -i Clip Respire Mickey 3D.mov -r 24 -f image2 -qscale 1 photo-%0d.jpg

Il faut soit "échapper" les espaces dans le nom de fichier avec des
obliques inverses (), soit le mettre entre guillemets.

Il dit que le huile de ffmpeg n’a pas le support de h264, et c’est bien ça !
Je regarde si , il y a moyen d’installer un build avec h264, qui doit être installé sur la machine, mais le problème est au message du dessous pourquoi un meme dvd installerai deux distributions différentes ?

Ptilou
ptilou
Le #26563323
Le lundi 21 décembre 2020 Í  10:22:03 UTC+1, ptilou a écrit :
Le lundi 21 décembre 2020 Í  08:03:00 UTC+1, David Larochette a écrit :
Le 20/12/2020 Í  10:31, ptilou a écrit :
[SNIP]
> Alors que je lance ça comme commande
> #test scrit
> ffmpeg -i Clip Respire Mickey 3D.mov -r 24 -f image2 -qscale 1 photo-%0d.jpg
Il faut soit "échapper" les espaces dans le nom de fichier avec des
obliques inverses (), soit le mettre entre guillemets.

Il dit que le huile de ffmpeg n’a pas le support de h264, et c’est bien ça !
Je regarde si , il y a moyen d’installer un build avec h264, qui doit être installé sur la machine, mais le problème est au message du dessous pourquoi un meme dvd installerai deux distributions différentes ?


Finalement sur l’autre machine celle o͹ l’on voit la possibilité de sélectionner des bloque de paquetage la ligne fonctionne, je l’ai mit dans ce script :
#!/bin/bash
function f_image-fusion {
ffmpeg -i $i -r 24 -f image2 -qscale 1 photo-%0d.jpg }
{
find ./ -iname *.Mov
echo "EOF"
} | {
while true; do
read -r i
test "$i" = "EOF" && break
f_image-fusion "$i"
done
}
Et même si je remplace par $0 mon $i dans la fonction ffmpeg, j’ai une erreur Í  la ligne 15 ?
Donc comment faire une boucle qui fasse que $i soit un fichier vidéo, terminant par *.mov, *.avi et *.mp4 ?
J’ai fait un man Bach, la doc datent de 2009, cette été la boucle fonctionnait je l’es fait tourné avec convert d’image magic ?
Merci

Ptilou
Poster une réponse
Anonyme