[Etch] Cpufreq m'envoie balader!

Le
Leon GRAY
Bonjours,

J'ai voulu régler le frequency scaling sur mon portable car j'en avais
marre de l'entendre tourner à fond pour 3 fois rien.
J'ai donc installé cpufreqd sur mon PC
Mais ce dernier refuse de se lancer, j'ai pourtant tenté de configurer
mon noyau correctement.
Voici d'ailleurs ce que me renvoie: $ cat /boot/config-2.6.18-ulysse
|grep FREQ

CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_DEBUG=y
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=y
CONFIG_CPU_FREQ_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=y
CONFIG_X86_ACPI_CPUFREQ=m
# CONFIG_X86_CPUFREQ_NFORCE2 is not set
CONFIG_X86_ACPI_CPUFREQ_PROC_INTF=y

et là ce que me donne: $ cat /boot/config-2.6.18-ulysse |grep ACPI

CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_SLEEP_PROC_FS=y
CONFIG_ACPI_SLEEP_PROC_SLEEP=y
CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_VIDEO=m
# CONFIG_ACPI_HOTKEY is not set
CONFIG_ACPI_FAN=m
# CONFIG_ACPI_DOCK is not set
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_THERMAL=m
CONFIG_ACPI_ASUS=m
# CONFIG_ACPI_IBM is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
# CONFIG_ACPI_CONTAINER is not set
# CONFIG_ACPI_SBS is not set
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_ACPI_CPUFREQ_PROC_INTF=y
CONFIG_HOTPLUG_PCI_ACPI=m
# CONFIG_HOTPLUG_PCI_ACPI_IBM is not set
CONFIG_PNPACPI=y


En revanche, je me suis apperçu que le module ACPI_FREQ n'était pas
lancé au démarrage, et lorsque je veux le lancer j'obtient ceci:
# modprobe acpi_cpufreq

FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-ulysse/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device


quelqu'un voit-il ce qui cloche???


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vos réponses
Trier par : date / pertinence
David Prévot
Le #9465091
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Leon GRAY a écrit :
Bonjours,


Salut,

J'ai voulu régler le frequency scaling sur mon portable car j'en avais
marre de l'entendre tourner à fond pour 3 fois rien.


le doux bruit du cpu qui crépite ;)

J'ai donc installé cpufreqd sur mon PC...



Pour ma part, j'ai installé powernowd, ça n'a pas posé de problème...

Amicalement

David
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFFhUA318/WetbTC/oRAlgpAKCdDD1y7+phBBF9J/fwSIbbPZegswCfcbJa
l4yEmRgOAUd8sMfUL1vUK3E WPd
-----END PGP SIGNATURE-----


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
giggz
Le #9465081
Leon GRAY a écrit :
Bonjours,

J'ai voulu régler le frequency scaling sur mon portable car j'en avais
marre de l'entendre tourner à fond pour 3 fois rien.
J'ai donc installé cpufreqd sur mon PC...
Mais ce dernier refuse de se lancer, j'ai pourtant tenté de configurer
mon noyau correctement.
Voici d'ailleurs ce que me renvoie: $ cat /boot/config-2.6.18-ulysse
|grep FREQ

CONFIG_CPU_FREQ=y
CONFIG_CPU_FREQ_TABLE=y
CONFIG_CPU_FREQ_DEBUG=y
CONFIG_CPU_FREQ_STAT=y
CONFIG_CPU_FREQ_STAT_DETAILS=y
# CONFIG_CPU_FREQ_DEFAULT_GOV_PERFORMANCE is not set
CONFIG_CPU_FREQ_DEFAULT_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_PERFORMANCE=y
CONFIG_CPU_FREQ_GOV_POWERSAVE=y
CONFIG_CPU_FREQ_GOV_USERSPACE=y
CONFIG_CPU_FREQ_GOV_ONDEMAND=y
CONFIG_CPU_FREQ_GOV_CONSERVATIVE=y
CONFIG_X86_ACPI_CPUFREQ=m
# CONFIG_X86_CPUFREQ_NFORCE2 is not set
CONFIG_X86_ACPI_CPUFREQ_PROC_INTF=y

et là ce que me donne: $ cat /boot/config-2.6.18-ulysse |grep ACPI

CONFIG_ACPI=y
CONFIG_ACPI_SLEEP=y
CONFIG_ACPI_SLEEP_PROC_FS=y
CONFIG_ACPI_SLEEP_PROC_SLEEP=y
CONFIG_ACPI_AC=m
CONFIG_ACPI_BATTERY=m
CONFIG_ACPI_BUTTON=m
CONFIG_ACPI_VIDEO=m
# CONFIG_ACPI_HOTKEY is not set
CONFIG_ACPI_FAN=m
# CONFIG_ACPI_DOCK is not set
CONFIG_ACPI_PROCESSOR=m
CONFIG_ACPI_THERMAL=m
CONFIG_ACPI_ASUS=m
# CONFIG_ACPI_IBM is not set
# CONFIG_ACPI_TOSHIBA is not set
CONFIG_ACPI_BLACKLIST_YEAR=0
# CONFIG_ACPI_DEBUG is not set
CONFIG_ACPI_EC=y
CONFIG_ACPI_POWER=y
CONFIG_ACPI_SYSTEM=y
# CONFIG_ACPI_CONTAINER is not set
# CONFIG_ACPI_SBS is not set
CONFIG_X86_ACPI_CPUFREQ=m
CONFIG_X86_ACPI_CPUFREQ_PROC_INTF=y
CONFIG_HOTPLUG_PCI_ACPI=m
# CONFIG_HOTPLUG_PCI_ACPI_IBM is not set
CONFIG_PNPACPI=y


En revanche, je me suis apperçu que le module ACPI_FREQ n'était pas
lancé au démarrage, et lorsque je veux le lancer j'obtient ceci:
# modprobe acpi_cpufreq

FATAL: Error inserting acpi_cpufreq
(/lib/modules/2.6.18-ulysse/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko):
No such device



T'as quoi comme portable ? c'est peut être po acpi_cpufreq qu'il faut ms
intel speedstep...
Sinon en mettant en dur acpi_cpufreq ?


quelqu'un voit-il ce qui cloche???




Tcho
GiGGz


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Leon GRAY
Le #9464991
giggz wrote:
T'as quoi comme portable ?


[MaVie] Un Asus A6VC (c'est comme le A6VA mais avec une carte Nvidia au
lieu d'une ATI).[/MaVie]

c'est peut être po acpi_cpufreq qu'il faut ms
intel speedstep...



Effectivement, j'ai remi les CONFIG_CPU_FREQ en module (en mettant cette
fois ci "USERSPACE" comme choix par default) et j'ai fait un modprode
speedstep_centrino, et tout de suite il a arrété de raler.
J'ai ensuite relancé cpufreqd et maintenant c'est bon, il me gère bien
la frequence du processeur.

Merci beaucoup

P.S: En revanche le cpu n'a pas l'air de vouloir descendre en dessous de
1300 MHz (la fréquence max est 1,6GHz) ça fait pas une grosse baisse...
A suivre...


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
David Prévot
Le #9464981
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Leon GRAY a écrit :
[...]
P.S: En revanche le cpu n'a pas l'air de vouloir descendre en dessous de
1300 MHz (la fréquence max est 1,6GHz) ça fait pas une grosse baisse...
A suivre...



cat /sys/devices/system/cpu/cpu0/cpufreq/cpuinfo_min_freq
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.6 (GNU/Linux)

iD8DBQFFhZkU18/WetbTC/oRAuT2AJ9y+oMva4rBgJWdZGNWuxepSWbnGwCfYtDb
PuaV5fc59YT4eN0scAFwiyI =i4DX
-----END PGP SIGNATURE-----


--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench
Vous pouvez aussi ajouter le mot ``spam'' dans vos champs "From" et
"Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme