Twitter iPhone pliant OnePlus 11 PS5 Disney+ Orange Livebox Windows 11

Failed to start load kernel modules

2 réponses
Avatar
ajh-valmer
Bonjour =E0 tous,

J'ai ce message au boot de Stretch :
"Failed to start load kernel modules"
=E0 la suite d'un changement d'ordinateur.
Mais lequel ou lesquels module(s) ?

Je subodorre la carte graphique de la carte m=E8re,
que je n'utilise pas (donc module pas install=E9)
pour une carte graphique d=E9di=E9e =E0 la place ( fonctionnelle),
et/ou la carte r=E9seau ethernet non utilis=E9e, idem,
module pas install=E9, =E0 la place carte WiFi r=E9seau (fonctionnel).

Les modules non install=E9s seraient "NVIDIA Corporation MCP61 PCI"

Merci.

A. Valmer

2 réponses

Avatar
Pascal Hambourg
Le 19/01/2019 à 16:25, ajh-valmer a écrit :
J'ai ce message au boot de Stretch :
"Failed to start load kernel modules"
à la suite d'un changement d'ordinateur.
Mais lequel ou lesquels module(s) ?

Probablement un de ceux listés dans /etc/modules ou
/etc/modules-load.d/*. Je parierais sur un pilote de capteur de
température/tension/vitesse de ventilateur ajouté par lm-sensors pour
l'ordinateur précédent.
Peut-être plus de détails avec
service kmod status
Je subodorre la carte graphique de la carte mère,
que je n'utilise pas (donc module pas installé)
pour une carte graphique dédiée à la place ( fonctionnelle),
et/ou la carte réseau ethernet non utilisée, idem,
module pas installé, à la place carte WiFi réseau (fonctionnel).

Ces modules sont normalement chargés automatiquement lorsque le matériel
correspondant est détecté.
Les modules non installés seraient "NVIDIA Corporation MCP61 PCI"

Ce n'est pas la désignation d'un module mais d'un chipset de carte mère.
Avatar
Pascal Hambourg
Le 19/01/2019 à 22:21, ajh-valmer a écrit :
On Saturday 19 January 2019 18:52:28 Pascal Hambourg wrote:
Le 19/01/2019 à 16:25, ajh-valmer a écrit :
J'ai ce message au boot de Stretch :
"Failed to start load kernel modules"
à la suite d'un changement d'ordinateur.
Mais lequel ou lesquels module(s) ?


Probablement un de ceux listés dans /etc/modules ou
/etc/modules-load.d/*. Je parierais sur un pilote de capteur de
température/tension/vitesse de ventilateur ajouté par lm-sensors pour
l'ordinateur précédent.
Peut-être plus de détails avec
service kmod status


(...)
J'ai trouvé cette info, taper :
# systemctl status systemd-modules-load.service

Cette commande est équivalente à celle que j'avais indiquée ci-dessus
(qui fonctionne aussi sur les systèmes n'ayant pas systemd).
Je reçois :
Process:212
# journalctl -b _PID!2
Il s'agit du processus "coretemp".

"coretemp" n'est pas un processus, c'est un module du noyau. Sa
description indique :
# modinfo -d coretemp
Intel Core temperature monitor
Il ne convient donc pas si le processeur de la nouvelle machine n'est
pas un Intel Core. Certains modules se chargent sans erreur même si
aucun périphérique correspondant n'est présent, d'autres non. Celui-ci
fait visiblement partie de la seconde catégorie.
Le PID 212 mentionné par systemctl status est celui du processus
/lib/systemd/systemd-modules-load exécuté par le service
systemd-modules-load.service, ayant pour fonction de charger
statiquement les modules listés dans divers fichiers comme
/etc/modules-load.d/modules.conf.
Core Temp est un petit utilitaire très pratique qui affiche en
temps réel la température des cores de votre processeur.
Donc possible qu'il soit lié à un capteur de lm-sensors... ?

Je ne connais pas cet utilitaire "Core Temp", mais ce n'est pas la même
chose que le module du noyau "coretemp" qui provoquait l'erreur.
Si lm-sensors est installé, tu peux exécuter sensors-detect pour
rechercher les capteurs présents et ajouter les modules correspondants.
Tribune libre
Tribune en direct