Finder se trompe d'application !

Le
JPP
Bonsoir/bonjour

Ce sujet est mauvais, j'explique :
Sur un SSD APFS j'ai deux volumes HSierra.
Un volume de "travail" et un volume HS_Small avec le même HSierra brut
d'installation.

Booté sous le HSierra de "travail", si je clique sur un lien, le Safari
de ce volume se lance : normal.

MAIS, si le volume HS_Small est monté, le Finder m'informe que c'est la
première fois que je lance Safari etc.
Bref, il veut lancer le Safari de ce volume HS_Small au lieu du Safari
du volume de boot d'où je clique le lien.

Pas dérangeant, certes, il suffit de démonter HS_Small, mais bizarre.

Une explication, une solution ?
J'ai consulté ce que j'ai pu sur le net, relancé le Finder, lsregister
pour reset des LaunchServices et je ne sais plus quoi, sans résultat.

Mes volumes apparaissent ainsi :

/dev/disk1 (synthesized):
#: TYPE NAME SIZE IDENTIFIER
0: APFS Container Scheme - +499.9 GB disk1
Physical Store disk0s2
1: APFS Volume i27-SSD 177.1 GB disk1s1
2: APFS Volume Preboot 139.6 MB disk1s2
3: APFS Volume Recovery 3.1 GB disk1s3
4: APFS Volume VM 2.1 GB disk1s4
5: APFS Volume HS_Small 18.0 GB disk1s5
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Matt
Le #26547758
On dim. 31 mai 2020 (02:17),
JPP
Bonsoir/bonjour

Hello,
Une explication, une solution ?
J'ai consulté ce que j'ai pu sur le net, relancé le Finder, lsregister
pour reset des LaunchServices et je ne sais plus quoi, sans résultat.
Mes volumes apparaissent ainsi :
/dev/disk1 (synthesized):
#: TYPE NAME SIZE IDENTIFIER
0: APFS Container Scheme - +499.9 GB disk1
Physical Store disk0s2
1: APFS Volume i27-SSD 177.1 GB disk1s1
2: APFS Volume Preboot 139.6 MB disk1s2
3: APFS Volume Recovery 3.1 GB disk1s3
4: APFS Volume VM 2.1 GB disk1s4
5: APFS Volume HS_Small 18.0 GB disk1s5

Essayes avec lsregister et l'option « -u » pour retirer les applications
de la base LaunchServices, par exemple :
#v+
#!/bin/sh
LSREGISTER="/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister"
FLAGS="-u"
find /Volumes/HS_Small/Applications -name "*.app" -type d -print
| while IFS= read -r app; do
$LSREGISTER $FLAGS "$app"
i=$((i+1))
echo "$i applications unregistered."
done
#v-
Ne pas oublier de relancer le Finder pour appliquer les changements.
À noter qu'exclure /Volumes/HS_Small de Spotlight évite apparemment
l'ajout des applications de ce volume à la base LaunchServices, voir si
c'est effectivement le cas.
hth
--
<gege> : Genre t'as une copine ...
<Mr-Freezze> : Bah ouais mon Gégé , on peut sortir avec des meufs ailleurs
que dans Les Sims
* bashfr.org
JPP
Le #26547842
Bonjour Matt,
On 31/05/20 08:03, Matt wrote:

Essayes avec lsregister et l'option « -u » pour retirer les applications
de la base LaunchServices, par exemple :

Je note la recette au cas où MAIS :

À noter qu'exclure /Volumes/HS_Small de Spotlight évite apparemment
l'ajout des applications de ce volume à la base LaunchServices, voir si
c'est effectivement le cas.

Plus simple que la cuisine lsregister que j'ai déjà faite, peut être pas
avec les mêmes paramètres (une vielle recette à toi à propos d'icônes
incorrectes)
je monte mon volume HS_Small
Prefs/Spotlight : j'exclus HS_Small
et sans même fermer les prefs, je clique un .webloc ET :
c'est le Safari du disque de boot qui est lancé, comme il se doit !
---------------------
Pendant qu'on y est, autre plaisanterie de mon HSierra (maudit m'a-t-on
déjà dit ) : il y a quelques jours, je m'aperçois que, dans le Dock,
Firefox a perdu son icône, remplacée par l'icône par défaut pour les
applications ).
Je me souviens de cette histoire d'icônes incorectes, je fais lsregister
sans changement.
Je fouine le net, je suis rassuré, je ne suis pas seul MAIS; pas de
solution.
Soudain, illumination ;
je crée un alias de Firefox dans Applications, juste à côté de l'original,
je glisse cet alias dans le Dock : icône correcte !
--------------
Cela fait des mois que JB me dit que c'est le bronx entre Finder,
Spotlight, LaunchServices etc. : il n'a pas tort !!!
Désolé, mais : QUEL BORDEL !
Roi Dieu PurR=c3=aa M=c3=a9ta-Maitre en M=c3=a9ta-Science
Le #26547847
Le 01/06/2020 à 13:45:14, JPP a écrit :
Bonjour Matt,
On 31/05/20 08:03, Matt wrote:

Essayes avec lsregister et l'option « -u » pour retirer les applications
de la base LaunchServices, par exemple :

Je note la recette  au cas où MAIS :

À noter qu'exclure /Volumes/HS_Small de Spotlight évite apparemment
l'ajout des applications de ce volume à la base LaunchServices, voir si
c'est effectivement le cas.

Plus simple que la cuisine lsregister que j'ai déjà faite, peut être pas
avec les mêmes paramètres (une vielle recette à toi à propos d'icônes
incorrectes)
    je monte mon volume HS_Small
    Prefs/Spotlight : j'exclus HS_Small
et sans même fermer les prefs, je clique un .webloc  ET :
    c'est le Safari du disque de boot qui est lancé, comme il se doit !
---------------------
Pendant qu'on y est, autre plaisanterie de mon HSierra (maudit m'a-t-on
déjà dit ) : il y a quelques jours, je m'aperçois que,  dans le Dock,
Firefox a perdu son icône, remplacée par l'icône par défaut pour les
applications ).
Je me souviens de cette histoire d'icônes incorectes, je fais lsregister
sans changement.
Je fouine le net, je suis rassuré, je ne suis pas seul MAIS; pas de
solution.
Soudain, illumination ;
    je crée un alias de Firefox dans Applications, juste à côté de
l'original,
    je glisse cet alias dans le Dock : icône correcte !
--------------
Cela fait des mois que JB me dit que c'est le bronx entre Finder,
Spotlight, LaunchServices etc. : il n'a pas tort !!!
Désolé, mais : QUEL BORDEL !



depuis que j'utilise Mac OS X j'ai jamais eu ce genre de problème
par contre depuis Catalina, quand je veux ouvrir un dossier du disque
interne parfois il lance le disque externe ça met près de 10 à 15
secondes de ballon rond qui tourne sans que tu puisse rien faire...
depuis Catalina je dis bien avant ça ne le faisait que si j'ouvre un
dossier du disque externe...
--
/ Croire c'est le contraire de savoir,
-- o -- si j'y crois, je ne sais pas,
/ si je sais, pas la peine d'y croire.
--> Je Croix Pas, car Je Sais que c'est Faux MalgRê TouT...
JPP
Le #26547854
On 01/06/20 07:59, … wrote:
par contre depuis Catalina, quand je veux ouvrir un dossier du disque
interne parfois il lance le disque externe ça met près de 10 à 15
secondes de ballon rond qui tourne sans que tu puisse rien faire...
depuis Catalina je dis bien avant ça ne le faisait que si j'ouvre un
dossier du disque externe...

Sous HSierra, j'ai ça systématiquement avec un disque externe FireWire
connecté via un adaptateur TB.
Tant que le disque n'est pas en rotation, Mac bloqué,.
Roi Dieu PurR=c3=aa M=c3=a9ta-Maitre en M=c3=a9ta-Science
Le #26547853
Le 01/06/2020 à 15:06:23, JPP a écrit :
On 01/06/20 07:59, … wrote:
par contre depuis Catalina, quand je veux ouvrir un dossier du disque
interne parfois il lance le disque externe ça met près de 10 à 15
secondes de ballon rond qui tourne sans que tu puisse rien faire...
depuis Catalina je dis bien avant ça ne le faisait que si j'ouvre un
dossier du disque externe...

Sous HSierra, j'ai ça systématiquement avec un disque externe FireWire
connecté via un adaptateur TB.
Tant que le disque n'est pas en rotation, Mac bloqué,.

depuis Catalina c'était tellement fréquent que je m'en suis aperçu que
c'était trop souvent par rapport à avant dans la même configuration de
disques...
--
/ Croire c'est le contraire de savoir,
-- o -- si j'y crois, je ne sais pas,
/ si je sais, pas la peine d'y croire.
--> Je Croix Pas, car Je Sais que c'est Faux MalgRê TouT...
Matt
Le #26547860
On lun. 01 juin 2020 (13:45),
JPP
Bonjour Matt,

Hello JPP,
Plus simple que la cuisine lsregister que j'ai déjà faite, peut être
pas avec les mêmes paramètres (une vielle recette à toi à propos
d'icônes incorrectes)
je monte mon volume HS_Small
Prefs/Spotlight : j'exclus HS_Small
et sans même fermer les prefs, je clique un .webloc ET : c'est le
Safari du disque de boot qui est lancé, comme il se doit !
---------------------
Pendant qu'on y est, autre plaisanterie de mon HSierra (maudit m'a-t-on
déjà dit ) : il y a quelques jours, je m'aperçois que, dans le Dock,
Firefox a perdu son icône, remplacée par l'icône par défaut pour les
applications ).

Ah oui en effet après recherche dans mes archives, l'exclusion dans
Spotlight du volume permet de couper court l'enregistrement dans
LaunchServices :)
Je me souviens de cette histoire d'icônes incorectes, je fais
lsregister sans changement. Je fouine le net, je suis rassuré, je ne
suis pas seul MAIS; pas de solution. Soudain, illumination ;
je crée un alias de Firefox dans Applications, juste à côté de
l'original, je glisse cet alias dans le Dock : icône correcte !
--------------
Cela fait des mois que JB me dit que c'est le bronx entre Finder,
Spotlight, LaunchServices etc. : il n'a pas tort !!!
Désolé, mais : QUEL BORDEL !

Pas de soucis. Depuis 10.13 je n'ai plus jamais eu de soucis avec
LaunchServices comme quoi (mais j'étais parti d'une installation
complète du système avec restauration des données personnelles avec
l'assistant de migration et une archive Time Machine).
--
Truckee: bon moi je vais sortir le monstre
Sebio: t'emmènes ta copine au resto?
* bashfr.org
Poster une réponse
Anonyme