[Firefox] accents

Le
Leonick
Bonjour,
J'ai un problème avec les caractères accentués dans les titres des pages avec
FF.
Il s'affiche correctement dans la barre de titres, mais quand je fais "envoyer
la page", les caractères sont remplaçés par d'autres symboles.
Par exemple, le mot "récit" est remplaçé par "récits", alors que dans le
marque-pages cela fonctionne correctement.
De même, quand dans la recherche google, je tape "récit", il est envoyé "r?cit"
à google, c'est très génant.
Est-ce normal (un bug connu quoi) ?

Merci

Leonick
http://bike-and-rain-en-irlande.champignytriathlon.org les photos et le récit
d'une ballade cyclotouristique en Irlande
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Fred Bezies
Le #10872741
Le 08.05.2004 14:20, Leonick nous a dit :

Bonjour,
J'ai un problème avec les caractères accentués dans les titres des pages avec
FF.
Il s'affiche correctement dans la barre de titres, mais quand je fais "envoyer
la page", les caractères sont remplaçés par d'autres symboles.
Par exemple, le mot "récit" est remplaçé par "récits", alors que dans le
marque-pages cela fonctionne correctement.



Un problème d'encodage donc.

De même, quand dans la recherche google, je tape "récit", il est envoyé "r?cit"
à google, c'est très génant.



En effet. Essaye de jeter un oeil (traduction littérable de ma version
anglaise) dans Voir / Encodage.

Est-ce normal (un bug connu quoi) ?



Des sites qui mettent un mauvais encodage ? ;o)


Merci



De rien ;o)

--
Frédéric Béziès -

Site Perso : http://perso.wanadoo.fr/frederic.bezies/
Weblog : http://www.u-blog.net/fredb/
Fourre-tout : http://perso.wanadoo.fr/frederic.bezies/pratique/
Leonick
Le #10872731
"Fred Bezies" news:c7imnh$vie$
Le 08.05.2004 14:20, Leonick nous a dit :

> Bonjour,
> J'ai un problème avec les caractères accentués dans les titres des pages


avec
> FF.
> Il s'affiche correctement dans la barre de titres, mais quand je fais


"envoyer
> la page", les caractères sont remplaçés par d'autres symboles.
> Par exemple, le mot "récit" est remplaçé par "récits", alors que dans le
> marque-pages cela fonctionne correctement.

Un problème d'encodage donc.



Pour cette page,
http://www.champignytriathlon.org/courses/2004/etampes2004_cc.htm "Valid HTML
4.01", dont le titre contient "récit", ça ne fonctionne pas, pourtant tout
s'affiche bien dans la barre des titres et ausi dans les marques pages.


> De même, quand dans la recherche google, je tape "récit", il est envoyé


"r?cit"
> à google, c'est très génant.

En effet. Essaye de jeter un oeil (traduction littérable de ma version
anglaise) dans Voir / Encodage.

> Est-ce normal (un bug connu quoi) ?

Des sites qui mettent un mauvais encodage ? ;o)



Effectivement, je n'avais pas pensé à cette éventualité venant de google. La
page de recherche de google n'est pas validée. Il n'y a pas de doc-type entre
autres.

Leonick
loufoque
Le #10872661
Leonick wrote:

mais quand je fais "envoyer
la page"



"Envoyer la page" ? Qu'est-ce que cette chose ?
Leonick
Le #10872631
"loufoque" news:c7isbe$2uh$
Leonick wrote:

> mais quand je fais "envoyer
> la page"

"Envoyer la page" ? Qu'est-ce que cette chose ?



En fait, ça permet d'envoyer l'URL de la page en cours. Dans FF version
Française, cest juste en dessous "fichier / enregistrer sous..."

Leonick
Zorg
Le #10872571
Pour certains sites, je suis obligé d'activer ce paramètre :
"View/Character Encoding/AutoDetect/Universal"

Ton site semble ok chez moi, avec un FF 0.8+ (Nighly Build 02/05)
a+
Anthony/Zorg
Leonick
Le #10872561
"Zorg" news:409e0bd8$0$13073$
Pour certains sites, je suis obligé d'activer ce paramètre :
"View/Character Encoding/AutoDetect/Universal"

Ton site semble ok chez moi, avec un FF 0.8+ (Nighly Build 02/05)
a+
Anthony/Zorg



En fait avec ou sans cette option, cela ne change rien.
Dans les marque page, c'est ok, en ligne de titre aussi, mais avec envoyer la
page, ça ne passe plus.

De même pour la recherche sur google, quand on tape "récit" dans la barre moteur
de recherche.

Leonick
http://bike-and-rain-en-irlande.champignytriathlon.org les photos et le récit
d'une ballade cyclotouristique en Irlande
Jean-Marc Molina
Le #11090261
Bonjour,

J'ai un problème avec les caractères accentués dans les titres des pages


avec
FF.

Tu tournes avec un Firefox français. Oui je suis devin :).
Donc quand tu rentres « récit » dans le champ de recherche, Google, te sort
un « r´®o´~{^´~cit » ? ^^.
Comme certains en parlent il doit s'agit d'un problème d'encodage mais je ne
sais pas trop où changer cela dans Firefox. J'ai réinstaller un Firefox
anglais pour que tout rentre dans l'ordre, de même pour un problème avec
l'extension SessionSaver (voir message « [Firefox] Test de l'extension
SessionSaver sur un Firefox français »).

JM
Publicité
Poster une réponse
Anonyme