[FL 2004] Police Champs HTML ?

Le
eRom
Bonjour ? tous,

Voil?, c'est une des premi?res fois que je travaille avec des typos impos?e et
j'avoue avoir un peu de mal
Voil? mon probl?me :
- 1 champs dynamique format HTML
- 1 fichier XML

Je remplis mon textfield avec les valeurs du fichier XML - Ok
Le champs est au format HTML afin de pouvoir inserer dynamiquement des liens
(sur des termes pr?cis balis? dans le XML) vers une fonction Flash - Ok
J'ai une typo impos?e (ex : GillSans).

Je voudrais pouvoir inclure la typo dans mon SWF afin que celui-ci soit
lisible partout (Mac/Pc) ainsi que sur les machines o? la typo n'est pas
install?e.
quand le textfield n'est pas au format HTML, pas de problemes, j'inclus mes
jeux de carat?res dans le panneau "propri?t?s" du champ.
Mais d?s que je passe au format HTML, rien ne s'affiche plus.

J'espere avoir ?t? assez clair..merci d'avance
@+
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
eRom
Le #17160351
Bon et bien il me semble avoir trouv? la solution, un peu bizarre je trouve....

En fait je ne d?fini pas mon champs comme un champs au format HTML (dans
l'environnement de Flash). juste un champs de type "dynamique"/
Je lui d?fini donc un jeu de caract?res ? incorporer et ensuite je lui
applique le contenu que je veux vie

monClip.htmlText = ...........

Les liens fonctionnent nickel et ma police est bien visible sur toutes les
plates-formes m?me sans la typo....

En tout cas merci......@+
Publicité
Poster une réponse
Anonyme