Flonflon

Le
Jo Engo
Bon, je n'ai toujours pas de son mais c'est normal vu que je n'ai pas
fait grand chose.

J'ai un problème avec les tests :

# J'arrête pulseaudio et pulseaudio-socket

systemctl --user stop pulseaudio && systemctl --user stop
pulseaudio.socket

# Jusque là tout va bien

# je lance le bruit blanc

aplay -D hw:0 -f S16_LE -c 2 -r 48000 /dev/urandom
aplay: main:828: erreur à l'ouverture audio: Périphérique ou ressource
occupé
abdallah@poupon-la-peste:~$ ls /dev|grep dsp
adsp
dsp
abdallah@poupon-la-peste:~$ lsof|grep dsp
abdallah@poupon-la-peste:~$


Quel peut être ce périphérique ou cette ressource occupée et par qui (vu
que c'est pas pulse) si ce n'est pas /dev/dsp ? Comment trouver le
processus dans ces conditions ?

Merci de vos lampadaires.

--
Plus le mensonge est énorme, plus les gens y croient.
-+- Joseph Goebbles (1897-1945) -+-
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Nicolas George
Le #26486516
Jo Engo , dans le message
:~$ ls /dev|grep dsp
adsp
dsp

/dev/dsp est l'émulation d'OSS par le noyau, pour les applications plus
que périmées.
Quel peut être ce périphérique ou cette ressource occupée et par qui (vu
que c'est pas pulse) si ce n'est pas /dev/dsp ? Comment trouver le
processus dans ces conditions ?

/dev/snd/*
Jo Engo
Le #26486785
Le Sun, 26 Aug 2018 18:53:58 +0000, Nicolas George a écrit :
/dev/snd/*


lsof|grep /dev/snd ne donne rien non plus :/
--
Mieux vaut vivre enchaîné près de celui que l'on aime,
que libre au milieu des jardins près de celui que l'on hait.
-+- Proverbe persan -+-
Jo Engo
Le #26486963
Le Sun, 26 Aug 2018 16:03:02 +0000, Jo Engo a écrit :
Bon, je n'ai toujours pas de son mais c'est normal vu que je n'ai pas
fait grand chose.


Bon, bon bref, j'ai testé (enfin !) avec un system live(*) et c'est aussi
le silence, La carte a pourtant bien l'air d'être reconnue ce qui me fait
bougrement pencher vers un problème matériel.
J'ai un dernier test à faire vu que c'est du BIOS pur jus, voir si le son
n'est pas désactivé au niveau du bios. C'est possible ?
(*) uname -a me dit 'Linux mint 4.15.0-20-generic #21-Ubuntu SMTP Tue Apr
24 06:16:15 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux
--
L'esprit, c'est l'inverse de l'argent, moins on en a, plus on est
heureux.
-+- Voltaire -+-
Publicité
Poster une réponse
Anonyme