[FMX] relance d'un mp3 externe

Le
Alex
Bonjour,

Dans une animation flash, j'ai un bouton qui charge un mp3 externe avec la
fonction "LoadSound" et un bouton qui pause le son en renvoyant la position
du son. Jusqu'à là cela marche bien. J'ai un 3ème bouton qui doit permettre
de relancer ce son là où il s'est arrêté mais là cela ne marche pas.
Quelqu'un aurait-il une idée ?
Merci bien
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Romuald
Le #16842461
Salut,

Que fais-tu pour relancer le son ?

Avec un son.start cela devrait marcher si tu places en premier paramètre la
position récupérée lors du pause...

monSon.start(décalageSecondes, 1);

Romuald.


"Alex" c1vm4g$r6h$
Bonjour,

Dans une animation flash, j'ai un bouton qui charge un mp3 externe avec la
fonction "LoadSound" et un bouton qui pause le son en renvoyant la


position
du son. Jusqu'à là cela marche bien. J'ai un 3ème bouton qui doit


permettre
de relancer ce son là où il s'est arrêté mais là cela ne marche pas.
Quelqu'un aurait-il une idée ?
Merci bien




Alex
Le #16842421
C'est exactement ce que je fais mais cela ne marche pas.
J'ai lu quelque part que c'état un problème de version de player. Alors
bêtement j'ai mis à jour mon player mais rien n'y fait. Scrongneugneu !

Merci quand même pour ta réponse.
---------
a l e x


"Romuald" c21g40$ac4$
Salut,

Que fais-tu pour relancer le son ?

Avec un son.start cela devrait marcher si tu places en premier paramètre


la
position récupérée lors du pause...

monSon.start(décalageSecondes, 1);

Romuald.


"Alex" c1vm4g$r6h$
> Bonjour,
>
> Dans une animation flash, j'ai un bouton qui charge un mp3 externe avec


la
> fonction "LoadSound" et un bouton qui pause le son en renvoyant la
position
> du son. Jusqu'à là cela marche bien. J'ai un 3ème bouton qui doit
permettre
> de relancer ce son là où il s'est arrêté mais là cela ne marche pas.
> Quelqu'un aurait-il une idée ?
> Merci bien
>
>




Romuald
Le #16842351
Salut,

le problème est peut etre en amont, fais-tu un trace de ce que te renvoi le
bouton pause pour savoir si la valeur est valide ?

Romuald.

"Alex" c22cb1$oet$

C'est exactement ce que je fais mais cela ne marche pas.
J'ai lu quelque part que c'état un problème de version de player. Alors
bêtement j'ai mis à jour mon player mais rien n'y fait. Scrongneugneu !

Merci quand même pour ta réponse.
---------
a l e x


Alex
Le #16842341
Le "Trace" renvoie la bonne position.
Si je te file le .fla, tu penses que tu pourrais l'examiner ?
Merci pour ton aide.


-----------
a l e x
Alex
Le #16842331
Je crois que j'ai trouvé le problème. Il semblerait que l'on ne puisse pas
relancer un mp3 externe s'il est chargé en streaming.
En chargeant le son en tant que "event sound" cela marche.
Dommage que cela ne marche pas en "streaming sound". Y'a peut-être une ruse
à connaître ???
---------
a l e x
Publicité
Poster une réponse
Anonyme