FormulaLocal et autres

Le
Annie
Bonjour,

Dans une macro en VBA, je dsire placer une formule dans
une cellule. J'ai de la difficult saisir la diffrence
entre FormulaLocal, FormulaR1C1, etc. Laquelle je dois
utiliser?

galement, une de mes formules que je dois ajouter dans
une cellule contient une rfrence une autre feuille du
classeur. Est-ce que cela peut m'occasionner un
problme? Si oui, comment puis-je le contourner?

Merci l'avances pour vos bonnes suggestions
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ru-th
Le #1232397
Salut

AMHA,
oublies formular1c1
formulalocal te permet de mettre en français le nom des formule
range("B1").formulalocal="=somme(a1:a10)"
formula tout court nécessite les noms de fonction en anglais
Range("c1").Formula = "=sum(a1:a10)"

a+
rural thierry

"Annie" news: 18f2c01c41bdd$6956b8f0$
Bonjour,

Dans une macro en VBA, je désire placer une formule dans
une cellule. J'ai de la difficulté à saisir la différence
entre FormulaLocal, FormulaR1C1, etc. Laquelle je dois
utiliser?

Également, une de mes formules que je dois ajouter dans
une cellule contient une référence à une autre feuille du
classeur. Est-ce que cela peut m'occasionner un
problème? Si oui, comment puis-je le contourner?

Merci à l'avances pour vos bonnes suggestions
isabelle
Le #1232221
bonjour Annie,

voici trois façons d'écrire la formule somme de la plage A1:A10 de
Feuill2

Range("C1").FormulaR1C1 = "=SUM(Feuil2!RC[-2]:R[9]C[-2])"
Range("C1").FormulaLocal = "=Somme(Feuil2!A1:A10)"
Range("C1").Formula = "=Sum(Feuil2!A1:A10)"

la méthode FormulaLocal a comme avantage d'écrire la formule "Somme" en
français et de pouvoir utiliser une référence de type A1 au lieu de RC.

isabelle


Bonjour,

Dans une macro en VBA, je désire placer une formule dans
une cellule. J'ai de la difficulté à saisir la différence
entre FormulaLocal, FormulaR1C1, etc. Laquelle je dois
utiliser?

Également, une de mes formules que je dois ajouter dans
une cellule contient une référence à une autre feuille du
classeur. Est-ce que cela peut m'occasionner un
problème? Si oui, comment puis-je le contourner?

Merci à l'avances pour vos bonnes suggestions


Pascal Engelmajer
Le #1228966
Salut,
1)
FormulaLocal c'est par exemple SOMME
FormulaR1C1 c'est alors SUM
2)
Non pas spécialement
--
Amicalement.
Pascal
"il n'y a pas de vent favorable pour celui qui ne sait pas ou il va."
Sénèque.
http://www.ilyapa.net/excel
"Annie" news: 18f2c01c41bdd$6956b8f0$
Bonjour,

Dans une macro en VBA, je désire placer une formule dans
une cellule. J'ai de la difficulté à saisir la différence
entre FormulaLocal, FormulaR1C1, etc. Laquelle je dois
utiliser?

Également, une de mes formules que je dois ajouter dans
une cellule contient une référence à une autre feuille du
classeur. Est-ce que cela peut m'occasionner un
problème? Si oui, comment puis-je le contourner?

Merci à l'avances pour vos bonnes suggestions
Annie
Le #1228965
Merci Isabelle, tu as éclairé ma lanterne!

Cependant, j'ai un problème avec ma référence à une autre
feuille. J'ai le code suivant:

Range("R2").FormulaLocal = "=SI(Q2-'Compagnie'!
I2=0;"";"!")"

Je reçois toujours le message suivant:

Erreur de compilation:
Attendu: fin d'instruction

Qu'est-ce qui ne fonctionne pas dans ma formule?

Merci beaucoup
-----Message d'origine-----
Bonjour,

Dans une macro en VBA, je désire placer une formule dans
une cellule. J'ai de la difficulté à saisir la
différence

entre FormulaLocal, FormulaR1C1, etc. Laquelle je dois
utiliser?

Également, une de mes formules que je dois ajouter dans
une cellule contient une référence à une autre feuille du
classeur. Est-ce que cela peut m'occasionner un
problème? Si oui, comment puis-je le contourner?

Merci à l'avances pour vos bonnes suggestions
.



Annie
Le #1228964
Merci beaucoup!

-----Message d'origine-----
Salut

AMHA,
oublies formular1c1
formulalocal te permet de mettre en français le nom des
formule

range("B1").formulalocal="=somme(a1:a10)"
formula tout court nécessite les noms de fonction en
anglais

Range("c1").Formula = "=sum(a1:a10)"

a+
rural thierry

"Annie" dans le message de

news: 18f2c01c41bdd$6956b8f0$
Bonjour,

Dans une macro en VBA, je désire placer une formule dans
une cellule. J'ai de la difficulté à saisir la différence
entre FormulaLocal, FormulaR1C1, etc. Laquelle je dois
utiliser?

Également, une de mes formules que je dois ajouter dans
une cellule contient une référence à une autre feuille du
classeur. Est-ce que cela peut m'occasionner un
problème? Si oui, comment puis-je le contourner?

Merci à l'avances pour vos bonnes suggestions


.



Annie
Le #1228792
Merci beaucoup pour les réponses.

-----Message d'origine-----
Salut,
1)
FormulaLocal c'est par exemple SOMME
FormulaR1C1 c'est alors SUM
2)
Non pas spécialement
--
Amicalement.
Pascal
"il n'y a pas de vent favorable pour celui qui ne sait
pas ou il va."

Sénèque.
http://www.ilyapa.net/excel
"Annie" dans le message de

news: 18f2c01c41bdd$6956b8f0$
Bonjour,

Dans une macro en VBA, je désire placer une formule dans
une cellule. J'ai de la difficulté à saisir la différence
entre FormulaLocal, FormulaR1C1, etc. Laquelle je dois
utiliser?

Également, une de mes formules que je dois ajouter dans
une cellule contient une référence à une autre feuille du
classeur. Est-ce que cela peut m'occasionner un
problème? Si oui, comment puis-je le contourner?

Merci à l'avances pour vos bonnes suggestions


.



Pascal Engelmajer
Le #1228790
Salut,
c'est le Rem caractère(') qui interompt la ligne
Range("R2").FormulaLocal = "=SI(Q2-Compagnie!I2=0;"";"!")"

--
Amicalement.
Pascal
"il n'y a pas de vent favorable pour celui qui ne sait pas ou il va."
Sénèque.
http://www.ilyapa.net/excel
"Annie" news: 1615e01c41be1$7bfb8810$
Merci Isabelle, tu as éclairé ma lanterne!

Cependant, j'ai un problème avec ma référence à une autre
feuille. J'ai le code suivant:

Range("R2").FormulaLocal = "=SI(Q2-'Compagnie'!
I2=0;"";"!")"

Je reçois toujours le message suivant:

Erreur de compilation:
Attendu: fin d'instruction

Qu'est-ce qui ne fonctionne pas dans ma formule?

Merci beaucoup
-----Message d'origine-----
Bonjour,

Dans une macro en VBA, je désire placer une formule dans
une cellule. J'ai de la difficulté à saisir la
différence

entre FormulaLocal, FormulaR1C1, etc. Laquelle je dois
utiliser?

Également, une de mes formules que je dois ajouter dans
une cellule contient une référence à une autre feuille du
classeur. Est-ce que cela peut m'occasionner un
problème? Si oui, comment puis-je le contourner?

Merci à l'avances pour vos bonnes suggestions
.



isabelle
Le #1228787
re bonjour Annie,

c'est bizarre ce truc, en anglais ça passe bien mais pas en français.

Range("R1").FormulaLocal = "=SI('Q2-Compagnie'!I2=0,"""",""!"")"

Range("R2").Formula = "=IF('Q2-Compagnie'!I2=0,"""",""!"")"

isabelle


Merci Isabelle, tu as éclairé ma lanterne!

Cependant, j'ai un problème avec ma référence à une autre
feuille. J'ai le code suivant:

Range("R2").FormulaLocal = "=SI(Q2-'Compagnie'!
I2=0;"";"!")"

Je reçois toujours le message suivant:

Erreur de compilation:
Attendu: fin d'instruction

Qu'est-ce qui ne fonctionne pas dans ma formule?

Merci beaucoup
-----Message d'origine-----
Bonjour,

Dans une macro en VBA, je désire placer une formule dans
une cellule. J'ai de la difficulté à saisir la
différence

entre FormulaLocal, FormulaR1C1, etc. Laquelle je dois
utiliser?

Également, une de mes formules que je dois ajouter dans
une cellule contient une référence à une autre feuille du
classeur. Est-ce que cela peut m'occasionner un
problème? Si oui, comment puis-je le contourner?

Merci à l'avances pour vos bonnes suggestions
.





Annie
Le #1228785
Salut!

J'ai enlevé le caractère ' mais ça ne fonctionne toujours
pas, on dirait que c'est mon point d'exlamation ("!") à la
fin de ma formule qui fait planter ma ligne...

Est-ce que ça se peut?
-----Message d'origine-----
Salut,
c'est le Rem caractère(') qui interompt la ligne
Range("R2").FormulaLocal = "=SI(Q2-Compagnie!I2=0;"";"!")"

--
Amicalement.
Pascal
"il n'y a pas de vent favorable pour celui qui ne sait
pas ou il va."

Sénèque.
http://www.ilyapa.net/excel
"Annie" dans le message de

news: 1615e01c41be1$7bfb8810$
Merci Isabelle, tu as éclairé ma lanterne!

Cependant, j'ai un problème avec ma référence à une autre
feuille. J'ai le code suivant:

Range("R2").FormulaLocal = "=SI(Q2-'Compagnie'!
I2=0;"";"!")"

Je reçois toujours le message suivant:

Erreur de compilation:
Attendu: fin d'instruction

Qu'est-ce qui ne fonctionne pas dans ma formule?

Merci beaucoup
-----Message d'origine-----
Bonjour,

Dans une macro en VBA, je désire placer une formule dans
une cellule. J'ai de la difficulté à saisir la
différence

entre FormulaLocal, FormulaR1C1, etc. Laquelle je dois
utiliser?

Également, une de mes formules que je dois ajouter dans
une cellule contient une référence à une autre feuille du
classeur. Est-ce que cela peut m'occasionner un
problème? Si oui, comment puis-je le contourner?

Merci à l'avances pour vos bonnes suggestions
.




.




Annie
Le #1228592
Merci beaucoup Isabelle,

Tout fonctionne maintenant!

-----Message d'origine-----
re bonjour Annie,

c'est bizarre ce truc, en anglais ça passe bien mais pas
en français.


Range("R1").FormulaLocal = "=SI('Q2-Compagnie'!
I2=0,"""",""!"")"


Range("R2").Formula = "=IF('Q2-Compagnie'!
I2=0,"""",""!"")"


isabelle


Merci Isabelle, tu as éclairé ma lanterne!

Cependant, j'ai un problème avec ma référence à une
autre


feuille. J'ai le code suivant:

Range("R2").FormulaLocal = "=SI(Q2-'Compagnie'!
I2=0;"";"!")"

Je reçois toujours le message suivant:

Erreur de compilation:
Attendu: fin d'instruction

Qu'est-ce qui ne fonctionne pas dans ma formule?

Merci beaucoup
-----Message d'origine-----
Bonjour,

Dans une macro en VBA, je désire placer une formule
dans



une cellule. J'ai de la difficulté à saisir la
différence

entre FormulaLocal, FormulaR1C1, etc. Laquelle je dois
utiliser?

Également, une de mes formules que je dois ajouter dans
une cellule contient une référence à une autre feuille
du



classeur. Est-ce que cela peut m'occasionner un
problème? Si oui, comment puis-je le contourner?

Merci à l'avances pour vos bonnes suggestions
.

.







Publicité
Poster une réponse
Anonyme