Formule Excel 2010

Le
Maieh Hors ligne
Bonjour,
Je bloque sur une formule et j’ai besoin de votre aide.
J’ai un tableau ou j’ai plusieurs fournisseurs et plusieurs pays. Je voudrais avoir le nombre de fournisseurs qui travaillent exclusivement avec un seul pays.
Par avance, merci
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Jacquouille
Le #26468272
Bonjour,
Certains virtuoses du clavier vont proposer une formule (fort bonne) avec
très certainement un peu de Somme.SI.
Perso, je reste fidèle à mon Sommeprod (de Excel 4), qui se valide d'un seul
doigt avec "enter"
où A1:A10 = pays
B1:B10 = nom du fournisseur
=Sommeprod((A1:A10="Moldavie")*(B1:B10))
Jacques XL MM III
" Le vin est au repas ce que le parfum est à la femme."
.
"Maieh" a écrit dans le message de groupe de discussion :

Bonjour,
Je bloque sur une formule et j’ai besoin de votre aide.
J’ai un tableau ou j’ai plusieurs fournisseurs et plusieurs pays. Je
voudrais
avoir le nombre de fournisseurs qui travaillent exclusivement avec un seul
pays.
Par avance, merci
Michd
Le #26468283
Bonjour Jacquouille,
Tu veux dire ceci :
où A1:A10 = pays
B1:B10 = nom du fournisseur
=Sommeprod((A1:A10="Moldavie")*(B1:B10="Nom Du Fournisseur"))
Dans la formule, on peut remplacer "Moldavie" et "Nom du fournisseur" par
une adresse de cellule.
MichD
Jacquouille
Le #26468298
Bonjour Denis,
Je pense que la sémantique exacte de la question est :
" Je voudrais avoir le nombre de fournisseurs qui travaillent exclusivement
avec un seul
pays."
Je pense que ta solution donnera le nombre de fois que "un tel fournisseur"
pour la Moldavie.
Peut-être le Questionneur précisera-t-il?
Maintenant, un bon TCD fera aussi très bien l'affaire.
Bonne fin de journée
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Michd" a écrit dans le message de groupe de discussion :
p8ogrk$u8k$
Bonjour Jacquouille,
Tu veux dire ceci :
où A1:A10 = pays
B1:B10 = nom du fournisseur
=Sommeprod((A1:A10="Moldavie")*(B1:B10="Nom Du Fournisseur"))
Dans la formule, on peut remplacer "Moldavie" et "Nom du fournisseur" par
une adresse de cellule.
MichD
Jacquouille
Le #26468307
... et en fait, on peut aussi comprendre ceci:" le nombre de fournisseurs
qui travaillent exclusivement avec un seul pays."
Auquel cas: =sommeprod((a1:a10)*(b1:b10="nom du fournisseur"))
formule à recopier autant de fois qu'il y a de fournisseur.
Ensuite, =nb.si(x1:x10=1) où x1:x10 = colonne dans laquelle on a calculé les
Sommeprod.
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Jacquouille" a écrit dans le message de groupe de discussion :
p8okks$1pt9$
Bonjour Denis,
Je pense que la sémantique exacte de la question est :
" Je voudrais avoir le nombre de fournisseurs qui travaillent exclusivement
avec un seul
pays."
Je pense que ta solution donnera le nombre de fois que "un tel fournisseur"
pour la Moldavie.
Peut-être le Questionneur précisera-t-il?
Maintenant, un bon TCD fera aussi très bien l'affaire.
Bonne fin de journée
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Michd" a écrit dans le message de groupe de discussion :
p8ogrk$u8k$
Bonjour Jacquouille,
Tu veux dire ceci :
où A1:A10 = pays
B1:B10 = nom du fournisseur
=Sommeprod((A1:A10="Moldavie")*(B1:B10="Nom Du Fournisseur"))
Dans la formule, on peut remplacer "Moldavie" et "Nom du fournisseur" par
une adresse de cellule.
MichD
Michd
Le #26468311
Bonjour,
2 plages nommées : Fournisseurs et Pays , chaque nom représente le même
nombre de lignes dans leur colonne respective.
suggestions 2 exemples :
=SOMMEPROD((Pays="NomDuPays")*(Fournisseurs<>""))
OU celle-ci qui requiert une validation matricielle :
=SOMME(SI(((Pays="toto1")*(Fournisseurs<>""))=1;1))
MichD
Publicité
Poster une réponse
Anonyme