Twitter iPhone pliant OnePlus 12 PS5 Disney+ Orange Livebox Windows 11 ChatGPT

Formule pour extraire un caractère (plusieurs fois le même) dans un texte

5 réponses
Avatar
Roland Miller
Bonjour,

je cherche =E2=80=A6 mais sans vraiment le r=C3=A9sultat souhait=C3=A9.

Par exemple j'ai le texte "(D=C3=A9ficit)"

Comment par une formule avoir "D=C3=A9ficit"?

Merci =C3=A0 l'avance.

5 réponses

Avatar
MichD
Le 25/09/19 à 13:05, Roland Miller a écrit :
Bonjour,
je cherche … mais sans vraiment le résultat souhaité.
Par exemple j'ai le texte "(Déficit)"
Comment par une formule avoir "Déficit"?
Merci à l'avance.

Bonjour,
Je ne suis pas sûr de comprendre ta question :
Si tu veux savoir si une expression est présente dans une cellule
donnée, cette fonction retourne la position de départ où elle se trouve
dans le texte. La recherche se fait seulement dans la cellule A1.
=SIERREUR(CHERCHE("Déficit";A1;1);"expression non présente")
Identique à la fonction précédente, mais ici, la fonction "Trouve" tient
compte de la casse de l'expression recherchée
=SIERREUR(CHERCHE("Déficit";A1;1);"expression non présente")
Ici, le texte "déficit" est retourné s'il est présent dans la cellule :
=STXT(A1;CHERCHE("Déficit";A1;1);NBCAR("Déficit"))
MichD
Avatar
Jacquouille
Bonsoir
Si j'ai bien compris, tu veux supprimer les parenthèses ()?
Pourquoi ne pas utiliser la fonction remplacer "(" puis ")" remplacer par
rien ""
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Roland Miller" a écrit dans le message de groupe de discussion :
Bonjour,
je cherche … mais sans vraiment le résultat souhaité.
Par exemple j'ai le texte "(Déficit)"
Comment par une formule avoir "Déficit"?
Merci à l'avance.
Avatar
Jacky
Bonjour à tous
Esaaye
Avec le mot en A1
=SUBSTITUE(SUBSTITUE(A1;"(";"");")";"")
Avatar
Jacquouille
Salut Jacky,
Comment ça va, dans le Grand Est ?
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.
"Jacky" a écrit dans le message de groupe de discussion :
qn8aui$sc8$
Bonjour à tous
Esaaye
Avec le mot en A1
=SUBSTITUE(SUBSTITUE(A1;"(";"");")";"")
Avatar
Jacky
Hello Jacques
Ca va, ca va.....
Le poids de l’âge (l’autre aussi d’ailleurs) se fait ressentir dans les
articulations
Je suis juste de passage sur ce faux rhum, que je ne fréquente plus
très souvent.
Je vois que Denis que je salue, est toujours très actif. Il doit se
sentir un peu seul. ;o))
Bonne continuation.
Bise à ton épouse.
Amitié.
Jacky
Jacquouille a utilisé son clavier pour écrire :
Salut Jacky,
Comment ça va, dans le Grand Est ?
Jacques
" Le vin est au repas ce que le parfum est à la femme."
.