[FreeBSD 6.0] : Problèmes avec pkgdb lors de la mise à jour vers GNOME 2.14

Le
NoSpamCity
Bonjour à tous,

Désolé de ces questions de newbie sous FreeBSD.

J'essaie d'upgrader GNOME 2.12 vers GNOME 2.14, en suivant
les instructions ici : http://www.freebsd.org/gnome/docs/faq2.html#q6

Après avoir mis à jour avec succès l'arbre des ports avec CVSup,
j'ai vérifier l'opératon avec pkgdb -fF et j'obtiens des messages
d'erreurs que je ne sais pas traiter (dans l'exemple ci-dessous,
j'ai utilisé l'option -a seulement pour afficher toutes les
erreurs rencontrées) :

chre# uname -a
FreeBSD chre.chre 6.0-RELEASE FreeBSD 6.0-RELEASE #0: Thu Nov 3
09:36:13 UTC 20
05 root@x64.samsco.home:/usr/obj/usr/src/sys/GENERIC i386
chre# pkgdb -aF
> Checking the package registry database
Stale dependency: gnome-screensaver-2.14.3 -> openldap-client-2.3.27
(net/openld
ap23-client):
Skipped. (running in non-interactive mode; specify -i to ask)
Stale dependency: gnome-screensaver-2.14.3 -> gnome-keyring-0.4.9
(security/gnom
e-keyring):
Skipped. (running in non-interactive mode; specify -i to ask)
Stale dependency: gnome-screensaver-2.14.3 -> gnome-mime-data-2.4.2
(misc/gnome-
mime-data):
Skipped. (running in non-interactive mode; specify -i to ask)
Stale dependency: gnome-screensaver-2.14.3 -> gnome-vfs-2.14.2_3
(devel/gnome-vf
s):
Skipped. (running in non-interactive mode; specify -i to ask)
Stale dependency: gnome-screensaver-2.14.3 -> pkg-config-0.21
(devel/pkg-config)
:
Skipped. (running in non-interactive mode; specify -i to ask)
Stale dependency: xscreensaver-gnome-hacks-4.24_1 -> pkg-config-0.21
(devel/pkg-
config):
Skipped. (running in non-interactive mode; specify -i to ask)
chre#



Toute piste et tout conseil seraient les bienvenus.
Merci,
Christian.
  • Partager ce contenu :
Vos réponses Page 1 / 2
Trier par : date / pertinence
NoSpamCity
Le #867117
NoSpamCity :

# pkgdb -aF
---> Checking the package registry database
Stale dependency: gnome-screensaver-2.14.3 -> openldap-client-2.3.27
(net/openldap23-client):


Ces dépendances sont manquantes, il faut les installer.
cd /usr/ports/net/openldap23-client && make install

etc...
Bonjour,


Et merci de ces éléments.

Toutefois, ayant fait au préalable un CVSup, j'ai du mal à suivre
pourquoi ces dépendances sont manquantes ?

Il m'avait semblé comprendre (mais je me trompe ?) qu'ayant mis à jour
l'arborescence des ports avec CVSup, l'installation de Gnome trouvait
toutes les dépendances dont il a besoin et que l'installation
s'effectuerait sans problèmes ?

--
@+,
Christian.


NoSpamCity
Le #866945
Bonjour à tous,

Désolé de ces questions de newbie sous FreeBSD.

J'essaie d'upgrader GNOME 2.12 vers GNOME 2.14, en suivant
les instructions ici : http://www.freebsd.org/gnome/docs/faq2.html#q6

Après avoir mis à jour avec succès l'arbre des ports avec CVSup,
j'ai vérifier l'opératon avec pkgdb -fF et j'obtiens des messages
d'erreurs que je ne sais pas traiter (dans l'exemple ci-dessous,
j'ai utilisé l'option -a seulement pour afficher toutes les
erreurs rencontrées) :

chre# uname -a
FreeBSD chre.chre 6.0-RELEASE FreeBSD 6.0-RELEASE #0: Thu Nov 3
09:36:13 UTC 20
05 :/usr/obj/usr/src/sys/GENERIC i386
chre# pkgdb -aF
---> Checking the package registry database
Stale dependency: gnome-screensaver-2.14.3 -> openldap-client-2.3.27
(net/openld
ap23-client):
Skipped. (running in non-interactive mode; specify -i to ask)
Stale dependency: gnome-screensaver-2.14.3 -> gnome-keyring-0.4.9
(security/gnom
e-keyring):
Skipped. (running in non-interactive mode; specify -i to ask)
Stale dependency: gnome-screensaver-2.14.3 -> gnome-mime-data-2.4.2
(misc/gnome-
mime-data):
Skipped. (running in non-interactive mode; specify -i to ask)
Stale dependency: gnome-screensaver-2.14.3 -> gnome-vfs-2.14.2_3
(devel/gnome-vf
s):
Skipped. (running in non-interactive mode; specify -i to ask)
Stale dependency: gnome-screensaver-2.14.3 -> pkg-config-0.21
(devel/pkg-config)
:
Skipped. (running in non-interactive mode; specify -i to ask)
Stale dependency: xscreensaver-gnome-hacks-4.24_1 -> pkg-config-0.21
(devel/pkg-
config):
Skipped. (running in non-interactive mode; specify -i to ask)
chre#



Toute piste et tout conseil seraient les bienvenus.
Merci,
Christian.
Bonjour,


Cette fois-ci, je suis perdu :(
Après un portupgrage -a (très, très long), voici ce que me dit
pkgdb -fF :

chre# pkgdb -fF
---> Checking the package registry database
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ...
/var/db/pkg/pkgdb.db:
unexpected file type or format -- Invalid argument; rebuild needed]
[Rebuilding
the pkgdb <format:bdb_btree> in /var/db/pkg ... /var/db/pkg/pkgdb.db:
unexpected
file type or format -- Invalid argument: Cannot update the pkgdb!]:
Cannot upda
te the pkgdb!]
chre#


Que se passe-t-il ? Comment puis-je corriger le problème ?

Merci,
Christian.

talon
Le #866943
NoSpamCity
chre# pkgdb -fF
---> Checking the package registry database
[Updating the pkgdb <format:bdb_btree> in /var/db/pkg ...
/var/db/pkg/pkgdb.db:
unexpected file type or format -- Invalid argument; rebuild needed]
[Rebuilding
the pkgdb <format:bdb_btree> in /var/db/pkg ... /var/db/pkg/pkgdb.db:
unexpected
file type or format -- Invalid argument: Cannot update the pkgdb!]:
Cannot upda
te the pkgdb!]
chre#



Que se passe-t-il ? Comment puis-je corriger le problème ?




Le connecteur de bd de ruby a été upgradé, et ne sait pas lire l'ancienne
base de données. Essaye de la bouger ailleurs. C'est un des problèmes de
portupgrade, ruby est trés lent, et il utilise un format de stockage instable.
Le même genre de choses que fait portupgrade je le fais en python 10 fois
plus vite, et le format de stockage (pickle) est stable et rapide.


Merci,
Christian.


--
Michel Talon

NoSpamCity
Le #866940
Bonjour,

Le connecteur de bd de ruby a été upgradé,
Ok, il y a eu une mise à jour


et ne sait pas lire l'ancienne base de données.
Une mise à jour qui n'assure pas la compatibilité ascendante ?


Essaye de la bouger ailleurs.
Là, je suis techniquement largué ;-) C'est à dire ? Comment faire ?


C'est un des problèmes de portupgrade, ruby est trés lent, et il utilise un format de stockage instable.
Cela semble étonnant. Pourquoi utiliser ruby s'il n'est pas fiable ?


Le même genre de choses que fait portupgrade je le fais en python 10 fois
plus vite, et le format de stockage (pickle) est stable et rapide.
Et l'on peut faire la même chose à la place de pkgdb -fF ?


Merci pour les précisions.

--
Christian.

F. Senault
Le #866939

Bonjour,

Le connecteur de bd de ruby a été upgradé,
Ok, il y a eu une mise à jour


et ne sait pas lire l'ancienne base de données.
Une mise à jour qui n'assure pas la compatibilité ascendante ?



Oui et non. Jette un oeil à l'entrée du fichier /usr/ports/UPDATING du
3/7/2006. La première suggestion dit ça :

A quick fix is to remove the databases, type:
'rm /var/db/pkg/pkgdb.db /usr/ports/INDEX*.db'.


(Le plus rapide est de supprimer les bases de données avec la commande
ci-dessus.)

Ils donnent d'autres pistes si tu veux conserver la bases de données de
portupgrade, mais ce n'est pas essentiel.

Essaye de la bouger ailleurs.
Là, je suis techniquement largué ;-) C'est à dire ? Comment faire ?


C'est un des problèmes de portupgrade, ruby est trés lent, et il
utilise un format de stockage instable.
Cela semble étonnant. Pourquoi utiliser ruby s'il n'est pas fiable ?



Ruby lui-même est fiable, et le format de stockage est plus qu'éprouvé,
me semble-t-il. Le problème de versions est décrit dans le fichier
updating.

Et pour la question de lenteur, il faut la pondérer par la fréquence des
opérations. Le commun des mortels utilise portupgrade une fois par mois
ou peut-être par semaine, la vitesse est un facteur moins important que
s'il s'agissait d'un daemon appelé en permanence, par exemple.

Fred
--
Oh I try to find her Oh I try to answer I touch her hand And death
smiles She really want to take me I've seen the door And the walls
cry (So) let it drain (Your) static blood And kiss the fallen angel
Down in the heart of hell (Noir Désir, Lola)


Christian
Le #866759

Bonjour,

Le connecteur de bd de ruby a été upgradé,
Ok, il y a eu une mise à jour


et ne sait pas lire l'ancienne base de données.
Une mise à jour qui n'assure pas la compatibilité ascendante ?



Oui et non. Jette un oeil à l'entrée du fichier /usr/ports/UPDATING du
3/7/2006. La première suggestion dit ça :

A quick fix is to remove the databases, type:
'rm /var/db/pkg/pkgdb.db /usr/ports/INDEX*.db'.


(Le plus rapide est de supprimer les bases de données avec la commande
ci-dessus.)

Ils donnent d'autres pistes si tu veux conserver la bases de données de
portupgrade, mais ce n'est pas essentiel.

Essaye de la bouger ailleurs.
Là, je suis techniquement largué ;-) C'est à dire ? Comment faire ?


C'est un des problèmes de portupgrade, ruby est trés lent, et il
utilise un format de stockage instable.
Cela semble étonnant. Pourquoi utiliser ruby s'il n'est pas fiable ?



Ruby lui-même est fiable, et le format de stockage est plus qu'éprouvé,
me semble-t-il. Le problème de versions est décrit dans le fichier
updating.

Et pour la question de lenteur, il faut la pondérer par la fréquence des
opérations. Le commun des mortels utilise portupgrade une fois par mois
ou peut-être par semaine, la vitesse est un facteur moins important que
s'il s'agissait d'un daemon appelé en permanence, par exemple.

Fred
Bonjour,


Et merci !

Je tente d'appliquer pour voir, en espérant réussir à installer la
nouvelle version de Gnome.


--
Christian.



Christian
Le #866758
Une mise à jour qui n'assure pas la compatibilité ascendante ?


Oui et non. Jette un oeil à l'entrée du fichier /usr/ports/UPDATING du
3/7/2006. La première suggestion dit ça :

A quick fix is to remove the databases, type:
'rm /var/db/pkg/pkgdb.db /usr/ports/INDEX*.db'.


(Le plus rapide est de supprimer les bases de données avec la commande
ci-dessus.)

Ils donnent d'autres pistes si tu veux conserver la bases de données de
portupgrade, mais ce n'est pas essentiel.

Cela semble étonnant. Pourquoi utiliser ruby s'il n'est pas fiable ?


Ruby lui-même est fiable, et le format de stockage est plus qu'éprouvé,
me semble-t-il. Le problème de versions est décrit dans le fichier
updating.

Et pour la question de lenteur, il faut la pondérer par la fréquence des
opérations. Le commun des mortels utilise portupgrade une fois par mois
ou peut-être par semaine, la vitesse est un facteur moins important que
s'il s'agissait d'un daemon appelé en permanence, par exemple.

Fred
Bonjour,


Et merci !

Je tente d'appliquer pour voir, en espérant réussir à installer la
nouvelle version de Gnome.


--
Christian.


NoSpamCity
Le #866757

Je tente d'appliquer pour voir, en espérant réussir à installer la
nouvelle version de Gnome.




Ok, pkgdb fonctionne à nouveau. Toutefois, j'ai toujours mes problèmes
de dépendances, je reprend le fil là ou je l'avais laissé sur ce sujet.

--
Christian.

F. Senault
Le #866756

(Moi aussi, je reprends le fil où il en était... :) )

NoSpamCity :

# pkgdb -aF
---> Checking the package registry database
Stale dependency: gnome-screensaver-2.14.3 -> openldap-client-2.3.27
(net/openldap23-client):


Ces dépendances sont manquantes, il faut les installer.
cd /usr/ports/net/openldap23-client && make install

etc...
Bonjour,


Et merci de ces éléments.

Toutefois, ayant fait au préalable un CVSup, j'ai du mal à suivre
pourquoi ces dépendances sont manquantes ?


Il est possible que la nouvelle version ait un jeu de dépendances
différentes de la précédente, ce qui n'a pas l'air de plaire à
portupgrade.

Mais le fichier UPDATING est magique. Entrée du 20060429 (trouvée en
cherchant... gnome).

Fred
--
Trusted you With my life
Shattered dreams Broken glass
I hope there is a closure Down your path (Kittie,
For I have yet to find The means to forgive Pink Lemonade)



NoSpamCity
Le #866755
Il est possible que la nouvelle version ait un jeu de dépendances
différentes de la précédente, ce qui n'a pas l'air de plaire à
portupgrade.

Mais le fichier UPDATING est magique. Entrée du 20060429 (trouvée en
cherchant... gnome).

Fred


Bonjour,

Arf, je découvre. RTFM n'est-ce pas ? ;-)

J'ai donc ajouté et installé les dépendances manquantes,
pkgdb -fF est ok, j'ai donc lancé un portupgrade -a (qui
me prend un jour ou deux) ; et ensuite je reprends la
FAQ d'installation de Gnome ici :
http://www.freebsd.org/gnome/docs/faq2.html#q6

La lecture du fichier UPDATING m'a renvoyé des
informations que j'avais lues ici :
http://www.freebsd.org/gnome/docs/faq214.html#q2

Question : il est dit dans la FAQ
# pkgdb -fF
# pkg_delete -rf pkg-config*


J'ai peur en faisant cela de supprimer beaucoup plus que
Gnome ('-rf pkg-config*'). Me trompe-je ?

Merci beaucoup pour l'aide déjà apportée.

--
Christian.

Poster une réponse
Anonyme