[gentoo-user-fr] bzarreries suite recompile glibc

Le
Pascal Ronecker
Salut,

suite à d'autres aventures (voir posts précédents)
me voilà armé d'une glibc avec les headers d'un noyau 2.6.14, avec ntpl
mais SANS ntplonly
après quelques recompiles de ci de là , ca va plutot bien

SAUF :

xdtv (soft qui exploite les cartes tuner) : je l'ai recompilé également
sinon marchait pas, mais depuis : il ne marche qu'en root !!

bouh, c'est laid, je l'ai lancé en root juste en désespoir de cause.
Dans les autres cas j'ai droit à un beau SIGSEV
(segmentation fault quoi)

Genre il irait écrire dans des zones mémoires où il n'aurait pas le droit ??

Je dirais que ca vient de xdtv lui même, mais comme avant mes modifs
systems ca marchait je me suis dit qu'un ptit post ici ne serait pas
perdu.


--
gentoo-user-fr@gentoo.org mailing list
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Keats
Le #7590941
yop
quel version de glibc ?
et t'as quoi comme use pour glibc ?

nahi ~ # emerge -pv glibc

pour moi ça marche nickel avec :
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] sys-libs/glibc-2.4-r1 [2.3.6-r3] USE="glibc-omitfp nls
nptl nptlonly userlocales -build -hardened -pic -profile" 16,134 kB

et j'ai lu par ci par là que glibc 2.4 buggait les trucs
donc j'y passerai pas pour l'instant :)


Le jeudi 30 mars 2006 à 00:19 +0200, Pascal Ronecker a écrit :
Salut,

suite à d'autres aventures (voir posts précédents)
me voilà armé d'une glibc avec les headers d'un noyau 2.6.14, avec ntpl
mais SANS ntplonly
après quelques recompiles de ci de là , ca va plutot bien ...

SAUF :

xdtv (soft qui exploite les cartes tuner) : je l'ai recompilé également
sinon marchait pas, mais depuis : il ne marche qu'en root !!

bouh, c'est laid, je l'ai lancé en root juste en désespoir de cause.
Dans les autres cas j'ai droit à un beau SIGSEV
(segmentation fault quoi)

Genre il irait écrire dans des zones mémoires où il n'aurait pas le droit ??

Je dirais que ca vient de xdtv lui même, mais comme avant mes modifs
systems ca marchait ... je me suis dit qu'un ptit post ici ne serait pas
perdu.





--
mailing list
Pascal Ronecker
Le #7590921
Keats wrote:
yop
quel version de glibc ?
et t'as quoi comme use pour glibc ?

nahi ~ # emerge -pv glibc

pour moi ça marche nickel avec :
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] sys-libs/glibc-2.4-r1 [2.3.6-r3] USE="glibc-omitfp nls
nptl nptlonly userlocales -build -hardened -pic -profile" 16,134 kB

et j'ai lu par ci par là que glibc 2.4 buggait les trucs
donc j'y passerai pas pour l'instant :)


Le jeudi 30 mars 2006 à 00:19 +0200, Pascal Ronecker a écrit :

Salut,

suite à d'autres aventures (voir posts précédents)
me voilà armé d'une glibc avec les headers d'un noyau 2.6.14, avec ntpl
mais SANS ntplonly
après quelques recompiles de ci de là , ca va plutot bien ...

SAUF :

xdtv (soft qui exploite les cartes tuner) : je l'ai recompilé également
sinon marchait pas, mais depuis : il ne marche qu'en root !!

bouh, c'est laid, je l'ai lancé en root juste en désespoir de cause.
Dans les autres cas j'ai droit à un beau SIGSEV
(segmentation fault quoi)

Genre il irait écrire dans des zones mémoires où il n'aurait pas le droit ??

Je dirais que ca vient de xdtv lui même, mais comme avant mes modifs
systems ca marchait ... je me suis dit qu'un ptit post ici ne serait pas
perdu.






--
mailing list




Calculating dependencies ...done!
[ebuild R ] sys-libs/glibc-2.3.5-r2 -build -erandom -glibc-compat20
-glibc-omitfp -hardened -linuxthreads-tls (-multilib) +nls +nptl
-nptlonly -pic -profile (-selinux) -userlocales 0 kB

Total size of downloads: 0 kB



Encore plus bizarre :

emerge xdtv 2.3.1 : marche pas en suer.

recuperation des sources du 2.3.2, compilation a la main : ca marche.

emerge du 2.3.2 : marche pas !


recompile a la main : marche plus !!!


gne???!!
--
mailing list
Didier LINK
Le #7590911
--=-67B345DMmbeh1+LQKieK
Content-Type: text/plain; charset=ISO-8859-15
Content-Transfer-Encoding: quoted-printable

Le jeudi 30 mars 2006 à 00:19 +0200, Pascal Ronecker a écrit :
Salut,


Salut,


suite à d'autres aventures (voir posts précédents)
me voilà armé d'une glibc avec les headers d'un noyau 2.6.14, avec nt pl
mais SANS ntplonly



Ok, plus de segfault finalement ? Tu t'en es sorti comment ?

après quelques recompiles de ci de là , ca va plutot bien ...

SAUF :

xdtv (soft qui exploite les cartes tuner) : je l'ai recompilé égaleme nt
sinon marchait pas, mais depuis : il ne marche qu'en root !!

bouh, c'est laid, je l'ai lancé en root juste en désespoir de cause.
Dans les autres cas j'ai droit à un beau SIGSEV
(segmentation fault quoi)



Mmmmhhh, ça sent les droits qui ne sont pas bons sur un périphérique
ça ! Vérifie à quoi accède xdtv, perso je ne peux pas te dire je ne l'ai
pas. Fouille les fichiers de configuration.


Genre il irait écrire dans des zones mémoires où il n'aurait pas le droit ??

Je dirais que ca vient de xdtv lui même, mais comme avant mes modifs
systems ca marchait ... je me suis dit qu'un ptit post ici ne serait pas
perdu.



ben non, on trouve toujours quelques bonnes idées à partager ici ;)

A+ et bon courage !

Didier

--
Didier Link Jabber :
MSN :

Clé GPG : 75BAC9EE


--=-67B345DMmbeh1+LQKieK
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: Ceci est une partie de message
=?ISO-8859-1?Q?numériquement?= =?ISO-8859-1?Q?_signée?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.2.2 (GNU/Linux)

iD8DBQBELF9mkyPwinW6ye4RAjRxAJwIRFfpjs/Qk9sPc1kxG+HerRR3cwCghCho
zWnjb92eR8ZI0PTRcpVVbjY =AZlM
-----END PGP SIGNATURE-----

--=-67B345DMmbeh1+LQKieK--


--
mailing list
Pascal Ronecker
Le #7590901
Keats wrote:
yop
quel version de glibc ?
et t'as quoi comme use pour glibc ?

nahi ~ # emerge -pv glibc

pour moi ça marche nickel avec :
These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild U ] sys-libs/glibc-2.4-r1 [2.3.6-r3] USE="glibc-omitfp nls
nptl nptlonly userlocales -build -hardened -pic -profile" 16,134 kB

et j'ai lu par ci par là que glibc 2.4 buggait les trucs
donc j'y passerai pas pour l'instant :)






Bah en fait c'est étrange. J'ai tenté une recompile "à la main" de xdtv,
avec un ./configure tout simple, install dans /sur/local ...
et ben ca amrche.

Donc ca doit venir des useflags que j'ai pour xdtv. C'est bizarre
qu'avant mon changement de glibc ca marchait. Donc un de mes useflags
doit faire appel à un machin à recompiler aussi ???


Calculating dependencies ...done!
[ebuild N ] media-tv/xdtv-2.3.2 +X -Xaw3d +aac +alsa +aqua_theme
+carbone_theme -debug -dvb +encode +ffmpeg +jpeg -linguas_ca -linguas_de
-linguas_en -linguas_es +linguas_fr -linguas_gl -linguas_it -linguas_ja
-linguas_pl -linguas_ru +lirc +mmx +neXt +nls +ogg +png -xinerama +xv
+xvid -zvbi 0


deja recompile xvid et neXtaw, sans resultat.
Apres faudrait que je tente le configure surchargé à la main, mais ca me
gave.

Je crois que je vais laisser els choses en l'état, après tout ca marche ...



bon sinon ma glibc c'est ça :

[ebuild R ] sys-libs/glibc-2.3.5-r2 -build -erandom -glibc-compat20
-glibc-omitfp -hardened -linuxthreads-tls (-multilib) +nls +nptl
-nptlonly -pic -profile (-selinux) -userlocales 0 kB


--
mailing list
Pascal Ronecker
Le #7590891
Au bout du conmpte :

ca se plante si j'ai un repertoire $PREFIX/lib/xdtv qui existe.
(c'est sensé contenir des trucs optionnels, des themes ...)

si je l'efface : plus de probleme.
(tout ce ci a coup d'emerge ou en manuel)

Donc ca vient d'une facon ou d'une autre ca vient de xdtv, a moi leur
forum :-)
--
mailing list
Pascal Ronecker
Le #7590861
Pascal Ronecker wrote:
Au bout du conmpte :

ca se plante si j'ai un repertoire $PREFIX/lib/xdtv qui existe.
(c'est sensé contenir des trucs optionnels, des themes ...)

si je l'efface : plus de probleme.
(tout ce ci a coup d'emerge ou en manuel)

Donc ca vient d'une facon ou d'une autre ca vient de xdtv, a moi leur
forum :-)
--
mailing list





Et ca continue dans la quatrieme dimension :

avec xdtv toujours installé à la main, depuis ce matin,
si je le fais démarrer par lirc (telecommande quoi) : segmentation fault.

Alors que la même commande lancée depuis une console ou un accourci
clavier fonctionne.

Dé-li-rant.


--
mailing list
Publicité
Poster une réponse
Anonyme