[gentoo-user-fr] [Gcc] Changer de version de Gcc avant compilation de tout le system pour mettre "pentiumm"

Le
grillot sebastien
Bonjour bonjour,
J'ai un centrino (enfin une architecture centrino donc un proc pentium
M) et je sais que la version de gcc (la 3.4 il me semble) ne prends
pas comme option pentium m et il faut lui donner pentium 4. Toutefois
si mes souvenirs sont bon la verion 4 (?) de gcc le permet. Je presume
que mon systeme sera bien mieux optimis avec un flag exact de mon
cpu toutefois je crois savoir qu'il va me falloir changer de gcc
lors de la compilation du systeme des le depart mais comment faire
?

Merci vous tous ;o)

Amicalement

Seb

--
gentoo-user-fr@gentoo.org mailing list

  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Bruno Michel
Le #7207451
Quoting grillot sebastien
Bonjour bonjour,
J'ai un centrino (enfin une architecture centrino donc un proc pentium
M) et je sais que la version de gcc (la 3.4 il me semble...) ne prends
pas comme option pentium m et il faut lui donner pentium 4. Toutefois
si mes souvenirs sont bon la verion 4 (?) de gcc le permet. Je presume
que mon systeme sera bien mieux optimisé avec un flag exact de mon
cpu... toutefois je crois savoir qu'il va me falloir changer de gcc
lors de la compilation du systeme des le depart... mais comment faire
?

Merci à vous tous ;o)

Amicalement

Seb



Bonjour,

je suis quasiment sur que gcc 3.4 peut utiliser -march=pentium-m.
Par contre, la version 4 de gcc est encore très instable.

--
Bruno Michel

--
mailing list
Alexandre St-Pierre
Le #7207421
> je suis quasiment sur que gcc 3.4 peut utiliser -march=pentium-m.
Par contre, la version 4 de gcc est encore très instable.



=gcc-3.4 peut utiliser -march=pentium-m. J'utilise gcc-3.3.5 avec


-march=pentium3 pour mon processeur Pentium M 1.4Ghz et je n'ai aucun
probleme. Le pentium M est beaucoup plus derive du P3 que du P4.

--
Alexandre St-Pierre


--
mailing list
Scouarnec Erwan
Le #7207401
--ReaqsoxgOBHFXBhH
Content-Type: text/plain; charset=iso-8859-1
Content-Disposition: inline
Content-Transfer-Encoding: quoted-printable


j'ai un intel centrino sur mon portable avec un gcc 3.4 et oui il
support le flags pentium-m pas besoin de gcc 4 pour çà



On Mon, Mar 14, 2005 at 07:45:55AM +0000, grillot sebastien wrote :
Bonjour bonjour,
J'ai un centrino (enfin une architecture centrino donc un proc pentium
M) et je sais que la version de gcc (la 3.4 il me semble...) ne prends
pas comme option pentium m et il faut lui donner pentium 4. Toutefois
si mes souvenirs sont bon la verion 4 (?) de gcc le permet. Je presume
que mon systeme sera bien mieux optimisé avec un flag exact de mon
cpu... toutefois je crois savoir qu'il va me falloir changer de gcc
lors de la compilation du systeme des le depart... mais comment faire
?

Merci à vous tous ;o)

Amicalement

Seb

--
mailing list




--ReaqsoxgOBHFXBhH
Content-Type: application/pgp-signature
Content-Disposition: inline

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.0 (GNU/Linux)

iD8DBQFCNo14HEwbqsmjwoYRArWsAKDLqInZziM+DR9gmswkzxm7BXjqlwCeMcBh
2rQjj3MVekN46n0g+evYP5U =JrQt
-----END PGP SIGNATURE-----

--ReaqsoxgOBHFXBhH--
Poster une réponse
Anonyme