[gentoo-user-fr] libc.so.6

Le
Pascal Ronecker
Bonjour tout le monde,

depuis mes dernières mises à jour (gnome et xorg souvenez vous )
j'ai quelques programmes qui ont des comportements bizarroides.

Concrètement :
- Eclipse refuse de se lancer, ou quand il veut bien, se palnte quand je
le ferme.
- xdtv (soft vachement bien de regardage de tv) : dans certains cas,
plantages alors qu'avant, non. (segmentation fault)

Dans tous les cas, soit d'après le message de log d'eclipse, soit en
passant xdtv au debugger gdb, ca a l'air de venir de lic.so.6
(ou quelques fois de libpthread.so.0)


eclipse par exemple :

An unexpected exception has been detected in native code outside the VM.
Unexpected Signal : 11 occurred at PC=0x400EA34B
Function=__libc_free+0x4A
Library=/lib/libc.so.6


Alors je me demandais :
- je peux y faire quelque chose ?
- y a moyen de retrouver dans les précédentes installs si y a eu une
mise à jour pas terrible ? (le genre de mise à jour après laquelle pas
mal de choses soient à recomiler)

toute idée est la bienvenue !


--
gentoo-user-fr@gentoo.org mailing list
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Yoann Pannier
Le #7204501
Pascal Ronecker wrote, On 04/15/2005 05:45 PM:
depuis mes dernières mises à jour (gnome et xorg ... souvenez vous ...)
j'ai quelques programmes qui ont des comportements bizarroides.



Tout ça est un peu trop vague pour moi. Donc je vais faire classique, au
risque de ne pas être utile :

Mises à jour.. programmes qui ne fonctionnent plus.. revdep-rebuild ?

--
Yoann Pannier

--
mailing list
Pascal Ronecker
Le #7204451
Yoann Pannier wrote:
Pascal Ronecker wrote, On 04/15/2005 05:45 PM:

depuis mes dernières mises à jour (gnome et xorg ... souvenez vous ...)
j'ai quelques programmes qui ont des comportements bizarroides.




Tout ça est un peu trop vague pour moi. Donc je vais faire classique, au
risque de ne pas être utile :

Mises à jour.. programmes qui ne fonctionnent plus.. revdep-rebuild ?




ouaoh, j'ai regardé revdep-rebuild -p --soname libc.so.6
... et vu que tout utilise cette bibliothèque là j'ai eu droit à une
proposition d'emerge de tout ou presque.

j'ai pas super envie de me lancer dans une compile de trois jours ...

en plus :

>Warning: Failed to resolve package order.
>Will merge in "random" order

ca met pas en confiance :-)

--
mailing list
Yoann Pannier
Le #7204401
Pascal Ronecker wrote, On 04/16/2005 08:24 AM:
ouaoh, j'ai regardé revdep-rebuild -p --soname libc.so.6



Chez moi, revdep-rebuild (gentoolkit-0.2.0, x86) ne fonctionne
normalement que si ses options sont en premier, et celles d'emerge à la
fin :

#revdep-rebuild --soname libc.so.6 -p

... et vu que tout utilise cette bibliothèque là j'ai eu droit à une
proposition d'emerge de tout ou presque.



Yep, mais comme --soname ne cherche pas ce qui est cassé, seulement ce
qui utilise, je ne suis pas sûr que ce soit la bonne méthode pour
résoudre tes problèmes.

j'ai pas super envie de me lancer dans une compile de trois jours ...



J'ai tendance à croire que tes problèmes viennent surtout des librairies
gnome ou/et xorg, et que la mention de glibc dans tes erreurs n'est
qu'un symptome.

Normalement, après la mise à jour de librairies, je crois qu'un revdep
normal devrait suffir à pointer les paquets qui doivent être recompiler.

#revdep-rebuild -pv

D'un autre côté, tu as parlé aussi de libpthread dans tes erreurs...
est-ce que par hasard tu serai passé à NPTL en même temps que... le reste ?

Si c'est le cas, un #emerge --emptytree world# ne te ferai pas de mal je
pense. la doc dit que ce n'est pas nécéssaire, mais bon si tu as des
soucis après l'upgrade...

http://www.gentoo.org/doc/fr/migration-to-2.6.xml#doc_chap11

--
Yoann Pannier

--
mailing list
Pascal Ronecker
Le #7204341
Yoann Pannier wrote:
Pascal Ronecker wrote, On 04/16/2005 08:24 AM:

ouaoh, j'ai regardé revdep-rebuild -p --soname libc.so.6




Chez moi, revdep-rebuild (gentoolkit-0.2.0, x86) ne fonctionne
normalement que si ses options sont en premier, et celles d'emerge à la
fin :

#revdep-rebuild --soname libc.so.6 -p


... et vu que tout utilise cette bibliothèque là j'ai eu droit à une
proposition d'emerge de tout ou presque.




Yep, mais comme --soname ne cherche pas ce qui est cassé, seulement ce
qui utilise, je ne suis pas sûr que ce soit la bonne méthode pour
résoudre tes problèmes.


j'ai pas super envie de me lancer dans une compile de trois jours ...




J'ai tendance à croire que tes problèmes viennent surtout des librairies
gnome ou/et xorg, et que la mention de glibc dans tes erreurs n'est
qu'un symptome.

Normalement, après la mise à jour de librairies, je crois qu'un revdep
normal devrait suffir à pointer les paquets qui doivent être recompiler.

#revdep-rebuild -pv

D'un autre côté, tu as parlé aussi de libpthread dans tes erreurs...
est-ce que par hasard tu serai passé à NPTL en même temps que... le reste ?

Si c'est le cas, un #emerge --emptytree world# ne te ferai pas de mal je
pense. la doc dit que ce n'est pas nécéssaire, mais bon si tu as des
soucis après l'upgrade...

http://www.gentoo.org/doc/fr/migration-to-2.6.xml#doc_chap11




NPTL ??
ca me disais rien alors je suis allé voir ton lien : en fait ca fait
depuis belle lurette que je suis en noyau 2.6. Peut être depuis
l'install je ne sais plus.
"Mauvaises" habitudes obligent : je ne fait confiance à personne en
matière de noyau, et je le recompile à l'ancienne :-)

mais alors, peut on envisager que ma glibc soit quand même à recompiler
? à cause d'un autre bidule dans un coin ?

Sinon, revdep-rebuild tout bête a finalement marché (après avoir upgradé
certains vieux machins par emerge "manuel", vu que des "vieux" packages
n'étaient plus dans l'arbre.
Mais sans grands résultats. ..


Bon sinon j'avais modifié mes useflags dans mon make.conf, m'enfin juste
pour y ajouter :
truetype bitmap-fonts truetype-fonts type1-fonts

rien de bien méchant quoi.
--
mailing list
Pascal Ronecker
Le #7204321
Pascal Ronecker wrote:
Yoann Pannier wrote:

Pascal Ronecker wrote, On 04/16/2005 08:24 AM:

ouaoh, j'ai regardé revdep-rebuild -p --soname libc.so.6





Chez moi, revdep-rebuild (gentoolkit-0.2.0, x86) ne fonctionne
normalement que si ses options sont en premier, et celles d'emerge à la
fin :

#revdep-rebuild --soname libc.so.6 -p


... et vu que tout utilise cette bibliothèque là j'ai eu droit à une
proposition d'emerge de tout ou presque.





Yep, mais comme --soname ne cherche pas ce qui est cassé, seulement ce
qui utilise, je ne suis pas sûr que ce soit la bonne méthode pour
résoudre tes problèmes.


j'ai pas super envie de me lancer dans une compile de trois jours ...





J'ai tendance à croire que tes problèmes viennent surtout des librairies
gnome ou/et xorg, et que la mention de glibc dans tes erreurs n'est
qu'un symptome.

Normalement, après la mise à jour de librairies, je crois qu'un revdep
normal devrait suffir à pointer les paquets qui doivent être recompiler.

#revdep-rebuild -pv

D'un autre côté, tu as parlé aussi de libpthread dans tes erreurs...
est-ce que par hasard tu serai passé à NPTL en même temps que... le
reste ?

Si c'est le cas, un #emerge --emptytree world# ne te ferai pas de mal je
pense. la doc dit que ce n'est pas nécéssaire, mais bon si tu as des
soucis après l'upgrade...

http://www.gentoo.org/doc/fr/migration-to-2.6.xml#doc_chap11




NPTL ??
ca me disais rien alors je suis allé voir ton lien : en fait ca fait
depuis belle lurette que je suis en noyau 2.6. Peut être depuis
l'install je ne sais plus.
"Mauvaises" habitudes obligent : je ne fait confiance à personne en
matière de noyau, et je le recompile à l'ancienne :-)

mais alors, peut on envisager que ma glibc soit quand même à recompiler
? à cause d'un autre bidule dans un coin ?

Sinon, revdep-rebuild tout bête a finalement marché (après avoir upgradé
certains vieux machins par emerge "manuel", vu que des "vieux" packages
n'étaient plus dans l'arbre.
Mais sans grands résultats. ..


Bon sinon j'avais modifié mes useflags dans mon make.conf, m'enfin juste
pour y ajouter :
truetype bitmap-fonts truetype-fonts type1-fonts

rien de bien méchant quoi.





AARRGGHH


je me suis dit que tant qu'à faire, mes problèmes divers ayant pour
origine mon apssageà xorg, ptet que mettre à jour aussi les pilotes
nvidia ne serait pas du luxe.

bon ...

ben mauvaise pioche ! X fait une seg fault au démarrage !! (caught
signal 11)

Là j'ai mis le pilote nv pour dépanner.

glxinfo -> seg fault par exemple


Mais qu'est-ce que c'est que ce binz ?
Si je résume : presque tout ce que je recompile depuis se apsse assez
mal ...

Au secours ! !!
--
mailing list
Pascal Ronecker
Le #7204311
Pascal Ronecker wrote:
Yoann Pannier wrote:

Pascal Ronecker wrote, On 04/16/2005 08:24 AM:

ouaoh, j'ai regardé revdep-rebuild -p --soname libc.so.6





Chez moi, revdep-rebuild (gentoolkit-0.2.0, x86) ne fonctionne
normalement que si ses options sont en premier, et celles d'emerge à la
fin :

#revdep-rebuild --soname libc.so.6 -p


... et vu que tout utilise cette bibliothèque là j'ai eu droit à une
proposition d'emerge de tout ou presque.





Yep, mais comme --soname ne cherche pas ce qui est cassé, seulement ce
qui utilise, je ne suis pas sûr que ce soit la bonne méthode pour
résoudre tes problèmes.


j'ai pas super envie de me lancer dans une compile de trois jours ...





J'ai tendance à croire que tes problèmes viennent surtout des librairies
gnome ou/et xorg, et que la mention de glibc dans tes erreurs n'est
qu'un symptome.

Normalement, après la mise à jour de librairies, je crois qu'un revdep
normal devrait suffir à pointer les paquets qui doivent être recompiler.

#revdep-rebuild -pv

D'un autre côté, tu as parlé aussi de libpthread dans tes erreurs...
est-ce que par hasard tu serai passé à NPTL en même temps que... le
reste ?

Si c'est le cas, un #emerge --emptytree world# ne te ferai pas de mal je
pense. la doc dit que ce n'est pas nécéssaire, mais bon si tu as des
soucis après l'upgrade...

http://www.gentoo.org/doc/fr/migration-to-2.6.xml#doc_chap11




NPTL ??
ca me disais rien alors je suis allé voir ton lien : en fait ca fait
depuis belle lurette que je suis en noyau 2.6. Peut être depuis
l'install je ne sais plus.
"Mauvaises" habitudes obligent : je ne fait confiance à personne en
matière de noyau, et je le recompile à l'ancienne :-)

mais alors, peut on envisager que ma glibc soit quand même à recompiler
? à cause d'un autre bidule dans un coin ?

Sinon, revdep-rebuild tout bête a finalement marché (après avoir upgradé
certains vieux machins par emerge "manuel", vu que des "vieux" packages
n'étaient plus dans l'arbre.
Mais sans grands résultats. ..


Bon sinon j'avais modifié mes useflags dans mon make.conf, m'enfin juste
pour y ajouter :
truetype bitmap-fonts truetype-fonts type1-fonts

rien de bien méchant quoi.




Mise à jour :

j'ai installé les drivers nvidia à partir des pilotes "officiels"
récupérés sur nvidia.com et ... ca marche.

Le problème venait du "Load GLX", qui faisait planter X.

je comprends toujours pas ce qui se passe ...
--
mailing list
Pascal Ronecker
Le #7204301
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Pascal Ronecker wrote:
| Pascal Ronecker wrote:
|
|> Yoann Pannier wrote:
|>
|>> Pascal Ronecker wrote, On 04/16/2005 08:24 AM:
|>>
|>>> ouaoh, j'ai regardé revdep-rebuild -p --soname libc.so.6
|>>
|>>
|>>
|>>
|>> Chez moi, revdep-rebuild (gentoolkit-0.2.0, x86) ne fonctionne
|>> normalement que si ses options sont en premier, et celles d'emerge à la
|>> fin :
|>>
|>> #revdep-rebuild --soname libc.so.6 -p
|>>
|>>
|>>> ... et vu que tout utilise cette bibliothèque là j'ai eu droit à une
|>>> proposition d'emerge de tout ou presque.
|>>
|>>
|>>
|>>
|>> Yep, mais comme --soname ne cherche pas ce qui est cassé, seulement ce
|>> qui utilise, je ne suis pas sûr que ce soit la bonne méthode pour
|>> résoudre tes problèmes.
|>>
|>>
|>>> j'ai pas super envie de me lancer dans une compile de trois jours ...
|>>
|>>
|>>
|>>
|>> J'ai tendance à croire que tes problèmes viennent surtout des librairies
|>> gnome ou/et xorg, et que la mention de glibc dans tes erreurs n'est
|>> qu'un symptome.
|>>
|>> Normalement, après la mise à jour de librairies, je crois qu'un revdep
|>> normal devrait suffir à pointer les paquets qui doivent être recompiler.
|>>
|>> #revdep-rebuild -pv
|>>
|>> D'un autre côté, tu as parlé aussi de libpthread dans tes erreurs...
|>> est-ce que par hasard tu serai passé à NPTL en même temps que... le
|>> reste ?
|>>
|>> Si c'est le cas, un #emerge --emptytree world# ne te ferai pas de mal je
|>> pense. la doc dit que ce n'est pas nécéssaire, mais bon si tu as des
|>> soucis après l'upgrade...
|>>
|>> http://www.gentoo.org/doc/fr/migration-to-2.6.xml#doc_chap11
|>>
|>
|> NPTL ??
|> ca me disais rien alors je suis allé voir ton lien : en fait ca fait
|> depuis belle lurette que je suis en noyau 2.6. Peut être depuis
|> l'install je ne sais plus.
|> "Mauvaises" habitudes obligent : je ne fait confiance à personne en
|> matière de noyau, et je le recompile à l'ancienne :-)
|>
|> mais alors, peut on envisager que ma glibc soit quand même à
|> recompiler ? à cause d'un autre bidule dans un coin ?
|>
|> Sinon, revdep-rebuild tout bête a finalement marché (après avoir
|> upgradé certains vieux machins par emerge "manuel", vu que des "vieux"
|> packages n'étaient plus dans l'arbre.
|> Mais sans grands résultats. ..
|>
|>
|> Bon sinon j'avais modifié mes useflags dans mon make.conf, m'enfin
|> juste pour y ajouter :
|> truetype bitmap-fonts truetype-fonts type1-fonts
|>
|> rien de bien méchant quoi.
|
|
|
| Mise à jour :
|
| j'ai installé les drivers nvidia à partir des pilotes "officiels"
| récupérés sur nvidia.com et ... ca marche.
|
| Le problème venait du "Load GLX", qui faisait planter X.
|
| je comprends toujours pas ce qui se passe ...



Top délire, pour un des programmes qui plantait (matage de TV), c'est
... l'upgrade à alsa 1.0.8 qui posait problème !!

alors je fait le vilain pas gentil, comme de toute façon j'avais mes
modules "livrés" par le noyau standrad, j'ai réinstallé par dessus mes
vieilles alsa-libs (des 1.0.1 pour voir) : recompilé et ca roule.

Bizarre, vous avez dit bizarre ?




-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org

iD8DBQFCYrJlnDcSLi/WBGsRAnl3AKCLAiJ+Z1sCpXkIBYF9ylKI3jXcdwCglfsF
+JLD8rnv5IU08abTrvITXcs =TjJR
-----END PGP SIGNATURE-----
--
mailing list
Publicité
Poster une réponse
Anonyme