[gentoo-user-fr] [ Mise à jour GCC 3.3.6, avec 3.4.6 installé ]

Le
Bonjour,

Je me suis aperçu que sur quelques machines utilisant toujours GCC 3.3.6 (je
ne souhaite pas migrer sur ces machines), il y a une version de GCC 3.3.6-r1
dispo mais comme GCC 3.4.6 est installé, emerge ne voit pas la mise à jour.

Est-ce génant d'updater GCC de la sorte, sachant que GCC 3.4.6 est installé,
mais ne sert pas.

emerge 'sys-devel/gcc-3.3.6-r1'

Dans mon cas, il aurait surement été préférable que GCC 3.4.6 ne soit pas
installé, mais bon à l'époque je n'ai pas fait gaffe.
Aussi, j'ai voulu rendre les choses propres et j'ai désinstallé GCC 3.4.6.
Là pas de souci, enfin presque. "emerge" n'est pas content car
"glibc-2.3.6-r5" a besoin de 3.4.6. Du coup, j'ai remis GCC 3.4.6, ne
voulant pas downgrader "glibc".

Je n'ai jusqu'à présent rencontré aucun problème entre GCC 3.3.6 et glibc
2.3.6-r5, mais à priori glibc devrait être utilisé avec GCC 3.4.6 vu la
dépendance ? J'avoue que je nage un peu, je ne connais pas le lien qu'il y a
entre le compilateur GCC et la GNU C Lib.

Vos lumières sont les bienvenues.

Merci,
Fabien

--
gentoo-user-fr@gentoo.org mailing list

  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Mickael PARIS
Le #7825361
------=_Part_6125_26525037.1170858763801
Content-Type: text/plain; charset=ISO-8859-1; format=flowed
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Salut,

à la fin de la lecture de ton mail, je ne vois pas ta question.... à la
question :
Est-ce génant d'updater GCC de la sorte, sachant que GCC 3.4.6 est






installé,
mais ne sert pas.






Non aucun soucis.

Par contre la fin du mail, c'est pas clair, mais alors pas du tout.

Mickael.
Le 07/02/07,

Bonjour,

Je me suis aperçu que sur quelques machines utilisant toujours GCC 3.3. 6(je
ne souhaite pas migrer sur ces machines), il y a une version de GCC
3.3.6-r1
dispo mais comme GCC 3.4.6 est installé, emerge ne voit pas la mise à
jour.

Est-ce génant d'updater GCC de la sorte, sachant que GCC 3.4.6 est
installé,
mais ne sert pas.

emerge 'sys-devel/gcc-3.3.6-r1'

Dans mon cas, il aurait surement été préférable que GCC 3.4.6 ne soit pas
installé, mais bon à l'époque je n'ai pas fait gaffe.
Aussi, j'ai voulu rendre les choses propres et j'ai désinstallé GCC 3 .4.6.
Là pas de souci, enfin presque. "emerge" n'est pas content car
"glibc-2.3.6-r5" a besoin de 3.4.6. Du coup, j'ai remis GCC 3.4.6, ne
voulant pas downgrader "glibc".

Je n'ai jusqu'à présent rencontré aucun problème entre GCC 3.3.6 et glibc
2.3.6-r5, mais à priori glibc devrait être utilisé avec GCC 3.4.6 v u la
dépendance ? J'avoue que je nage un peu, je ne connais pas le lien qu'i l y
a
entre le compilateur GCC et la GNU C Lib.

Vos lumières sont les bienvenues.

Merci,
Fabien

--
mailing list





------=_Part_6125_26525037.1170858763801
Content-Type: text/html; charset=ISO-8859-1
Content-Transfer-Encoding: quoted-printable
Content-Disposition: inline

Salut, Bonjour, ne soit pas
------=_Part_6125_26525037.1170858763801--
--
mailing list
fly.captain
Le #7825341
Mickael PARIS a écrit :
Salut,

à la fin de la lecture de ton mail, je ne vois pas ta question.... à
la question :
>>>Est-ce génant d'updater GCC de la sorte, sachant que GCC 3.4.6 est
installé,
>>>mais ne sert pas.
Non aucun soucis.



Ok, merci.

Par contre la fin du mail, c'est pas clair, mais alors pas du tout.


Désolé, je vais essayer de faire plus clair cette fois.

Comme je disais, j'ai quelques machines où le compilateur utilisé est
GCC 3.3.6
Cependant, une autre version de GCC est aussi présente sur ces machines
: GCC 3.4.6
GCC 3.4.6 est installé, mais non utilisé, je n'ai jamais migré vers
cette version.

Comme GCC 3.4.6 est installé, "emerge" ne voit pas l'update de GCC 3.3.6

Je me disais donc qu'au lieu de mettre à jour GCC 3.3.6 avec la commande
: emerge 'sys-devel/gcc-3.3.6-r1'
peut-être aurait-il mieux fallu que je fasse du nettoyage, donc
désinstaller GCC 3.4.6, puis bloquer l'installation de GCC > 3.3.6

C'est ce que j'avais commencé à faire, mais une fois GCC 3.4.6
désinstallé, j'ai un problème avec glibc-2.3.6-r5, emerge me le fait
savoir !
En effet cette version dépend de GCC 3.4.6. Je n'ai pas voulu downgrader
glibc ne sachant pas ce que cela pouvait impliquer.

Ma question était donc, comment GCC et glibc sont-ils liés ?

J'imagine que mes machines utilisent depuis longtemps GCC 3.3.6 avec
glibc-2.3.6-r5 alors qu'elles ne devraient pas.

Je n'ai jamais eu de souci, mais, est-ce à votre avis une source d'ennuis ?

Merci,

Fabien

Mickael.
Le 07/02/07, *
Bonjour,

Je me suis aperçu que sur quelques machines utilisant toujours GCC
3.3.6 (je
ne souhaite pas migrer sur ces machines), il y a une version de
GCC 3.3.6-r1
dispo mais comme GCC 3.4.6 est installé, emerge ne voit pas la
mise à jour.

Est-ce génant d'updater GCC de la sorte, sachant que GCC 3.4.6 est
installé,
mais ne sert pas.

emerge 'sys-devel/gcc-3.3.6-r1'

Dans mon cas, il aurait surement été préférable que GCC 3.4.6 ne
soit pas
installé, mais bon à l'époque je n'ai pas fait gaffe.
Aussi, j'ai voulu rendre les choses propres et j'ai désinstallé
GCC 3.4.6.
Là pas de souci, enfin presque. "emerge" n'est pas content car
"glibc-2.3.6-r5" a besoin de 3.4.6. Du coup, j'ai remis GCC 3.4.6, ne
voulant pas downgrader "glibc".

Je n'ai jusqu'à présent rencontré aucun problème entre GCC 3.3.6
et glibc
2.3.6-r5, mais à priori glibc devrait être utilisé avec GCC 3.4.6
vu la
dépendance ? J'avoue que je nage un peu, je ne connais pas le lien
qu'il y a
entre le compilateur GCC et la GNU C Lib.

Vos lumières sont les bienvenues.

Merci,
Fabien

--
mailing list





--
mailing list
Jean-François Maeyhieux
Le #7825331
--=-mnl5CdszKcVNiuVSma/3
Content-Type: text/plain; charset=ISO-8859-15
Content-Transfer-Encoding: quoted-printable

On Wed, 2007-02-07 at 14:44 +0100, wrote:
Bonjour,

Je me suis aperçu que sur quelques machines utilisant toujours GCC 3.3. 6 (je
ne souhaite pas migrer sur ces machines), il y a une version de GCC 3.3.6 -r1
dispo mais comme GCC 3.4.6 est installé, emerge ne voit pas la mise à jour.

Est-ce génant d'updater GCC de la sorte, sachant que GCC 3.4.6 est inst allé,
mais ne sert pas.

emerge 'sys-devel/gcc-3.3.6-r1'

Dans mon cas, il aurait surement été préférable que GCC 3.4.6 ne soit pas
installé, mais bon à l'époque je n'ai pas fait gaffe.
Aussi, j'ai voulu rendre les choses propres et j'ai désinstallé GCC 3 .4.6.
Là pas de souci, enfin presque. "emerge" n'est pas content car
"glibc-2.3.6-r5" a besoin de 3.4.6. Du coup, j'ai remis GCC 3.4.6, ne
voulant pas downgrader "glibc".

Je n'ai jusqu'à présent rencontré aucun problème entre GCC 3.3.6 et glibc
2.3.6-r5, mais à priori glibc devrait être utilisé avec GCC 3.4.6 v u la
dépendance ? J'avoue que je nage un peu, je ne connais pas le lien qu'i l y a
entre le compilateur GCC et la GNU C Lib.

Vos lumières sont les bienvenues.




Il te faut utiliser "gcc-config -l" pour voir tes versions de gcc
installé puis selectionner le gcc actif avec "gcc-config 1" ou
"gcc-config x" pour selectionner respectivement le premier gccde la
liste ou le xième.



Merci,
Fabien



--
--------------------------------------------------------------------------- -----------
Jean-François Maeyhieux
--------------------------------------------------------------------------- -----------
PGP Public Key - Key ID = 63DB4770 Tuttle (JFM) http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x63DB4770
--------------------------------------------------------------------------- -----------

--=-mnl5CdszKcVNiuVSma/3
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.2 (GNU/Linux)

iD8DBQBFyi1EHVRy9WPbR3ARAnqgAJ9nTh24bRVTBOBUvdVzBZYzDxJUvgCgrjHT
0wwenOxGhn9zj4cPNCja9mw =HTkP
-----END PGP SIGNATURE-----

--=-mnl5CdszKcVNiuVSma/3--


--
mailing list
fly.captain
Le #7825321
Jean-François Maeyhieux a écrit :
On Wed, 2007-02-07 at 14:44 +0100, wrote:

Bonjour,

Je me suis aperçu que sur quelques machines utilisant toujours GCC 3.3.6 (je
ne souhaite pas migrer sur ces machines), il y a une version de GCC 3.3.6-r1
dispo mais comme GCC 3.4.6 est installé, emerge ne voit pas la mise à jour.

Est-ce génant d'updater GCC de la sorte, sachant que GCC 3.4.6 est installé,
mais ne sert pas.

emerge 'sys-devel/gcc-3.3.6-r1'

Dans mon cas, il aurait surement été préférable que GCC 3.4.6 ne soit pas
installé, mais bon à l'époque je n'ai pas fait gaffe.
Aussi, j'ai voulu rendre les choses propres et j'ai désinstallé GCC 3.4.6.
Là pas de souci, enfin presque. "emerge" n'est pas content car
"glibc-2.3.6-r5" a besoin de 3.4.6. Du coup, j'ai remis GCC 3.4.6, ne
voulant pas downgrader "glibc".

Je n'ai jusqu'à présent rencontré aucun problème entre GCC 3.3.6 et glibc
2.3.6-r5, mais à priori glibc devrait être utilisé avec GCC 3.4.6 vu la
dépendance ? J'avoue que je nage un peu, je ne connais pas le lien qu'il y a
entre le compilateur GCC et la GNU C Lib.

Vos lumières sont les bienvenues.





Il te faut utiliser "gcc-config -l" pour voir tes versions de gcc
installé puis selectionner le gcc actif avec "gcc-config 1" ou
"gcc-config x" pour selectionner respectivement le premier gccde la
liste ou le xième.




Oui, je sais bien, mais je ne veux pas changer de compilateur, et devoir
tout recompiler.
Mon message était vraiment pas clair ;-)

Merci quand même.

--
mailing list
Poster une réponse
Anonyme