[gentoo-user-fr] Problème de dépendance

Le
Anthony
Salut,
J'essaye d'installer un web-mail, et j'essaye d'installer horde-imp

emerge -p horde-imp :
Calculating dependencies done!
*[blocks B ] dev-php/mod_php (is blocking dev-lang/php-5.0.5-r5)*
*[blocks B ] dev-php/php (is blocking dev-lang/php-5.0.5-r5)*
*[blocks B ] dev-php/mod_php (is blocking dev-php/PEAR-PEAR-1.4.6-r1)*
*[blocks B ] dev-php/php (is blocking dev-php/PEAR-PEAR-1.4.6-r1)*
[ebuild N ] net-libs/c-client-2004a-r1
()
*[ebuild N ] dev-php/mod_php-4.4.0-r9 *
*[ebuild N ] dev-php/php-4.4.0-r4 *
[ebuild N ] app-admin/php-toolkit-1.0-r2
*[ebuild N ] dev-lang/php-5.0.5-r5 *
[ebuild N ] dev-php/PEAR-PEAR-1.4.6-r1
[ebuild N ] dev-php/PEAR-DB-1.7.6-r1
[ebuild N ] dev-php/PEAR-Mail_Mime-1.3.1-r1
[ebuild N ] dev-php/PEAR-File-1.2.2
[ebuild N ] dev-php/PEAR-Log-1.9.3
()
[ebuild N ] app-admin/webapp-config-1.11
[ebuild N ] www-apps/horde-2.2.9
[ebuild N ] www-apps/horde-imp-3.2.8

Mon problème est donc de comprendre pourquoi php 4 et 5 veulent
s'installer ;-)

A+
Anthony

--
gentoo-user-fr@gentoo.org mailing list
Vos réponses
Trier par : date / pertinence
GreenDuck
Le #7563681
Le passage de php de dev-php/(mod) à dev-lang/php occasionne parfois des
ruptures dans les dépendances.

A ta place, je commencerais par installer une version de dev-lang/php (4
ou 5, celle que tu préfères en terme de stabilité et de sécurité, horde
nécessite uniquement php4)

Ensuite, emerge Horde, et tu verras, il n'y aura plus de problème.

En agissant ainsi, tu donnes à ton système une version de php qui te
convient, et le système n'a plus à choisir dans les différentes
versions.

Cordialement

GreenDuck

Le lundi 06 février 2006 à 20:59 +0100, Anthony a écrit :
Salut,
J'essaye d'installer un web-mail, et j'essaye d'installer horde-imp...

emerge -p horde-imp :
Calculating dependencies ...done!
*[blocks B ] dev-php/mod_php (is blocking dev-lang/php-5.0.5-r5)*
*[blocks B ] dev-php/php (is blocking dev-lang/php-5.0.5-r5)*
*[blocks B ] dev-php/mod_php (is blocking dev-php/PEAR-PEAR-1.4.6-r1)*
*[blocks B ] dev-php/php (is blocking dev-php/PEAR-PEAR-1.4.6-r1)*
[ebuild N ] net-libs/c-client-2004a-r1
(...)
*[ebuild N ] dev-php/mod_php-4.4.0-r9 *
*[ebuild N ] dev-php/php-4.4.0-r4 *
[ebuild N ] app-admin/php-toolkit-1.0-r2
*[ebuild N ] dev-lang/php-5.0.5-r5 *
[ebuild N ] dev-php/PEAR-PEAR-1.4.6-r1
[ebuild N ] dev-php/PEAR-DB-1.7.6-r1
[ebuild N ] dev-php/PEAR-Mail_Mime-1.3.1-r1
[ebuild N ] dev-php/PEAR-File-1.2.2
[ebuild N ] dev-php/PEAR-Log-1.9.3
(...)
[ebuild N ] app-admin/webapp-config-1.11
[ebuild N ] www-apps/horde-2.2.9
[ebuild N ] www-apps/horde-imp-3.2.8

Mon problème est donc de comprendre pourquoi php 4 et 5 veulent
s'installer ;-)

A+
Anthony





--
mailing list
Anthony Jaguenaud
Le #7563671
GreenDuck a écrit :
A ta place, je commencerais par installer une version de dev-lang/php (4
ou 5, celle que tu préfères en terme de stabilité et de sécurité, horde
nécessite uniquement php4)



J'ai déjà essayé, mais ce sont les module PERL qui on besoin de php 5,
et php 5 me faisait une erreur de compilation :-(

Je réessaye....


Anthony
--
mailing list
Julien 'ezaekiel' LAVERGNE
Le #7563661
> [ebuild N ] dev-php/PEAR-Mail_Mime-1.3.1-r1
[ebuild N ] dev-php/PEAR-File-1.2.2
[ebuild N ] dev-php/PEAR-Log-1.9.3
(...)
[ebuild N ] app-admin/webapp-config-1.11
[ebuild N ] www-apps/horde-2.2.9 [ebuild N ]
www-apps/horde-imp-3.2.8
Mon problème est donc de comprendre pourquoi php 4 et 5 veulent
s'installer ;-)

A+
Anthony



emerge horde
et ensuite horde-imp


--
mailing list
Publicité
Poster une réponse
Anonyme