[gentoo-user-fr] Problème gcc (deuxième essai)

Le
Anthony Jaguenaud
Bonjour,
J'ai un problème avec gcc.
J'utilise sur un serveur maison, une version hardened de la gentoo.
Je n'arrivais pas installer la nouvelle glibc (2.4-r3). Ayant gcc 4 et
gcc 3, j'ai viré (unmerge gcc 3)
J'ai eu des problèmes de compilation que j'ai tenté de résoudre en
faisant un lien (ln -s gcc-4.1 gcc).

Je suis un peu bloqué depuis un temps certain Comment réinstaller un
gcc (à la mode bootstrap par exemple), pour remettre mon installation
d'aplomb ?

A+
Anthony
P.S.: Oui, je sais, je suis un boulet !

--
gentoo-user-fr@gentoo.org mailing list
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
polytan
Le #7641261
Anthony Jaguenaud a écrit :
Bonjour,
J'ai un problème avec gcc.
J'utilise sur un serveur maison, une version hardened de la gentoo.
Je n'arrivais pas installer la nouvelle glibc (2.4-r3). Ayant gcc 4 et
gcc 3, j'ai viré (unmerge gcc 3)...
J'ai eu des problèmes de compilation que j'ai tenté de résoudre en
faisant un lien (ln -s gcc-4.1 gcc).

Je suis un peu bloqué depuis un temps certain... Comment réinstaller un
gcc (à la mode bootstrap par exemple), pour remettre mon installation
d'aplomb ?

A+
Anthony
P.S.: Oui, je sais, je suis un boulet !



As-tu fais un gcc-config -l et choisi le bon gcc (puis env-update &&
source /etc/profile) ?

Parce que le lien c'est barbare, à mon goût tout du moins ;)

Amitiés,

Polytan
--
mailing list
Anthony Jaguenaud
Le #7641251
a écrit :
Anthony Jaguenaud a écrit :
Bonjour,
J'ai un problème avec gcc.
J'utilise sur un serveur maison, une version hardened de la gentoo.
Je n'arrivais pas installer la nouvelle glibc (2.4-r3). Ayant gcc 4 et
gcc 3, j'ai viré (unmerge gcc 3)...
J'ai eu des problèmes de compilation que j'ai tenté de résoudre en
faisant un lien (ln -s gcc-4.1 gcc).

Je suis un peu bloqué depuis un temps certain... Comment réinstaller un
gcc (à la mode bootstrap par exemple), pour remettre mon installation
d'aplomb ?

A+
Anthony
P.S.: Oui, je sais, je suis un boulet !



As-tu fais un gcc-config -l et choisi le bon gcc (puis env-update &&
source /etc/profile) ?


# gcc-config -l
* gcc-config: Active gcc profile is invalid!
[1] i686-pc-linux-gnu-4.1.1
(la petite étoile est rouge)

Parce que le lien c'est barbare, à mon goût tout du moins ;)


Je l'avais enlevé, parce que rien ne marchait :-(

Anthony
--
mailing list
Jean-François Maeyhieux
Le #7641221
--=-Xe1n6hNZd18ceBaTdk4I
Content-Type: text/plain; charset=ISO-8859-15
Content-Transfer-Encoding: quoted-printable

On Wed, 2006-10-25 at 07:50 +0200, Anthony Jaguenaud wrote:
a écrit :
> Anthony Jaguenaud a écrit :
>> Bonjour,
>> J'ai un problème avec gcc.
>> J'utilise sur un serveur maison, une version hardened de la gentoo.
>> Je n'arrivais pas installer la nouvelle glibc (2.4-r3). Ayant gcc 4 et
>> gcc 3, j'ai viré (unmerge gcc 3)...
>> J'ai eu des problèmes de compilation que j'ai tenté de résoudre en
>> faisant un lien (ln -s gcc-4.1 gcc).
>>
>> Je suis un peu bloqué depuis un temps certain... Comment réinstall er un
>> gcc (à la mode bootstrap par exemple), pour remettre mon installatio n
>> d'aplomb ?
>>
>> A+
>> Anthony
>> P.S.: Oui, je sais, je suis un boulet !
>>
> As-tu fais un gcc-config -l et choisi le bon gcc (puis env-update &&
> source /etc/profile) ?
# gcc-config -l
* gcc-config: Active gcc profile is invalid!
[1] i686-pc-linux-gnu-4.1.1
(la petite étoile est rouge)

> Parce que le lien c'est barbare, à mon goût tout du moins ;)
Je l'avais enlevé, parce que rien ne marchait :-(

Anthony



Le problème est loin d'être simplement la version de gcc configuré ma is
bien le support du hardened avec gcc 4.x. En effet, d'après les posts
récents sur la mailing list gentoo-hardened, gcc-4 n'est pas encore prê t
d'être complètement "hardened". Il semblerait que tu compiles en mode
vanilla avec gcc-4 par défault. Je t'invite à t'inscrire à cette mail ing
list pour être tenu au courant en espérant que l'anglais n'est pas un
problème pour toi.

Sinon voici comme référence un lien sur des archives de la ML pointant
sur le sujet en question, je te conseille de lire le thread en entier:
http://www.mail-archive.com//msg00693.html

Zentoo




--
--------------------------------------------------------------------------- -----------
Jean-François Maeyhieux
--------------------------------------------------------------------------- -----------
PGP Public Key - Key ID = 63DB4770 Tuttle (JFM) http://pgpkeys.mit.edu:11371/pks/lookup?op=get&search=0x63DB4770
--------------------------------------------------------------------------- -----------

--=-Xe1n6hNZd18ceBaTdk4I
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: This is a digitally signed message part

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQBFP1FAHVRy9WPbR3ARAvVXAJ9VO0//uoytrRFdmQYAzVActKk+lwCeLyFo
yBOkrUw9wYBEQfvkCHNZDno =uwlI
-----END PGP SIGNATURE-----

--=-Xe1n6hNZd18ceBaTdk4I--

--
mailing list
Le #7641181
Désolé j'ai oublié de changer le sujet.


--
mailing list
Le #7641171
Bonjour à tous,

Voici le problème récurent que j'ai avec gentoo. Au bout d'un certain,
mes lecteurs vidéo que ce soit vlc ou kaffeine, ne m'affichent plus les
vidéo. Vlc me fait cette erreur :

main error: no suitable access module
for `/mnt/divx/Poirot/Hercule Poirot - [5x08]
- Vol de bijoux à l'hôtel Metropole.avi' main error: no suitable access
module for `/mnt/divx/Poirot/Hercule Poirot - [6x10] - Je ne suis pas
coupable (téléfilm) - FR - [found via ed2k-series.new.fr].avi' main
error: no suitable decoder module for fourcc `XVID'. VLC probably does
not support this sound or video format.

Quelqu'un aurait-il une idée?

Par avance merci

--
mailing list
Le #7641161
Bonjour à tous,

Voici le problème récurent que j'ai avec gentoo. Au bout d'un certain,
mes lecteurs vidéo que ce soit vlc ou kaffeine, ne m'affichent plus les
vidéo. Vlc me fait cette erreur :

main error: no suitable access module
for `/mnt/divx/Poirot/Hercule Poirot - [5x08]
- Vol de bijoux à l'hôtel Metropole.avi' main error: no suitable access
module for `/mnt/divx/Poirot/Hercule Poirot - [6x10] - Je ne suis pas
coupable (téléfilm) - FR - [found via ed2k-series.new.fr].avi' main
error: no suitable decoder module for fourcc `XVID'. VLC probably does
not support this sound or video format.

Quelqu'un aurait-il une idée?

Par avance merci

--
mailing list
Didier LINK
Le #7641151
--=-ociWjHByWrBrkb0U8p8F
Content-Type: text/plain; charset=ISO-8859-15
Content-Transfer-Encoding: quoted-printable

Le samedi 28 octobre 2006 à 16:17 +0200, a écrit :
Bonjour à tous,



Bonjour,


Voici le problème récurent que j'ai avec gentoo. Au bout d'un certain ,
mes lecteurs vidéo que ce soit vlc ou kaffeine, ne m'affichent plus les
vidéo. Vlc me fait cette erreur :

main error: no suitable access module
for `/mnt/divx/Poirot/Hercule Poirot - [5x08]
- Vol de bijoux à l'hôtel Metropole.avi' main error: no suitable acce ss
module for `/mnt/divx/Poirot/Hercule Poirot - [6x10] - Je ne suis pas
coupable (téléfilm) - FR - [found via ed2k-series.new.fr].avi' main
error: no suitable decoder module for fourcc `XVID'. VLC probably does
not support this sound or video format.



On dirait bien que ce codec avi n'est pas reconnu par tes lecteurs. Je
ne connais pas vlc mais kaffeine dépend de la xine-lib, regarde du coté
du support de ffmpeg surtout.

Au passage je suppose que ça n'a rien à voir avec gcc, n'oublie pas de
démarrer un nouveau fil de discussion sinon tu n'auras pas toute l'aide
attendue.

Didier

ps : en plus je suppose que tu as les originaux de ces films ... sinon
ta question n'a rien à faire sur cette liste. A bon entendeur ... :-)


--=-ociWjHByWrBrkb0U8p8F
Content-Type: application/pgp-signature; name=signature.asc
Content-Description: Ceci est une partie de message
=?ISO-8859-1?Q?numériquement?= =?ISO-8859-1?Q?_signée?
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.5 (GNU/Linux)

iD8DBQBFQ2mAkyPwinW6ye4RAvoiAKCZ+J9GiQEokQzmsbnIgv2IqgLzUQCfVWn6
cMC+sEXfaMHGC02ujn4GAMI =mnGQ
-----END PGP SIGNATURE-----

--=-ociWjHByWrBrkb0U8p8F--

--
mailing list
Anthony Jaguenaud
Le #7641141
Quelqu'un pourrait-il me faire un package binaire pour gcc 3.3.6 en i-686 ?

Ca devrait me permettre de le réinstaller correctement.


A+
Anthony
--
mailing list
Christophe PEREZ
Le #7641131
Le Mon, 30 Oct 2006 20:12:47 +0100, Anthony Jaguenaud a écrit :

Quelqu'un pourrait-il me faire un package binaire pour gcc 3.3.6 en i-686 ?



J'ai bien un gcc-3.4.6-r1.tbz2, mais pas de 3.3.6.
Ceci dit, pour la prochaine fois, avec buildsyspkg dans les FEATURES ça
ne devrait pas t'arriver.

--
Christophe PEREZ
--
mailing list
Publicité
Poster une réponse
Anonyme