HS: Fabmanager erreur certbot

Le
raphael.poitevin
Bonsoir,

Bien que mal à l’aise avec les forums s’il vaut mieux =
que je poste sur
celui de fabmanager, dites-moi.

Debian Stretch, docker-ce 5:18.09.4~3-0~debian-stretch

Je me frotte à l’installation de fabmanager en suivant cette d=
oc :
https://github.com/sleede/fab-manager/blob/master/docker/README.md

Tout semble bien se passer jusqu’à l’étape de d=
émarrage de :
sudo systemctl start letsencrypt.service
celui-ci contient cette commande :
[Unit]
Description=letsencrypt cert update oneshot
Requires=docker.service

[Service]
Type=oneshot
ExecStart=/usr/bin/docker run --rm --name letsencrypt -v "/apps/fabmanage=
r/log:/var/log/letsencrypt" -v "/apps/fabmanager/letsencrypt/etc:/etc/letse=
ncrypt" -v "/apps/fabmanager/letsencrypt/config:/letsencrypt-config" quay.i=
o/letsencrypt/letsencrypt:latest -c "/letsencrypt-config/webroot.ini" certo=
nly
ExecStartPost=-/usr/bin/docker restart fabmanager_nginx_1

Vu qu’une erreur m’est retournée, je teste directement=
 :
sudo /usr/bin/docker run --rm --name letsencrypt -v
"/apps/fabmanager/log:/var/log/letsencrypt" -v
"/apps/fabmanager/letsencrypt/etc:/etc/letsencrypt" -v
"/apps/fabmanager/letsencrypt/config:/letsencrypt-config"
quay.io/letsencrypt/letsencrypt:latest -c
"/letsencrypt-config/webroot.ini" certonly

Avec ce retour :

Warning: This Docker image will soon be switching to Alpine Linux.
You can switch now using the certbot/certbot repo on Docker Hub.
/opt/certbot/venv/local/lib/python2.7/site-packages/cryptography/hazmat/pri=
mitives/constant_time.py:26: CryptographyDeprecationWarning: Support for yo=
ur Python version is deprecated. The next version of cryptography will remo=
ve support. Please upgrade to a 2.7.x release that supports hmac.compare_di=
gest as soon as possible.
utils.PersistentlyDeprecated2018,
Use of --agree-dev-preview is deprecated.
usage:
certbot [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN]

Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
it will attempt to use a webserver both for obtaining and installing the
certificate.
certbot: error: unrecognized arguments: --Run docker pull quay.io/letsencry=
pt/letsencrypt:latest

Sauf qu’il n’y a aucun appel à la commande certbot dan=
s ce que j’ai
tapé.

En vous remerciant d’avance. Je ne suis pas familier de docker.

Cordialement,
--
Raphaël
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
G2PC
Le #26514234
Bonsoir,
Bien que mal à l’aise avec les forums s’il vaut mieux que je poste sur
celui de fabmanager, dites-moi.
Debian Stretch, docker-ce 5:18.09.4~3-0~debian-stretch
Je me frotte à l’installation de fabmanager en suivant cette doc :
https://github.com/sleede/fab-manager/blob/master/docker/README.md
Tout semble bien se passer jusqu’à l’étape de démarrage de :
sudo systemctl start letsencrypt.service
celui-ci contient cette commande :
[Unit]
Description=letsencrypt cert update oneshot
Requires=docker.service
[Service]
Type=oneshot
ExecStart=/usr/bin/docker run --rm --name letsencrypt -v "/apps/fabmanager/log:/var/log/letsencrypt" -v "/apps/fabmanager/letsencrypt/etc:/etc/letsencrypt" -v "/apps/fabmanager/letsencrypt/config:/letsencrypt-config" quay.io/letsencrypt/letsencrypt:latest -c "/letsencrypt-config/webroot.ini" certonly
ExecStartPost=-/usr/bin/docker restart fabmanager_nginx_1
Vu qu’une erreur m’est retournée, je teste directement :
sudo /usr/bin/docker run --rm --name letsencrypt -v
"/apps/fabmanager/log:/var/log/letsencrypt" -v
"/apps/fabmanager/letsencrypt/etc:/etc/letsencrypt" -v
"/apps/fabmanager/letsencrypt/config:/letsencrypt-config"
quay.io/letsencrypt/letsencrypt:latest -c
"/letsencrypt-config/webroot.ini" certonly
Avec ce retour :
Warning: This Docker image will soon be switching to Alpine Linux.
You can switch now using the certbot/certbot repo on Docker Hub.
/opt/certbot/venv/local/lib/python2.7/site-packages/cryptography/hazmat/primitives/constant_time.py:26: CryptographyDeprecationWarning: Support for your Python version is deprecated. The next version of cryptography will remove support. Please upgrade to a 2.7.x release that supports hmac.compare_digest as soon as possible.
utils.PersistentlyDeprecated2018,
Use of --agree-dev-preview is deprecated.
usage:
certbot [SUBCOMMAND] [options] [-d DOMAIN] [-d DOMAIN] ...
Certbot can obtain and install HTTPS/TLS/SSL certificates. By default,
it will attempt to use a webserver both for obtaining and installing the
certificate.
certbot: error: unrecognized arguments: --Run docker pull quay.io/letsencrypt/letsencrypt:latest
Sauf qu’il n’y a aucun appel à la commande certbot dans ce que j’ai
tapé.
En vous remerciant d’avance. Je ne suis pas familier de docker.
Cordialement,


Peut être poster aussi sur leur page Github directement, pour leur
permettre d'améliorer leur doc ?
https://github.com/sleede/fab-manager/issues
Publicité
Poster une réponse
Anonyme