Impossible d'installer ma carte réseau Gigabit Marvell Yukon - désespéré...

Le
spamme
Bonjour

Voila un mois que j'ai installé RedHat 9 sur mon ordinateur avec
l'intention de me mettre à Linux. Première constatation : Internet ne
marche pas. Je me rend compte que ma carte réseau (Marvell Yukon
Gigabit Ethernet 10/100/1000Base-T Adapter, Copper RJ-45, intégré à ma
carte mère A7N8X-E Deluxe) n'est pas installée. J'ai cherché pendant
un mois dans tous les forums que je trouvais, j'ai essayé de faire ce
qu'on disait (j'ai trouvé pas mal de fois qu'il fallait copier un
certain fichier dans un répertoire puis faire 'build quelquechose'
je me souviens plus très bien mais je l'ai fait sans succès)

Bref au bout d'un mois, après avoir essayé tout ce qu'on me disait,
toujours pas d'Internet. Quelqu'un sait-il d'où ça peut venir ? Sinon
connaissez vous un tutorial TRES détaillé pour installer une carte
réseau Gigabit (TRES car c'est la première fois que j'installe
Linux..) ?

Merci d'avance

Bruno
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
no_spam
Le #1096577
On Tue, 22 Jun 2004 02:01:45 -0700, Bruno wrote:

Bonjour

Voila un mois que j'ai installé RedHat 9 sur mon ordinateur avec
l'intention de me mettre à Linux. Première constatation : Internet ne
marche pas. Je me rend compte que ma carte réseau (Marvell Yukon
Gigabit Ethernet 10/100/1000Base-T Adapter, Copper RJ-45, intégré à ma
carte mère A7N8X-E Deluxe) n'est pas installée. J'ai cherché pendant
un mois dans tous les forums que je trouvais, j'ai essayé de faire ce
qu'on disait (j'ai trouvé pas mal de fois qu'il fallait copier un
certain fichier dans un répertoire puis faire 'build quelquechose'...
je me souviens plus très bien mais je l'ai fait sans succès)


poste le résultat de cat /proc/pci
Avec un peu de chance, le driver existe et est standard.

Jean-Marie Bonnet
Le #1486027
Le 22 Jun 2004 02:01:45 -0700 ,
(Bruno) a écrit:

Bonjour
Bonjour


Voila un mois que j'ai installé RedHat 9 sur mon ordinateur avec
l'intention de me mettre à Linux. Première constatation : Internet ne
marche pas. Je me rend compte que ma carte réseau (Marvell Yukon
Gigabit Ethernet 10/100/1000Base-T Adapter, Copper RJ-45, intégré à ma
carte mère A7N8X-E Deluxe) n'est pas installée. J'ai cherché pendant
un mois dans tous les forums que je trouvais, j'ai essayé de faire ce
qu'on disait (j'ai trouvé pas mal de fois qu'il fallait copier un
certain fichier dans un répertoire puis faire 'build quelquechose'...
je me souviens plus très bien mais je l'ai fait sans succès)

Bref au bout d'un mois, après avoir essayé tout ce qu'on me disait,
toujours pas d'Internet. Quelqu'un sait-il d'où ça peut venir ? Sinon
connaissez vous un tutorial TRES détaillé pour installer une carte
réseau Gigabit (TRES car c'est la première fois que j'installe
Linux..) ?

Merci d'avance

Bruno
Cette carte a 2 cartes réseau intégrées (j'ai la même):

- la gygabite qui utilise le module sk98lin
- la 100Mbits/s du chip nforce qui utilise le module forcedeth

Ces 2 modules fonctionnent parfaitement avec un noyau 2.6
Je ne peux te dire ce qu'il en est pour un 2.4, essaie la commande
modprobe sk98lin et donne le résultat.

spamme
Le #1096888
Bonjour

Les problemes que j'ai étant apparemment résolus avec le kernel 2.6,
est-il possible de mettre à jour mon kernel sans tout réinstaller (et
sans Internet vu que pour l'instant je n'y ai pas accès avec Linux...)

Petite précision : je n'y connait rien, ne soyez pas avares en
explications SVP :D

Bruno


no_spam
On Tue, 22 Jun 2004 02:01:45 -0700, Bruno wrote:

Bonjour

Voila un mois que j'ai installé RedHat 9 sur mon ordinateur avec
l'intention de me mettre à Linux. Première constatation : Internet ne
marche pas. Je me rend compte que ma carte réseau (Marvell Yukon
Gigabit Ethernet 10/100/1000Base-T Adapter, Copper RJ-45, intégré à ma
carte mère A7N8X-E Deluxe) n'est pas installée. J'ai cherché pendant
un mois dans tous les forums que je trouvais, j'ai essayé de faire ce
qu'on disait (j'ai trouvé pas mal de fois qu'il fallait copier un
certain fichier dans un répertoire puis faire 'build quelquechose'...
je me souviens plus très bien mais je l'ai fait sans succès)


poste le résultat de cat /proc/pci
Avec un peu de chance, le driver existe et est standard.



no_spam
Le #1485992
On Wed, 23 Jun 2004 09:23:24 -0700, Bruno wrote:

Bonjour

Les problemes que j'ai étant apparemment résolus avec le kernel 2.6,
est-il possible de mettre à jour mon kernel sans tout réinstaller (et
sans Internet vu que pour l'instant je n'y ai pas accès avec Linux...)



Le module sk98lin existe en 2.4.
Il faudrait peut-être déjà essayer ça...

L'update d'une version majeure du noyau est plus délicate qu'un
update simple puisqu'il faut souvent aussi mettre à jour un paquet
d'utilitaires (cf le fichier /usr/src/linux/Changes).
Donc, pour commencer, tu devrais plutôt essayer les solutions
possibles avec un 2.4.
Le fait que tu n'ai pas accès à internet sous Linux n'est pas bloquant
en soi si tu y a accès sous un autre OS:
il suffit de télécharger sous cette OS et de récupérer ensuite les
fichiers sous Linux..

Marc
Le #1485962
no_spam wrote:

On Wed, 23 Jun 2004 09:23:24 -0700, Bruno wrote:


Bonjour

Les problemes que j'ai étant apparemment résolus avec le kernel 2.6,
est-il possible de mettre à jour mon kernel sans tout réinstaller (et
sans Internet vu que pour l'instant je n'y ai pas accès avec Linux...)




Bonjour,

peux-tu préciser les problèmes que tu as avec ce chipset Marvell/Yukon ?

En effet, sur la carte Asus K8V SE au moins, ce chipset est buggué et
nécessite un patch pour fonctionner normalement. (regarde le syslog pour
vérifier).

Le noyau 2.6.7 inclu le patch que j'ai fait, mais je peux te l'envoyer
aussi pour un 2.4.x (c'est le même).

Marc.

--
L'I2C sous Windows
http://perso.club-internet.fr/mbouget/index.html

ATTENTION : enlevez les X pour répondre (remove all X to reply)


spamme
Le #1098544
no_spam et Marc
Euh... je suis un peu emm... embêtant je sais mais ce que vous dites

pour moi c'est presque du chinois :S enfin je fais ce que je peux pour
comprendre quoi...

no_spam
J'ai essayé d'installer une espece de patch pour sk98lin que j'avais

trouvé sur Internet et dont on parlait pour mon type de problèmes...
mais sans succès... j'ai peut-être mal fait... suis pas très fort...

Marc
En fait mon problème est tout simplement que linux ne reconnait pas

mon port réseau gigabit Marvell/Yukon et que je ne trouve pas le moyen
de lui faire connaitre... si tu pense que ton patch résout ça je veux
bien que tu me l'envoie à cette adresse : (ne
supporte pas plus de 10 Mo)

Merci !

Bruno


Marc
no_spam wrote:

On Wed, 23 Jun 2004 09:23:24 -0700, Bruno wrote:


Bonjour

Les problemes que j'ai étant apparemment résolus avec le kernel 2.6,
est-il possible de mettre à jour mon kernel sans tout réinstaller (et
sans Internet vu que pour l'instant je n'y ai pas accès avec Linux...)




Bonjour,

peux-tu préciser les problèmes que tu as avec ce chipset Marvell/Yukon ?

En effet, sur la carte Asus K8V SE au moins, ce chipset est buggué et
nécessite un patch pour fonctionner normalement. (regarde le syslog pour
vérifier).

Le noyau 2.6.7 inclu le patch que j'ai fait, mais je peux te l'envoyer
aussi pour un 2.4.x (c'est le même).

Marc.




Publicité
Poster une réponse
Anonyme