impression avec cups

Le
thierry
bonjour

je n'arrive pas a imprimer avec les application (mozilla, openoffice) ,
mais par contre avec les apllication kde et quand je fait un test
d'impression cela marche (par http://locahost:631) .
quand je regarde dans les logs au momment ou j'imprime il ne se passe
rien,ni dans cups ni dans lpd.

quand je fait un lpq (sous root ou pas) voila la reponse :

Printer 'hp1100@localhost' - cannot open connection - Aucun fichier ou
répertoire de ce type
Make sure the remote host supports the LPD protocol
and accepts connections from this host and from non-privileged (>1023)
ports.

j'ai essaye de desactiver mon firewall (shorewall 2.01) c'est pareil.

voila aussi avec la commande lpstat -v :

system for hp1100: localhost
system for all: localhost
Printer 'hp1100@localhost' - cannot open connection - Aucun fichier ou
répertoire de ce type
Make sure the remote host supports the LPD protocol
and accepts connections from this host and from non-privileged (>1023) ports
Printer 'all@localhost' - cannot open connection - Aucun fichier ou
répertoire de ce type
Make sure the remote host supports the LPD protocol
and accepts connections from this host and from non-privileged (>1023) ports

ma config :slackware 9.1 , shorewall 2.01 , snort 2.11

par contre snort me loggue des paquet en local sur le port 631 quand
j'envoie l'impression

exemples :

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993045 127.0.0.1:34104 -> 127.0.0.1:631
TCP TTL:64 TOS:0x0 ID:57297 IpLen:20 DgmLen:52 DF
***A**** Seq: 0xCFD821B7 Ack: 0xD02A73B8 Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393005
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993119 127.0.0.1:631 -> 127.0.0.1:34104
TCP TTL:64 TOS:0x0 ID:35990 IpLen:20 DgmLen:308 DF
***AP*** Seq: 0xD02A73DD Ack: 0xCFD821B7 Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393006
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993141 127.0.0.1:34104 -> 127.0.0.1:631
TCP TTL:64 TOS:0x0 ID:57298 IpLen:20 DgmLen:52 DF
***A**** Seq: 0xCFD821B7 Ack: 0xD02A73DD Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393005
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993170 127.0.0.1:34104 -> 127.0.0.1:631
TCP TTL:64 TOS:0x0 ID:57299 IpLen:20 DgmLen:52 DF
***A**** Seq: 0xCFD821B7 Ack: 0xD02A74DD Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393006
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

mon imprimantes est localiser en /dev/lp0 car en mode console sije fait
un : cat fichier.txt > /dev/lp0 cela s'imprime aussi en root qu'en users.

j'espere avoir ete assez precis sinon n'hesite pas a poser plus de
question et de plus je debute sous slackware.

merci
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
sans_flotus_spam
Le #1532135
thierry wrote:

bonjour

je n'arrive pas a imprimer avec les application (mozilla, openoffice) ,
mais par contre avec les apllication kde et quand je fait un test
d'impression cela marche (par http://locahost:631) .
quand je regarde dans les logs au momment ou j'imprime il ne se passe
rien,ni dans cups ni dans lpd.

quand je fait un lpq (sous root ou pas) voila la reponse :

Printer '' - cannot open connection - Aucun fichier ou
répertoire de ce type
Make sure the remote host supports the LPD protocol
and accepts connections from this host and from non-privileged (>1023)
ports.

j'ai essaye de desactiver mon firewall (shorewall 2.01) c'est pareil.

voila aussi avec la commande lpstat -v :

system for hp1100: localhost
system for all: localhost
Printer '' - cannot open connection - Aucun fichier ou
répertoire de ce type
Make sure the remote host supports the LPD protocol
and accepts connections from this host and from non-privileged (>1023)
ports Printer '' - cannot open connection - Aucun fichier ou
répertoire de ce type
Make sure the remote host supports the LPD protocol
and accepts connections from this host and from non-privileged (>1023)
ports

ma config :slackware 9.1 , shorewall 2.01 , snort 2.11

par contre snort me loggue des paquet en local sur le port 631 quand
j'envoie l'impression

exemples :

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993045 127.0.0.1:34104 -> 127.0.0.1:631
TCP TTL:64 TOS:0x0 ID:57297 IpLen:20 DgmLen:52 DF
***A**** Seq: 0xCFD821B7 Ack: 0xD02A73B8 Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393005
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993119 127.0.0.1:631 -> 127.0.0.1:34104
TCP TTL:64 TOS:0x0 ID:35990 IpLen:20 DgmLen:308 DF
***AP*** Seq: 0xD02A73DD Ack: 0xCFD821B7 Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393006
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993141 127.0.0.1:34104 -> 127.0.0.1:631
TCP TTL:64 TOS:0x0 ID:57298 IpLen:20 DgmLen:52 DF
***A**** Seq: 0xCFD821B7 Ack: 0xD02A73DD Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393005
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993170 127.0.0.1:34104 -> 127.0.0.1:631
TCP TTL:64 TOS:0x0 ID:57299 IpLen:20 DgmLen:52 DF
***A**** Seq: 0xCFD821B7 Ack: 0xD02A74DD Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393006
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

mon imprimantes est localiser en /dev/lp0 car en mode console sije fait
un : cat fichier.txt > /dev/lp0 cela s'imprime aussi en root qu'en users.

j'espere avoir ete assez precis sinon n'hesite pas a poser plus de
question et de plus je debute sous slackware.

merci


apparemment, tu n'as pas donné de nom_de_machine.nom_de_réseau à ta machine,
genre babasse.reseau.net. localhost, c'est la boucle locale. cups a besoin
de connaître une machine sur un réseau.
que raconte la page "printers" du serveur cups
(http://machine.reseau.net:631) ?
A+

thierry
Le #1532107
thierry wrote:


bonjour

je n'arrive pas a imprimer avec les application (mozilla, openoffice) ,
mais par contre avec les apllication kde et quand je fait un test
d'impression cela marche (par http://locahost:631) .
quand je regarde dans les logs au momment ou j'imprime il ne se passe
rien,ni dans cups ni dans lpd.

quand je fait un lpq (sous root ou pas) voila la reponse :

Printer '' - cannot open connection - Aucun fichier ou
répertoire de ce type
Make sure the remote host supports the LPD protocol
and accepts connections from this host and from non-privileged (>1023)
ports.

j'ai essaye de desactiver mon firewall (shorewall 2.01) c'est pareil.

voila aussi avec la commande lpstat -v :

system for hp1100: localhost
system for all: localhost
Printer '' - cannot open connection - Aucun fichier ou
répertoire de ce type
Make sure the remote host supports the LPD protocol
and accepts connections from this host and from non-privileged (>1023)
ports Printer '' - cannot open connection - Aucun fichier ou
répertoire de ce type
Make sure the remote host supports the LPD protocol
and accepts connections from this host and from non-privileged (>1023)
ports

ma config :slackware 9.1 , shorewall 2.01 , snort 2.11

par contre snort me loggue des paquet en local sur le port 631 quand
j'envoie l'impression

exemples :

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993045 127.0.0.1:34104 -> 127.0.0.1:631
TCP TTL:64 TOS:0x0 ID:57297 IpLen:20 DgmLen:52 DF
***A**** Seq: 0xCFD821B7 Ack: 0xD02A73B8 Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393005
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993119 127.0.0.1:631 -> 127.0.0.1:34104
TCP TTL:64 TOS:0x0 ID:35990 IpLen:20 DgmLen:308 DF
***AP*** Seq: 0xD02A73DD Ack: 0xCFD821B7 Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393006
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993141 127.0.0.1:34104 -> 127.0.0.1:631
TCP TTL:64 TOS:0x0 ID:57298 IpLen:20 DgmLen:52 DF
***A**** Seq: 0xCFD821B7 Ack: 0xD02A73DD Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393005
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

[**] BAD-TRAFFIC loopback traffic [**]
04/01-08:42:59.993170 127.0.0.1:34104 -> 127.0.0.1:631
TCP TTL:64 TOS:0x0 ID:57299 IpLen:20 DgmLen:52 DF
***A**** Seq: 0xCFD821B7 Ack: 0xD02A74DD Win: 0x7FFF TcpLen: 32
TCP Options (3) => NOP NOP TS: 393006 393006
=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+=+

mon imprimantes est localiser en /dev/lp0 car en mode console sije fait
un : cat fichier.txt > /dev/lp0 cela s'imprime aussi en root qu'en users.

j'espere avoir ete assez precis sinon n'hesite pas a poser plus de
question et de plus je debute sous slackware.

merci



apparemment, tu n'as pas donné de nom_de_machine.nom_de_réseau à ta machine,
genre babasse.reseau.net. localhost, c'est la boucle locale. cups a besoin
de connaître une machine sur un réseau.
que raconte la page "printers" du serveur cups
(http://machine.reseau.net:631) ?
A+

oK merci pour la reponse je vais essayer


merci


G.Delafond
Le #1031563
<posté comme article et comme courrier>

thierry wrote:

bonjour

je n'arrive pas a imprimer avec les application (mozilla, openoffice) ,
mais par contre avec les apllication kde et quand je fait un test
d'impression cela marche (par http://locahost:631) .
quand je regarde dans les logs au momment ou j'imprime il ne se passe
rien,ni dans cups ni dans lpd.

Si KDE sait imprimer, toutes tes applis savent imprimer.

Il suffit de leur donner "kprinter" comme commande d'impression.
Tu auras accès à toutes les fonctions de kprinter : impression en fax, pdf,
etc.
--
G.Delafond
http://www.delafond.org

Publicité
Poster une réponse
Anonyme