Inclure plus de 8 conditions dans une formule Excel

Le
rochefred
Bonjour,
Je cherche à inclure 12 conditions dans une formule Excel, mais ce dernier
bloque à compter de la 8ème.
J'ai réalisé une formule du genre :
=si(A1=1;A2;si(A1=2;moyenne(A2:A3);si(A1=3;moyenne(A2:A4)
A1 étant le mois en cours.
Auriez vous une alternative à ce problème.
merci d'avance aux bonnes âmes qui parviendront à me débloquer.
Cordialement
Fred
Vos réponses
Trier par : date / pertinence
AV
Le #1899959
J'ai réalisé une formule du genre :
=si(A1=1;A2;si(A1=2;moyenne(A2:A3);si(A1=3;moyenne(A2:A4)...


Si la suite des conditions ressemble aux premières énoncées :

=SI(A1=1;A2;MOYENNE(INDIRECT("A2:A" &A1+1)))

AV

AV
Le #1899948
=MOYENNE(DECALER(A2;;;A1;1))

AV
Joël GARBE
Le #1899947
Bonjour Fred

=CHOISIR(A1;"Janvier";"Février";"Mars";"Avril";"Mai";"Juin";"Juillet";"Août";"Septembre";"Octobre";"Novembre";"Décembre")
en remplaçant :

Janvier par A2
Février par moyenne(A2:A3)
etc...

Mais il doit y avoir encore mieux !!! à chercher

Bon courage
--

Bien cordialement,

Joël GARBE
www.joelgarbe.fr
"rochefred" news:
Bonjour,
Je cherche à inclure 12 conditions dans une formule Excel, mais ce dernier
bloque à compter de la 8ème.
J'ai réalisé une formule du genre :
=si(A1=1;A2;si(A1=2;moyenne(A2:A3);si(A1=3;moyenne(A2:A4)...
A1 étant le mois en cours.
Auriez vous une alternative à ce problème.
merci d'avance aux bonnes âmes qui parviendront à me débloquer.
Cordialement
Fred


Publicité
Poster une réponse
Anonyme