Installation module CPAN

Le
Franck Dia
Bonjour.
Pour installer des modules Perl j'utilise la commande suivante:
perl -MCPAN -e shell
Le problème c'est que cela m'oblige à installer à chaque fois (ça m'ai
arrivé à 2 reprises pour être exact) la dernière version du module CPAN. Et
franchement l'install dure "des plombes".
Existe t'il un moyen d'empécher la mise à jour automatique de ce module?
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Paul GABORIT
Le #434426
À (at) Fri, 16 Apr 2004 01:41:01 +0200,
Franck Dia
Pour installer des modules Perl j'utilise la commande suivante:
perl -MCPAN -e shell
Le problème c'est que cela m'oblige à installer à chaque fois (ça m'ai
arrivé à 2 reprises pour être exact) la dernière version du module CPAN. Et
franchement l'install dure "des plombes".
Existe t'il un moyen d'empécher la mise à jour automatique de ce module?


À ma connaissance, la mise à jour n'est pas obligatoire. Elle est juste
proposée dès que le module s'aperçoit qu'il n'est pas à jour. Rien n'empêche
de continuer à utiliser la version actuellement installée (sauf si un module
que vous voulez installer demande lui-même la mise à jour de CPAN).

Vous pouvez aussi régler la fréquence de mise à jour des 'indices'
(01mailrc.txt.gz, 02packages.details.txt.gz et 03modlist.data.gz) pour éviter
que CPAN se rende compte qu'il n'est pas à jour. Par défaut, il vérifie tous
les jours. Cela se règle via le champs 'index_expire' dans CPAN/Config.pm (la
valeur est en jour).

--
Paul Gaborit - Perl en français -
Franck Dia
Le #434424
Le 16/04/04 18:05, dans , « Paul GABORIT »


À (at) Fri, 16 Apr 2004 01:41:01 +0200,
Franck Dia
Pour installer des modules Perl j'utilise la commande suivante:
perl -MCPAN -e shell
Le problème c'est que cela m'oblige à installer à chaque fois (ça m'ai
arrivé à 2 reprises pour être exact) la dernière version du module CPAN. Et
franchement l'install dure "des plombes".
Existe t'il un moyen d'empécher la mise à jour automatique de ce module?


À ma connaissance, la mise à jour n'est pas obligatoire. Elle est juste
proposée dès que le module s'aperçoit qu'il n'est pas à jour. Rien n'empêche
de continuer à utiliser la version actuellement installée (sauf si un module
que vous voulez installer demande lui-même la mise à jour de CPAN).

Vous pouvez aussi régler la fréquence de mise à jour des 'indices'
(01mailrc.txt.gz, 02packages.details.txt.gz et 03modlist.data.gz) pour éviter
que CPAN se rende compte qu'il n'est pas à jour. Par défaut, il vérifie tous
les jours. Cela se règle via le champs 'index_expire' dans CPAN/Config.pm (la
valeur est en jour).


Merci beaucoup


Publicité
Poster une réponse
Anonyme