Interdire une version précise d’un paquet.

Le
nicolas.patrois
Bonjour,

J’ai ce bogue de gravité critical sur libdns-export1110 (=
1:9.11.17+dfsg-4) <En attente de traitement>
b1 - #954736 - Upgrade to 9.16.1-1 causes dhcpd to die with SIGABRT
Quand je réponds non, il arrête tout. J’aimerais juste qu=
e les mises à jour se fassent mais que ce paquet (et les paquets qui d=
épendent de lui) ne le soit pas.
Je suis obligé de mettre à jour avec aptitude d’autres pa=
quets mais c’est pénible.
Je sais qu’on peut punaiser un paquet mais ça bloque toute mis=
e à jour, pas la mise à jour vers une version précise (ou j=
’ai raté un truc).
Quelqu’un sait comment bloquer juste une version d’un paque=
t dans une mise à jour ?

nicolas patrois : pts noir asocial
--
RÉALISME

M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des =
humains ? Un cerveau plus gros ?
P : Non Une carte bleue suffirait
=
Vos réponses
Trier par : date / pertinence
Cyrille BIOT
Le #26541203
Oups désolé j'avais pas vu la réponse
aptitude forbid-version
Désolé, je ne connaissais pas cette option
merci en tout cas
Cyrille BIOT
Le #26541205
Même soucis
aptitude hold libdns-export1110
ne fait rien, le paquet n'est pas gelé
aptitude search "~ahold"
ihA libglx-mesa0 - free implementation of the
OpenGL API -- G
ThA libreoffice-common - suite de productivité
bureautique -- fichi
Il n'apparait pas dans cette liste
Donc j'attends pour l'instant la résolution de ce bug...

a écrit :
Bonjour,
J’ai ce bogue de gravité critical sur libdns-export1110 (→
1:9.11.17+dfsg-4) <En attente de traitement>
b1 - #954736 - Upgrade to 9.16.1-1 causes dhcpd to die with SIGABRT
Quand je réponds non, il arrête tout. J’aimerais juste que les mises
à jour se fassent mais que ce paquet (et les paquets qui dépendent
de lui) ne le soit pas.
Je suis obligé de mettre à jour avec aptitude d’autres paquets mais
c’est pénible.
Je sais qu’on peut punaiser un paquet mais ça bloque toute mise à
jour, pas la mise à jour vers une version précise (ou j’ai raté un
truc).
Quelqu’un sait comment bloquer juste une version d’un paquet dans
une mise à jour ?
nicolas patrois : pts noir asocial
--
RÉALISME
M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme
des humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...
Cyrille BIOT
Le #26541211
Oui et le hold n'est pas fonctionnel, donc retour cas départ ;)

a écrit :
# aptitude forbid-version libdns-export1110
Le paquet libdns-export1110 n'est pas installé, l'interdiction de
mise à jour n'est pas possible.
nicolas.patrois
Le #26541212
Le 25/03/2020 11:09:41, François LE GAD a écrit :
Bonjour,
aptitude forbid-version [paquet]
Tu peux alors mettre le reste à jour avec aptitude. La mise à j our de
[paquet] est ignorée jusqu'à la publication d'une autre version .

Merci, je ne connaissais pas.
Manque de bol, le paquet n’est pas installé donc ça ne ma rche pas.
# aptitude forbid-version libdns-export1110
Le paquet libdns-export1110 n'est pas installé, l'interdiction de mise à jour n'est pas possible.
nicolas patrois : pts noir asocial
--
RÉALISME
M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...
=
nicolas.patrois
Le #26541217
Le 25/03/2020 12:52:37, Gaëtan Perrier a écrit :
Je vais sûrement dire une bêtise, mais pourquoi vouloir bloquer une
version d'un paquet qui n'est pas installé ?

Il est imposé par la mise à jour d’un autre paquet.
nicolas patrois : pts noir asocial
--
RÉALISME
M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme des humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...
=
Gaëtan Perrier
Le #26541222
------GLTT0PLCJFGVQJR8QXCRP87NL0AUB9
Content-Type: text/plain;
charset=utf-8
Content-Transfer-Encoding: quoted-printable
Dans ce cas tu bloques la mise à jour de l'autre paquet.
Gaëtan
Le 25 mars 2020 13:13:31 GMT+01:00, a é crit :
Le 25/03/2020 12:52:37, Gaëtan Perrier a écrit :
Je vais sûrement dire une bêtise, mais pourquoi vouloir bloqu er une
version d'un paquet qui n'est pas installé ?

Il est imposé par la mise à jour d’un autre paquet.
nicolas patrois : pts noir asocial
--
RÉALISME
M : Qu'est-ce qu'il nous faudrait pour qu'on nous considère comme de s
humains ? Un cerveau plus gros ?
P : Non... Une carte bleue suffirait...

--
Envoyé de mon appareil Android avec Courriel K-9 Mail. Veuillez exc user ma brièveté.
------GLTT0PLCJFGVQJR8QXCRP87NL0AUB9
Content-Type: text/html;
charset=utf-8
Content-Transfer-Encoding: quoted-printable
------GLTT0PLCJFGVQJR8QXCRP87NL0AUB9--
Cyrille BIOT
Le #26541258
Gaëtan Perrier
Dans ce cas tu bloques la mise à jour de l'autre paquet.


Effectivement, il faut geler ces paquets et ça passe
# aptitude search "~ahold"
ih isc-dhcp-client - client DHCP pour l'obtention
automatique d
ih isc-dhcp-common - toutes les pages de manuel
concernant tous
par contre gros soucis dans la mise à jour de la libc6 mais c'est un
autre problème ;)
Publicité
Poster une réponse
Anonyme