interface wifi disparue : WTF ?

Le
Lulu
Yo !

Toujours avec mon portable avec écran et clavier morts

Lors de ma dernière session ssh, j'ai lancé un 'apt-get update' suivi
d'un 'apt-get dist-upgrade' qui a installé le noyau 5.3.0-42-generic

Mais quand j'ai ribouté ce portable, il ne monte pas sur le réseau.

Donc je le branche sur ma téloche avec un clavier usb pour découvrir que
l'interface 'wlp5s0' n'apparaît pas dans la sortie de 'ifconfig -a'
(seule l'interface 'lo' apparaît).

Je profite de l'affichage de la téloche pour rebooter sur le noyau
4.16.0-41600-generic qui monte bien l'interface wlp5s0 et me permet
d'effectuer mes sauvegardes par ssh.

Que puis-je faire pour réveiller mon interface wifi avec ce nouveau
noyau ?

Merci.
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Didier
Le #26542507
Le 07/04/2020 à 21:40, Lulu a écrit :
Yo !
Toujours avec mon portable avec écran et clavier morts...
Lors de ma dernière session ssh, j'ai lancé un 'apt-get update' suivi
d'un 'apt-get dist-upgrade' qui a installé le noyau 5.3.0-42-generic...
Mais quand j'ai ribouté ce portable, il ne monte pas sur le réseau.
Donc je le branche sur ma téloche avec un clavier usb pour découvrir que
l'interface 'wlp5s0' n'apparaît pas dans la sortie de 'ifconfig -a'
(seule l'interface 'lo' apparaît).
Je profite de l'affichage de la téloche pour rebooter sur le noyau
4.16.0-41600-generic qui monte bien l'interface wlp5s0 et me permet
d'effectuer mes sauvegardes par ssh.
Que puis-je faire pour réveiller mon interface wifi avec ce nouveau
noyau ?
Merci.

Sur mon Raspberry, je ne passe plus jamais ces commandes, trop de
risques d'avoir des choses à réparer après, j'ai déjà donné.
Didier.
dyrmak
Le #26542514
En 26 lignes Didier a écrit
dans news:r6ip76$su7$
le mardi, 07 avril 2020 à 22:52:56 :
Le 07/04/2020 à 21:40, Lulu a écrit :
Yo !
Toujours avec mon portable avec écran et clavier morts...
Lors de ma dernière session ssh, j'ai lancé un 'apt-get update' suivi
d'un 'apt-get dist-upgrade' qui a installé le noyau 5.3.0-42-generic...
Mais quand j'ai ribouté ce portable, il ne monte pas sur le réseau.
Donc je le branche sur ma téloche avec un clavier usb pour découvrir que
l'interface 'wlp5s0' n'apparaît pas dans la sortie de 'ifconfig -a'
(seule l'interface 'lo' apparaît).
Je profite de l'affichage de la téloche pour rebooter sur le noyau
4.16.0-41600-generic qui monte bien l'interface wlp5s0 et me permet
d'effectuer mes sauvegardes par ssh.
Que puis-je faire pour réveiller mon interface wifi avec ce nouveau
noyau ?
Merci.

Sur mon Raspberry, je ne passe plus jamais ces commandes, trop de
risques d'avoir des choses à réparer après, j'ai déjà donné.
Didier.

Je ne sais pas s'il faut le signaler mais,....quelqu'un explicait je ne sais
plus où, que l'utilisation des apt aptitudes etc, pouvait entraîner
l'installation ou pas des dépendances qui n'étaient pas forcement
souhaitables dans l'environnement de Linux Mint, autrement dit, il
vaut mieux se contenter du bouclier bleu qui signale le "i" de ses
mises à jour et d'installer les applications seulement avec
l'administrateur de programmes, et comme je suis un gourmand des apt
et autres et bien sur la Mint 19.3 j'en a eu des petites surprises pas
très réjouissantes, le genre de truc qui fait peeeerdre du temps.
Et si on utilisait de nouveau la téloche sur le dernier noyau ?
dyrmak
--
Vive en paz harmonioso
++++ --- ++++
Linux operating system
++++ --- ++++
Lulu
Le #26542536
Le 07-04-2020, dyrmak
En 26 lignes Didier a écrit
Le 07/04/2020 à 21:40, Lulu a écrit :
Toujours avec mon portable avec écran et clavier morts...
Lors de ma dernière session ssh, j'ai lancé un 'apt-get update'
suivi d'un 'apt-get dist-upgrade' qui a installé le noyau
5.3.0-42-generic...
Mais quand j'ai ribouté ce portable, il ne monte pas sur le réseau.
Donc je le branche sur ma téloche avec un clavier usb pour découvrir
que l'interface 'wlp5s0' n'apparaît pas dans la sortie de 'ifconfig
-a' (seule l'interface 'lo' apparaît).
Je profite de l'affichage de la téloche pour rebooter sur le noyau
4.16.0-41600-generic qui monte bien l'interface wlp5s0 et me permet
d'effectuer mes sauvegardes par ssh.
Que puis-je faire pour réveiller mon interface wifi avec ce nouveau
noyau ?
Merci.

Sur mon Raspberry, je ne passe plus jamais ces commandes, trop de
risques d'avoir des choses à réparer après, j'ai déjà donné.
Didier.

Je ne sais pas s'il faut le signaler mais,....quelqu'un explicait je
ne sais plus où, que l'utilisation des apt aptitudes etc, pouvait
entraîner l'installation ou pas des dépendances qui n'étaient pas
forcement souhaitables dans l'environnement de Linux Mint, autrement
dit, il vaut mieux se contenter du bouclier bleu qui signale le "i"
de ses mises à jour et d'installer les applications seulement avec
l'administrateur de programmes, et comme je suis un gourmand des apt
et autres et bien sur la Mint 19.3 j'en a eu des petites surprises
pas très réjouissantes, le genre de truc qui fait peeeerdre du temps.

Je n'ai jamais eu de problème avec apt sur mes 3 linux mint, c'est même
avec apt que je mets à jour la distrib' quand une nouvelle version est
disponible (je suis passé de la 17.2 à la 19.3 sans réinstaller).
Par ailleurs je crois bien que c'est en cliquant sur le bouclier bleu
que ce noyau 5.3.0-42-generic a été installé.
Et si on utilisait de nouveau la téloche sur le dernier noyau ?

Pas compris...
C'est bien en branchant ce PC sur la téloche que j'ai pu voir que la
commande 'ifconfig -a' n'affichait que l'interface loopback.
Quelles commandes passer pour diagnostiquer (et résoudre) le problème ?
dyrmak
Le #26542538
En 52 lignes Lulu a écrit
dans news:
le mercredi, 08 avril 2020 à 09:17:01 :
Je ne sais pas s'il faut le signaler mais,....quelqu'un explicait je
ne sais plus où, que l'utilisation des apt aptitudes etc, pouvait
entraîner l'installation ou pas des dépendances qui n'étaient pas
forcement souhaitables dans l'environnement de Linux Mint, autrement
dit, il vaut mieux se contenter du bouclier bleu qui signale le "i"
de ses mises à jour et d'installer les applications seulement avec
l'administrateur de programmes, et comme je suis un gourmand des apt
et autres et bien sur la Mint 19.3 j'en a eu des petites surprises
pas très réjouissantes, le genre de truc qui fait peeeerdre du temps.

Je n'ai jamais eu de problème avec apt sur mes 3 linux mint, c'est même
avec apt que je mets à jour la distrib' quand une nouvelle version est
disponible (je suis passé de la 17.2 à la 19.3 sans réinstaller).
Par ailleurs je crois bien que c'est en cliquant sur le bouclier bleu
que ce noyau 5.3.0-42-generic a été installé.


Alors ce n'était pas la peine de le signaler, en général apt et
autres c'est ok.
Et si on utilisait de nouveau la téloche sur le dernier noyau ?

Pas compris...

Là encore, dans les Mint Mate 19.3, la configuration network est liée
à Xorg, c'est pas pour rien qu'ils inhibent l'utilisation des tty
autres que celle sur laquelle Xorg se lance, si ça se trouve, une
téloche n'est pas suffissant pour que le network fonctionne, il te faut
peut-être ton écran en état de marche.....
Mais apparemment le noyau d'avant fait fonctionner le network....
C'est bien en branchant ce PC sur la téloche que j'ai pu voir que la
commande 'ifconfig -a' n'affichait que l'interface loopback.
Quelles commandes passer pour diagnostiquer (et résoudre) le problème ?

Sur le noyau d'avant <lspci -k> identifie les modules
<lsmod> les modules chargés
<modinfo nom_du_module>: informations sur le module
Sur le noyau actuel les modules réseaux existent-t-ils ? (wifi,
ethernet)
Il y a aussi les journaux de systemd
dyrmak
--
¿ Cómo era aquello del rayo verde ?
++++ --- ++++
Linux operating system
++++ --- ++++
Pascal Hambourg
Le #26542545
Le 08/04/2020 à 09:17, Lulu a écrit :
Donc je le branche sur ma téloche avec un clavier usb pour découvrir
que l'interface 'wlp5s0' n'apparaît pas dans la sortie de 'ifconfig
-a' (seule l'interface 'lo' apparaît).
Je profite de l'affichage de la téloche pour rebooter sur le noyau
4.16.0-41600-generic qui monte bien l'interface wlp5s0




(...)
Quelles commandes passer pour diagnostiquer (et résoudre) le problème ?

Identifier le contrôleur wifi et son module/driver, à faire avec les
deux noyaux pour comparer :
lspci -nnk
Est-ce un module fourni avec le noyau ou compilé à part ? Dans le second
cas il faut le recompiler pour le nouveau noyau, après avoir installé
les en-têtes du nouveau noyau (linux-headers-xxx) le cas échéant.
Pascal Hambourg
Le #26542544
Le 08/04/2020 à 10:55, dyrmak a écrit :
Là encore, dans les Mint Mate 19.3, la configuration network est liée
à Xorg,

Peux-tu expliquer ? Je ne vois pas le rapport entre le réseau et Xorg.
c'est pas pour rien qu'ils inhibent l'utilisation des tty
autres que celle sur laquelle Xorg se lance,

Et pour quelle raison, au juste ?
si ça se trouve, une
téloche n'est pas suffissant pour que le network fonctionne

Là aussi il va falloir expliquer pourquoi.
Lulu
Le #26542568
Le 08-04-2020, Pascal Hambourg
Le 08/04/2020 à 09:17, Lulu a écrit :
Donc je le branche sur ma téloche avec un clavier usb pour
découvrir que l'interface 'wlp5s0' n'apparaît pas dans la sortie
de 'ifconfig -a' (seule l'interface 'lo' apparaît).
Je profite de l'affichage de la téloche pour rebooter sur le noyau
4.16.0-41600-generic qui monte bien l'interface wlp5s0




(...)
Quelles commandes passer pour diagnostiquer (et résoudre) le problème ?

Identifier le contrôleur wifi et son module/driver, à faire avec les
deux noyaux pour comparer :
lspci -nnk
Est-ce un module fourni avec le noyau ou compilé à part ? Dans le
second cas il faut le recompiler pour le nouveau noyau, après avoir
installé les en-têtes du nouveau noyau (linux-headers-xxx) le cas
échéant.

lspci -nnk me montre que ma carte wifi est une "Ralink corp. RT3090"
avec un "kernel driver in use: rt2800pci"
La première ligne de "modinfo rt2800pci" raconte :
filename: /lib/modules/4.16.0-041600-generic/kernel/drivers/net/wireless/ralink/rt2x00/rt2800pci.ko
Ce qui me donne l'idée de visiter
/lib/modules/5.3.0-42-generic/kernel/drivers/net qui ne contient PAS de
répertoire "wireless" !!
Je remonte dans /lib/modules/5.3.0-42-generic/ et saisi 'ls -lR * | grep
rt' --> pas de fichier rt2800pci (ni de ral*, ou de mac80211)
Je vérifie que j'ai bien les même paquets pour le 4.16 :
linux-headers-4.16.0-041600
linux-headers-4.16.0-041600-generic
linux-image-4.16.0-041600-generic
que pour le nouveau noyau 5.3.0-42 :
linux-headers-5.3.0-42
linux-headers-5.3.0-42-generic
linux-image-5.3.0-42-generic
linux-modules-5.3.0-42-generic
Un coup de 'apt-file update' suivi d'un 'apt-file search rt2800pci.ko'
me montre que le driver a été déplacé dans le paquet linux-modules-extra-5.3.0-42-generic
qui n'est pas installé !!
J'installe et je riboute : c'est 0K, le portable monte sur le réseau
sans intervention de ma part.
Merci à vous pour les pistes d'investigation !
Lulu
Le #26542567
Le 08-04-2020, Pascal Hambourg
Le 08/04/2020 à 09:17, Lulu a écrit :
Donc je le branche sur ma téloche avec un clavier usb pour
découvrir que l'interface 'wlp5s0' n'apparaît pas dans la sortie
de 'ifconfig -a' (seule l'interface 'lo' apparaît).
Je profite de l'affichage de la téloche pour rebooter sur le noyau
4.16.0-41600-generic qui monte bien l'interface wlp5s0




(...)
Quelles commandes passer pour diagnostiquer (et résoudre) le problème ?

Identifier le contrôleur wifi et son module/driver, à faire avec les
deux noyaux pour comparer :
lspci -nnk
Est-ce un module fourni avec le noyau ou compilé à part ? Dans le
second cas il faut le recompiler pour le nouveau noyau, après avoir
installé les en-têtes du nouveau noyau (linux-headers-xxx) le cas
échéant.

lspci -nnk me montre que ma carte wifi est une "Ralink corp. RT3090"
avec un "kernel driver in use: rt2800pci"
La première ligne de "modinfo rt2800pci" raconte :
filename: /lib/modules/4.16.0-041600-generic/kernel/drivers/net/wireless/ralink/rt2x00/rt2800pci.ko
Ce qui me donne l'idée de visiter
/lib/modules/5.3.0-42-generic/kernel/drivers/net qui ne contient PAS de
répertoire "wireless" !!
Je remonte dans /lib/modules/5.3.0-42-generic/ et saisi 'ls -lR * | grep
rt' --> pas de fichier rt2800pci (ni de ral*, ou de mac80211)
Je vérifie que j'ai bien les même paquets pour le 4.16 :
linux-headers-4.16.0-041600
linux-headers-4.16.0-041600-generic
linux-image-4.16.0-041600-generic
que pour le nouveau noyau 5.3.0-42 :
linux-headers-5.3.0-42
linux-headers-5.3.0-42-generic
linux-image-5.3.0-42-generic
linux-modules-5.3.0-42-generic
Un coup de 'apt-file update' suivi d'un 'apt-file search rt2800pci.ko'
me montre que le driver a été déplacé dans le paquet linux-modules-extra-5.3.0-42-generic
qui n'est pas installé !!
J'installe et je riboute : c'est 0K, le portable monte sur le réseau
sans intervention de ma part.
Merci à vous pour les pistes d'investigation !
Pascal Hambourg
Le #26542573
Le 08/04/2020 à 13:55, Lulu a écrit :
Je vérifie que j'ai bien les même paquets pour le 4.16 :
linux-headers-4.16.0-041600
linux-headers-4.16.0-041600-generic
linux-image-4.16.0-041600-generic
que pour le nouveau noyau 5.3.0-42 :
linux-headers-5.3.0-42
linux-headers-5.3.0-42-generic
linux-image-5.3.0-42-generic
linux-modules-5.3.0-42-generic
Un coup de 'apt-file update' suivi d'un 'apt-file search rt2800pci.ko'
me montre que le driver a été déplacé dans le paquet linux-modules-extra-5.3.0-42-generic
qui n'est pas installé !!

Sympa Mint !
Quand Debian scinde un paquet, ce dernier dépend des nouveaux paquets
issus de la scission pour assurer la compatibilité avec l'existant.
ptilou
Le #26542621
Le mardi 7 avril 2020 21:45:03 UTC+2, Lulu a écrit :
Yo !
Toujours avec mon portable avec écran et clavier morts...
Lors de ma dernière session ssh, j'ai lancé un 'apt-get update' suivi
d'un 'apt-get dist-upgrade' qui a installé le noyau 5.3.0-42-generic ...
Mais quand j'ai ribouté ce portable, il ne monte pas sur le rés eau.
Donc je le branche sur ma téloche avec un clavier usb pour déco uvrir que
l'interface 'wlp5s0' n'apparaît pas dans la sortie de 'ifconfig -a'
(seule l'interface 'lo' apparaît).
Je profite de l'affichage de la téloche pour rebooter sur le noyau
4.16.0-41600-generic qui monte bien l'interface wlp5s0 et me permet
d'effectuer mes sauvegardes par ssh.
Que puis-je faire pour réveiller mon interface wifi avec ce nouveau
noyau ?
Merci.

lsusb
lspci
dmesg
ifconfig add !
Publicité
Poster une réponse
Anonyme