Twitter iPhone pliant OnePlus 12 PS5 Disney+ Orange Livebox Windows 11 ChatGPT

Interprétation de

4 réponses
Avatar
Dominique Ottello
Bonjour,

Windows 7 Pro 64bits - Adresse IPv4 et IPv6 fixes.

Je me « bats » depuis un certain temps avec le support d'Avanquest au
sujet du non fonctionnement de LiveUpdate de Driver Genius.

Toutes mes connexions internet IPv4 et IPv6 fonctionnent parfaitement :
Par exemple : http://test-ipv6.com/ me donne 10/10 pour IPv4 et IPv6
Aucun problème avec :
- Mes courriels en envoi et réception sur trois fournisseurs différents
- Firefox, Opera et IE9
- Usenet (la preuve ici)
- FTP sur trois fournisseurs différents
- Mise à jour W7
- Mises à jour semi-automatique pour une dizaine de logiciels
- Serveur local Apache, PHP, MySQL

J'ai utilisé Wireshark pour regarder les paquets qui transitent lors des
appels à LiveUpdate de Driver Genius et n'étant pas un expert, quelques
paquets revenant périodiquement me semblent être la clé du problème :

>84 2.311215 208.53.158.118 82.247.17.31 TCP 1514 [TCP Previous segment lost] [TCP segment of a reassembled PDU]
>85 2.311257 82.247.17.31 208.53.158.118 TCP 66 49308 > http [ACK] Seq=153 Ack=7301 Win=65536 Len=0 SLE=10221 SRE=11681
>86 2.313185 208.53.158.118 82.247.17.31 TCP 1514 [TCP Out-Of-Order] [TCP segment of a reassembled PDU]
>87 2.313198 82.247.17.31 208.53.158.118 TCP 66 49308 > http [ACK] Seq=153 Ack=8761 Win=65536 Len=0 SLE=10221 SRE=11681
>88 2.313889 208.53.158.118 82.247.17.31 TCP 1514 [TCP Out-Of-Order] [TCP segment of a reassembled PDU]
>89 2.314006 82.247.17.31 208.53.158.118 TCP 54 49308 > http [ACK] Seq=153 Ack=11681 Win=65536 Len=0
>90 2.448458 208.53.158.118 82.247.17.31 TCP 1514 [TCP Previous segment lost] [TCP segment of a reassembled PDU]
>91 2.448475 82.247.17.31 208.53.158.118 TCP 66 [TCP Dup ACK 89#1] 49308 > http [ACK] Seq=153 Ack=11681 Win=65536 Len=0 SLE=13141 SRE=14601
>92 2.449663 208.53.158.118 82.247.17.31 TCP 1514 [TCP Out-Of-Order] [TCP segment of a reassembled PDU]
>93 2.449700 82.247.17.31 208.53.158.118 TCP 54 49308 > http [ACK] Seq=153 Ack=14601 Win=65536 Len=0

Pourriez-vous me dire comment pourrait être résolu le problème de
Previous segment lost et Out-Of-Order qui sont très nombreux.

Merci.
--
Ce n'est pas parce qu'ils sont nombreux à avoir tort
qu'ils ont forcément raison. Coluche

4 réponses

Avatar
Xavier Roche
Le 25/09/2011 11:40, Dominique Ottello a écrit :
84 2.311215 208.53.158.118 82.247.17.31 TCP 1514 [TCP Previous segment lost] [TCP segment of a reassembled PDU]
85 2.311257 82.247.17.31 208.53.158.118 TCP 66 49308 > http [ACK] Seq3 Acks01 Wine536 Len=0 SLE221 SRE681





En IPv6 j'aurais dit problème de MTU, mais c'est supposé ne pas pouvoir
arriver en IpV4 (PTMU discovery)

Les "TCP Previous segment lost", ca peut aussi être wireshark qui
n'arrive pas à capturer assez vite ..
Avatar
Erwan David
Xavier Roche écrivait :

Le 25/09/2011 11:40, Dominique Ottello a écrit :
84 2.311215 208.53.158.118 82.247.17.31 TCP 1514 [TCP Previous segment lost] [TCP segment of a reassembled PDU]
85 2.311257 82.247.17.31 208.53.158.118 TCP 66 49308 > http [ACK] Seq3 Acks01 Wine536 Len=0 SLE221 SRE681





En IPv6 j'aurais dit problème de MTU, mais c'est supposé ne pas pouvoir
arriver en IpV4 (PTMU discovery)



Euh il suffit d'un $%£%* qui filtre icmp sur le chemin...
Déjà vérifier que ICMP n'est pas filtré localement...

Les "TCP Previous segment lost", ca peut aussi être wireshark qui
n'arrive pas à capturer assez vite ..



Pas forcément : on a de la fragmentation et il suffit que les fragments
arrivent dans le désordre pour que wireshark affiche ça.

--
Le travail n'est pas une bonne chose. Si ça l'était,
les riches l'auraient accaparé
Avatar
Dominique Ottello
Erwan David écrivait :

Euh il suffit d'un $%£%* qui filtre icmp sur le chemin...
Déjà vérifier que ICMP n'est pas filtré localement...



Le parefeu de W7 est totalement désactivé.
Le problème est identique avec parefeu local actif ou inactif.
Avatar
Dominique Ottello
Dominique Ottello écrivait :

Je me « bats » depuis un certain temps avec le support d'Avanquest au
sujet du non fonctionnement de LiveUpdate de Driver Genius.



Merci pour vos réponses.

L'opiniatreté paie ; après quelques vingt échanges de messages, j'ai
enfin reçu, hier, une réponse positive d'Avanquest :

« Il semble que nous ayons trouvé l'origine du problème. Notre serveur
sera donc rebouté aujourd'hui. Veuillez refaire les mises à jour à
partir de demain. Merci de votre patience et de votre compréhension. »

Et ce matin, plus aucun problème de LiveUpdate.


--
Ce n'est pas parce qu'ils sont nombreux à avoir tort
qu'ils ont forcément raison. Coluche