IP d'interface débranchée répond au ping

Le
Alain Rpnpif
Bonjour,

Sous Squeeze modifié par testing, j'ai deux cartes réseaux eth0 et
eth1. Seule eth1 est branchée.

/etc/network/interfaces
allow-hotplug eth1
auto eth1
iface eth1 inet static
address 192.168.1.23
[]
auto eth0
iface eth0 inet static
address 192.168.1.24


Auriez-vous une idée de la raison qui fait qu'un ping vers
192.168.1.24 (eth0) réponde à partir d'un autre poste du rés=
eau
192.168.1.0 malgré le fait que le câble soit débranché =
? Évidemment les
adresses MAC sont différentes.

Cela fait comme si l'interface eth1 avait deux IP différentes, c'est
que dit l'arp sur le poste appelant. Pourtant ifconfig donne la bonne
info.

--
Alain Rpnpif

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers debian-user-french-REQUEST@lists.debian.org
En cas de soucis, contactez EN ANGLAIS listmaster@lists.debian.org
Archive: http://lists.debian.org/20120226134421.44095D821F@chro.home
Vos réponses Page 2 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pascal Hambourg
Le #24282571
Salut,

Alain Rpnpif a écrit :

Sous Squeeze modifié par testing, j'ai deux cartes réseaux eth0 et
eth1. Seule eth1 est branchée.

/etc/network/interfaces
allow-hotplug eth1
auto eth1
iface eth1 inet static
address 192.168.1.23
[...]
auto eth0
iface eth0 inet static
address 192.168.1.24

Auriez-vous une idée de la raison qui fait qu'un ping vers
192.168.1.24 (eth0) réponde à partir d'un autre poste du réseau
192.168.1.0 malgré le fait que le câble soit débranché ?



Oui : le postulat adopté sous Linux selon lequel les adresses locales
(configurées sur les interfaces de la machine) appartiennent à la
machine et sont utilisables sur toutes les interfaces. On appelle cela
"weak host model". C'est totalement vrai en IPv4 (à l'exception de
127.0.0.0/8 qui n'est utilisable que sur une interface de loopback),
mais avec quelques restrictions en IPv6 à cause des adresses multicast
utilisées pour la découverte du voisinage (équivalent de ARP qui utilise
l'adresse de broadcast).

Cela fait comme si l'interface eth1 avait deux IP différentes, c'est
que dit l'arp sur le poste appelant.



En fait c'est comme si la machine avait deux adresses IP, ce qui est
bien le cas.

Au passage c'est risqué de configurer le même préfixe (sous-réseau) sur
deux interface dont une est déconnectée : il y avait une chance sur deux
que le noyau décide de router les paquets sortants destinés à ce
sous-réseau par l'interface déconnectée.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Pascal Hambourg
Le #24282581
Alain Rpnpif a écrit :

Donc le problème se situe au démarrage de Debian qui ne détecte pas les
câbles débranchés. Savez-vous quel est le programme qui devrait faire ce
travail au démarrage ?



Il me semble que ifplugd est prévu pour ce genre de choses.

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Alain Rpnpif
Le #24282611
Le 26 février 2012, Pascal Hambourg a écrit :

Salut,


Oui : le postulat adopté sous Linux selon lequel les adresses locales
(configurées sur les interfaces de la machine) appartiennent à la
machine et sont utilisables sur toutes les interfaces. On appelle cela
"weak host model". C'est totalement vrai en IPv4 (à l'exception de
127.0.0.0/8 qui n'est utilisable que sur une interface de loopback),
mais avec quelques restrictions en IPv6 à cause des adresses multica st
utilisées pour la découverte du voisinage (équivalent de A RP qui utilise
l'adresse de broadcast).

> Cela fait comme si l'interface eth1 avait deux IP différentes, c'e st
> que dit l'arp sur le poste appelant.

En fait c'est comme si la machine avait deux adresses IP, ce qui est
bien le cas.

Au passage c'est risqué de configurer le même préfixe (sou s-réseau) sur
deux interface dont une est déconnectée : il y avait une chance sur deux
que le noyau décide de router les paquets sortants destinés à   ce
sous-réseau par l'interface déconnectée.




OK, merci de vos réponses.
Allow-hotpkug ne résout pas le problème. Il me semble pourtant qu 'à
l'époque où j'utilisais Mandriva, un câble déconnectà © ne permettait pas
d'activer une interface réseau. C'est aussi le cas d'ubuntu 10 mais
c'est vrai qu'il était en dhcp donc sans adresse IP au départ.
Par contre la déconnexion et reconnexion à chaud fonctionne bien sur
cette Debian.

Je vais voir du côté de ifplugd et aussi changer la config du r éseau.

Merci.

--
Alain Rpnpif

--
Lisez la FAQ de la liste avant de poser une question :
http://wiki.debian.org/fr/FrenchLists

Pour vous DESABONNER, envoyez un message avec comme objet "unsubscribe"
vers
En cas de soucis, contactez EN ANGLAIS
Archive: http://lists.debian.org/
Publicité
Poster une réponse
Anonyme