[Kernel 2.6.3] Divers problèmes

Le
doug
Bonjour à toutes, tous,

J'ai récemment installé un noyau 2.6.3 (compilé par mes soins) sur ma
slackware 9.1 est je me retrouve avec les problèmes suivants :

1/- Lors de l'utilisation de X, la souris (Logitech MouseMan Plus PS/2) est
folle (comme si c'était pas le bon protocole qui était utilisé) et ce
jusqu'à ce que je la débranche et la rebranche.
Le protocole utilisé est "IMPS/2" (Le seul qui m'ait permis d'utiliser la
molette grace au "mapping" des boutons 4 et 5) alors que sous un noyau
2.4.23 j'utilse indépendament "IMPS2" ou "MouseManPlusPS/2".

2/- le "beep" ne fonctionne plus :
- echo -e "\a" ne fait rien !!!
- Quand je reboot, ou que je lance la commande shutdown -H now,
aucun beep ne viens signaler l'arrêt du système

3/- Le lecteur CDROM (/dev/cdrom -> /dev/hdc) n'est plus accessible
- la commande mount /mnt/cdrom renvoie :
- mount : /dev/cdrom is not a valid block device

Pour information :
- Tout fonctionne bien avec un noyau 2.4.23

Pour le CDROM :
- Le support IDE/ATAPI CDROM est activé (BLK_DEV_IDECD = Y)
- L'émulation SCSI est activée (BLK_DEV_IDESCSI = Y)
- /dev file system est désactivé (DEVFS_FS = N)
- /proc fs est activé (PROC_FS = Y)
- ISO9660 CDrom FS est activé (ISO9660_FS = Y) (Avec support Microsoft
joliet)
- UDF file system est activé (UDF_FS = Y)

Pour la souris:
- Support Bus Mouse désactivé (BUSMOUSE = N)
- Mouse Interface est activé (on ne peut pas l'enlever ! INPUT_MOUSEDEV = Y)
- Event interface est activé (INPUT_EVDEV = Y)
- Mice est activé (INPUT_MOUSE = Y)
- PS/2 est activé (MOUSE_PS2 = Y)
- gpm tourne

Bref pour moi, y'a pas de raison que ça ne tourne pas !!!
J'ai chercher sur google, resultat : nada !
Une aide, un lien, une doc me serait précieux alors n'hésitez pas.

D'avance merci.

--
@+
Doug
[Pourquoi t'es qui, qu'est ce que tu fais par où ?]
-- Pour me contacter enlever no-spam (2X) --
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
no_spam
Le #1015263
On Sat, 06 Mar 2004 21:16:43 +0100, doug wrote:

Bonjour à toutes, tous,

J'ai récemment installé un noyau 2.6.3 (compilé par mes soins) sur ma
slackware 9.1 est je me retrouve avec les problèmes suivants :

1/- Lors de l'utilisation de X, la souris (Logitech MouseMan Plus PS/2) est
folle (comme si c'était pas le bon protocole qui était utilisé) et ce
jusqu'à ce que je la débranche et la rebranche.
Le protocole utilisé est "IMPS/2" (Le seul qui m'ait permis d'utiliser la
molette grace au "mapping" des boutons 4 et 5) alors que sous un noyau
2.4.23 j'utilse indépendament "IMPS2" ou "MouseManPlusPS/2".


Conflit gpm/X ?
Il faut utiliser /dev/input/mice pour gpm et /dev/gpmdata pour X
(option -R de gpm).

2/- le "beep" ne fonctionne plus :
- echo -e "\a" ne fait rien !!!
- Quand je reboot, ou que je lance la commande shutdown -H now,
aucun beep ne viens signaler l'arrêt du système


CONFIG_INPUT_PCSPKR pour l'activer ?


3/- Le lecteur CDROM (/dev/cdrom -> /dev/hdc) n'est plus accessible
- la commande mount /mnt/cdrom renvoie :
- mount : /dev/cdrom is not a valid block device

Pour information :
- Tout fonctionne bien avec un noyau 2.4.23

Pour le CDROM :
- Le support IDE/ATAPI CDROM est activé (BLK_DEV_IDECD = Y)
- L'émulation SCSI est activée (BLK_DEV_IDESCSI = Y)
- /dev file system est désactivé (DEVFS_FS = N)


Il faut mettre udev, dans ce cas...
http://www.kernel.org/pub/linux/utils/kernel/hotplug/
Le cdrom marchera quand l'un des deux sera activé, j'en suis sur.

grosnours [F.T.]
Le #1015087
no_spam wrote:
On Sat, 06 Mar 2004 21:16:43 +0100, doug wrote:


Bonjour à toutes, tous,

J'ai récemment installé un noyau 2.6.3 (compilé par mes soins) sur ma
slackware 9.1 est je me retrouve avec les problèmes suivants :

1/- Lors de l'utilisation de X, la souris (Logitech MouseMan Plus PS/2) est
folle (comme si c'était pas le bon protocole qui était utilisé) et ce
jusqu'à ce que je la débranche et la rebranche.
Le protocole utilisé est "IMPS/2" (Le seul qui m'ait permis d'utiliser la
molette grace au "mapping" des boutons 4 et 5) alors que sous un noyau
2.4.23 j'utilse indépendament "IMPS2" ou "MouseManPlusPS/2".



Conflit gpm/X ?
Il faut utiliser /dev/input/mice pour gpm et /dev/gpmdata pour X
(option -R de gpm).


pour être plus précis,

gpm -m /dev/input/mice -t imps2 -R ms
et configurer X avec les lignes suivantes:
Option "Protocol" "MouseSystems"
Option "Device" "/dev/gpmdata"
Option "ZAxisMapping" "4 5"

S'assurer que gpm se lance bien au boot.


Fanf
Le #1018436
no_spam wrote:
On Sat, 06 Mar 2004 21:16:43 +0100, doug wrote:


Bonjour à toutes, tous,




Bonjour,


1/- Lors de l'utilisation de X, la souris (Logitech MouseMan Plus PS/2) est
folle (comme si c'était pas le bon protocole qui était utilisé) et ce
jusqu'à ce que je la débranche et la rebranche.
Le protocole utilisé est "IMPS/2" (Le seul qui m'ait permis d'utiliser la
molette grace au "mapping" des boutons 4 et 5) alors que sous un noyau
2.4.23 j'utilse indépendament "IMPS2" ou "MouseManPlusPS/2".



Conflit gpm/X ?
Il faut utiliser /dev/input/mice pour gpm et /dev/gpmdata pour X
(option -R de gpm).




J'avais le même problème avec une logitech optique. La solution : mettre
le protocole "ExplorerPS/2" dans XF86Config-4 :
http://kerneltrap.org/node/view/2199:(...)

Q:
My mouse wheel is not working in X.
My Logitech (MousManPS/2) mouse stopped working in X.
My extra buttons don't work in X.

A:
Check your XFree86 config file.
Make sure the mouse protocol is set to "ExplorerPS/2", as that is what
the 2.6 kernel exports to applications regardless of the real mouse type.
Make sure you have an "ZAxisMapping 4 5" entry.
Make sure you have an entry for remapping the extra buttons above 5.


Publicité
Poster une réponse
Anonyme