KN3.7 & apt-get upgrade & erreur !

Le
ptiloups
Bonjour,

J'ai une erreur aprs un apt-get upgrade sur une KN3.7
(comment la resoudre sans rinstaller, et passer en commentaire les
lignet testing dans le sources.lists ?)
Merci
Ptilou

L'erreur :


root@monpc:~# apt-get -f install
Lecture des listes de paquets Fait
Construction de l'arbre des dpendances Fait
Correction des dpendances Fait
Les paquets supplmentaires suivants seront installs :
cupsys-bsd cupsys-client libcupsys2-dev libcupsys2-gnutls10
Paquets suggrs :
kdelibs3-cups
Les NOUVEAUX paquets suivants seront installs :
cupsys-client
Les paquets suivants seront mis jour :
cupsys-bsd libcupsys2-dev libcupsys2-gnutls10
3 mis jour, 1 nouvellement installs, 0 enlever et 470 non mis
jour.
7 partiellement installs ou enlevs.
Il est ncessaire de prendre 0o/292ko dans les archives.
Aprs dpaquetage, 340ko d'espace disque supplmentaires seront
utiliss.
Souhaitez-vous continuer ? [O/n] O
debconf: Perl may be unconfigured (Can't locate warnings/register.pm in
@INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.4
/usr/local/share/perl/5.8.4 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at
/usr/share/perl/5.8/vars.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl/5.8/vars.pm line
7.
Compilation failed in require at /usr/share/perl/5.8/File/Spec.pm line
4.
BEGIN failed--compilation aborted at /usr/share/perl/5.8/File/Spec.pm
line 4.
Compilation failed in require at /usr/lib/perl/5.8/IO/File.pm line 12.
BEGIN failed--compilation aborted at /usr/lib/perl/5.8/IO/File.pm line
12.
Compilation failed in require at /usr/share/perl/5.8/FileHandle.pm line
9.
Compilation failed in require at (eval 1) line 3.
BEGIN failed--compilation aborted at (eval 1) line 3.
) -- aborting
Paramtrage de passwd (4.0.3-30.8)
Can't locate warnings/register.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl .) at /usr/share/perl/5.8/vars.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl/5.8/vars.pm line
7.
Compilation failed in require at /usr/share/perl/5.8/base.pm line 4.
BEGIN failed--compilation aborted at /usr/share/perl/5.8/base.pm line
4.
Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line
5.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Log.pm
line 5.
Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 5.
BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm
line 5.
Compilation failed in require at /usr/share/debconf/frontend line 4.
BEGIN failed--compilation aborted at /usr/share/debconf/frontend line
4.
dpkg : erreur de traitement de passwd (--configure) :
le sous-processus post-installation script a retourn une erreur de
sortie d'tat 2
Des erreurs ont t rencontres pendant l'excution :
passwd
Can't locate warnings/register.pm in @INC (@INC contains: /etc/perl
/usr/local/lib/perl/5.8.4 /usr/local/share/perl/5.8.4 /usr/lib/perl5
/usr/share/perl5 /usr/lib/perl/5.8 /usr/share/perl/5.8
/usr/local/lib/site_perl .) at /usr/share/perl/5.8/File/Find.pm line 5.
BEGIN failed--compilation aborted at /usr/share/perl/5.8/File/Find.pm
line 5.
Compilation failed in require at /usr/bin/debsums line 10.
BEGIN failed--compilation aborted at /usr/bin/debsums line 10.
E: Problem executing scripts DPkg::Post-Invoke 'if [ -x
/usr/bin/debsums ]; then /usr/bin/debsums --generate=nocheck -sp
/var/cache/apt/archives; fi'
E: Sub-process returned an error code
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@monpc:~#
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Bruno patri
Le #1223922
Bonjour,

J'ai une erreur après un apt-get upgrade sur une KN3.7
(comment la resoudre sans réinstaller, et passer en commentaire les
lignet testing dans le sources.lists ?)
Merci
Ptilou

L'erreur :


:~# apt-get -f install
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances... Fait
Correction des dépendances... Fait
Les paquets supplémentaires suivants seront installés :
cupsys-bsd cupsys-client libcupsys2-dev libcupsys2-gnutls10
Paquets suggérés :
kdelibs3-cups
Les NOUVEAUX paquets suivants seront installés :
cupsys-client
Les paquets suivants seront mis à jour :
cupsys-bsd libcupsys2-dev libcupsys2-gnutls10
3 mis à jour, 1 nouvellement installés, 0 à enlever et 470 non mis
à jour.
7 partiellement installés ou enlevés.
Il est nécessaire de prendre 0o/292ko dans les archives.
Après dépaquetage, 340ko d'espace disque supplémentaires seront
utilisés.
Souhaitez-vous continuer ? [O/n] O
debconf: Perl may be unconfigured (Can't locate warnings/register.pm in
@INC (@INC contains: /etc/perl /usr/local/lib/perl/5.8.4
/usr/local/share/perl/5.8.4 /usr/lib/perl5 /usr/share/perl5
/usr/lib/perl/5.8 /usr/share/perl/5.8 /usr/local/lib/site_perl .) at
/usr/share/perl/5.8/vars.pm line 7.
BEGIN failed--compilation aborted at /usr/share/perl/5.8/vars.pm line
7.
Compilation failed in require at /usr/share/perl/5.8/File/Spec.pm line
4.


Visiblement il y a un probleme avec les bibliothèques Perl. Il faut les
(ré)installer avec une version >=5.8

--
Bruno

Poster une réponse
Anonyme