La clé de recherche n'a pas été trouvé dans aucun enregistrement

Le
Mimi
Bonjour,

Je distribue mon application développée sur Access XP dans un package avec
le Runtime Access.

Cela fait 2 fois que je me retrouve confrontée au problème suivant :

L'installation se passe bien, toutes les fonctionnalités de l'appli
fonctionnent correctement sauf tout ce qui concerne l'import-export.
Dans mon appli les imports et exports se font via des fichiers .txt et le
message d'erreur qui apparaît est le suivant : "la clé de recherche n'a pas
été trouvée dans aucun enregistrement."

Je n'arrive pas à trouver d'information sur ce message d'erreur.

Qu'est ce qu'il veut dire? quelle est la cause? comment y remédier?

Si vous avez des infos merci par avance.

Mimi
  • Partager ce contenu :
Vos réponses
Trier par : date / pertinence
Gafish
Le #5517931
Bonjour,

Une piste :
http://www.google.fr/groups?hl=fr&lr=&selm=uvQ253gbDHA.1744%40TK2MSFTNGP12.p
hx.gbl

Arnaud

"Mimi"
Bonjour,

Je distribue mon application développée sur Access XP dans un package avec
le Runtime Access.

Cela fait 2 fois que je me retrouve confrontée au problème suivant :

L'installation se passe bien, toutes les fonctionnalités de l'appli
fonctionnent correctement sauf tout ce qui concerne l'import-export.
Dans mon appli les imports et exports se font via des fichiers .txt et le
message d'erreur qui apparaît est le suivant : "la clé de recherche n'a
pas

été trouvée dans aucun enregistrement...."

Je n'arrive pas à trouver d'information sur ce message d'erreur.

Qu'est ce qu'il veut dire? quelle est la cause? comment y remédier?

Si vous avez des infos merci par avance.

Mimi




Mimi
Le #5517861
Bonjour,

Je vais voir si cela peut résoudre mon problème.

Merci

Mimi


"Gafish" news:
Bonjour,

Une piste :

http://www.google.fr/groups?hl=fr&lr=&selm=uvQ253gbDHA.1744%40TK2MSFTNGP12.p

hx.gbl

Arnaud

"Mimi"
Bonjour,

Je distribue mon application développée sur Access XP dans un package
avec


le Runtime Access.

Cela fait 2 fois que je me retrouve confrontée au problème suivant :

L'installation se passe bien, toutes les fonctionnalités de l'appli
fonctionnent correctement sauf tout ce qui concerne l'import-export.
Dans mon appli les imports et exports se font via des fichiers .txt et
le


message d'erreur qui apparaît est le suivant : "la clé de recherche n'a
pas

été trouvée dans aucun enregistrement...."

Je n'arrive pas à trouver d'information sur ce message d'erreur.

Qu'est ce qu'il veut dire? quelle est la cause? comment y remédier?

Si vous avez des infos merci par avance.

Mimi








Mimi
Le #5517791
Re,

Je viens de voir avec les 2 clients chez qui le problème se pose : un a
Access 97 et l'autre n'a pas Access.
Merci pour ta réponse Gafish mais malheureusement elle ne résoud pas mon
problème.

Le message d'erreur (erreur n° 5003709) me fait penser à problème d'index
mais je ne vois pas le rapport avec l'import de fichier texte.
Si vous avez d'autres idées je suis preneuse.

Merci

Mimi

"Mimi" news:
Bonjour,

Je vais voir si cela peut résoudre mon problème.

Merci

Mimi


"Gafish" news:
Bonjour,

Une piste :



http://www.google.fr/groups?hl=fr&lr=&selm=uvQ253gbDHA.1744%40TK2MSFTNGP12.p

hx.gbl

Arnaud





Gafish
Le #5516061
Re,

Tu as un champ numéroauto dans ta table ?

"Mimi" #
Re,

Je viens de voir avec les 2 clients chez qui le problème se pose : un a
Access 97 et l'autre n'a pas Access.
Merci pour ta réponse Gafish mais malheureusement elle ne résoud pas mon
problème.

Le message d'erreur (erreur n° 5003709) me fait penser à problème d'index
mais je ne vois pas le rapport avec l'import de fichier texte.
Si vous avez d'autres idées je suis preneuse.

Merci

Mimi

"Mimi" news:
Bonjour,

Je vais voir si cela peut résoudre mon problème.

Merci

Mimi


"Gafish" news:
Bonjour,

Une piste :





http://www.google.fr/groups?hl=fr&lr=&selm=uvQ253gbDHA.1744%40TK2MSFTNGP12.p

hx.gbl

Arnaud









Mimi
Le #5515661
Bonjour,


Non je n'ai pas de champ numéro auto dans une table. Mes index sont sur des
champs numériques.
Etant donné que le problème se passe chez des clients distants et avec le
runtime pas évident de voir ce qui se passe...

Mon processus d'import se passe en plusieurs phases :
1ere : je vide les tables des données existantes
2 eme : je remplis les tables par un import des fichiers textes

Les messages d'erreurs sont récupérés dans une table puis affichés dans un
état à la fin de l'import :
J'ai plusieurs lignes de " La clé de recherche n'a été trouvée dans
aucun enregistrement."
Puis pour chaque table qui doit être remplis j'ai une ligne de "Le
moteur de base de données Microsoft Jet ne peut pas trouver la table ou la
requête source 'T_ParcelleL'. Assurez-vous qu'elle existe et qu'elle est
correctement orthographiée. - 5003078"
T_ParcelleL étant une de mes tables à remplir mais il me met le même message
pour chaque table.


Merci de intéressé à mon problème en tous cas.

Mimi




"Gafish" news:%
Re,

Tu as un champ numéroauto dans ta table ?

"Mimi" #
Re,

Je viens de voir avec les 2 clients chez qui le problème se pose : un a
Access 97 et l'autre n'a pas Access.
Merci pour ta réponse Gafish mais malheureusement elle ne résoud pas mon
problème.

Le message d'erreur (erreur n° 5003709) me fait penser à problème
d'index


mais je ne vois pas le rapport avec l'import de fichier texte.
Si vous avez d'autres idées je suis preneuse.

Merci

Mimi

"Mimi" news:
Bonjour,

Je vais voir si cela peut résoudre mon problème.

Merci

Mimi


"Gafish" news:
Bonjour,

Une piste :







http://www.google.fr/groups?hl=fr&lr=&selm=uvQ253gbDHA.1744%40TK2MSFTNGP12.p

hx.gbl

Arnaud













Poster une réponse
Anonyme