lecture d'une image dans une requ=c3=aate

Le
Laurent Paris
bonjour à tous,

J'ai une base de données dont une des tables (MYM_FINITION) contient 3
champs :
FINITION : de type texte
DESIGN_FR : de type texte
IMAGE : de type image

Je n'arrive pas à récupérer l'image pour l'insérer dans une zone répétée.
La doc suggère SQLLitMémo(), mais cela ne fonctionne pas

Avez-vous une piste ?
Merci pour votre aide.




Ci-dessous un extrait du code :


// Remplissage des finitions
// -
sdREQ est une Source de Données
sTexteRequete est une chaîne

sTexteRequete=[
SELECT FINITION, DESIGN_FR, IMAGE
FROM MYM_FINITION
WHERE COLLEC='%1'
AND FINITION<>''
ORDER BY FINITION
]
sTexteRequete=ChaîneConstruit(sTexteRequete,SAI_COLLEC)

ZoneRépétéeSupprimeTout(ZR_FINITION)

SI HExécuteRequêteSQL(sdREQ,sTexteRequete) ALORS
POUR TOUT sdREQ
ZoneRépétéeAjouteLigne(ZR_FINITION ,
sdREQ.FINITION , sdREQ.DESIGN_FR , sdREQ.IMAGE)
FIN
HLibèreRequête(sdREQ)
SINON
Erreur(HErreurInfo())
FIN


Cet email a fait l'objet d'une analyse antivirus par AVG.
http://www.avg.com
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Romain PETIT
Le #26438094
Laurent Paris a utilisé son clavier pour écrire :
bonjour à tous,

Bonjour,
J'ai une base de données dont une des tables (MYM_FINITION) contient 3 champs

[...]
sur une base HFSQL ?
A+
--
Romain PETIT
contact : rompetit chez free fr
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup
Laurent Paris
Le #26438097
Le 12/07/2017 à 13:36, Romain PETIT a écrit :
Laurent Paris a utilisé son clavier pour écrire :
bonjour à tous,

Bonjour,
J'ai une base de données dont une des tables (MYM_FINITION) contient 3
champs

[...]
sur une base HFSQL ?
A+

Oui, sur une base HFSQL réseau (pas C/S)
---
Cet email a fait l'objet d'une analyse antivirus par AVG.
http://www.avg.com
Laurent Paris
Le #26438096
Le 12/07/2017 à 13:36, Romain PETIT a écrit :
Laurent Paris a utilisé son clavier pour écrire :
bonjour à tous,

Bonjour,
J'ai une base de données dont une des tables (MYM_FINITION) contient 3
champs

[...]
sur une base HFSQL ?
A+


Entre temps j'ai trouvé une solution pas propre du tout.
Pour résumer : le principe consiste à utiliser l'instruction
HextraitMémo() pour copier sur le disque dur local l'image lue dans la
requête, puis ajouter à la zone répétée l'image créée en local sur le
disque dur.
sTexteRequete=[
SELECT FINITION, DESIGN_FR, IMAGE
FROM MYM_FINITION
WHERE COLLEC='%1'
AND FINITION<>''
ORDER BY FINITION
]
sTexteRequete=ChaîneConstruit(sTexteRequete,SAI_COLLEC)
ZoneRépétéeSupprimeTout(ZR_FINITION)
SI HExécuteRequêteSQL(sdREQ,sTexteRequete) ALORS
POUR TOUT sdREQ
sFichierImage=SysRep(srMesDocuments)+...
"DLLsoftwareTEMPImagefinition_"+sdREQ.FINITION+".png"
SI PAS HExtraitMémo(sdREQ,IMAGE,sFichierImage) ALORS
Erreur(HErreurInfo())
FIN
ZoneRépétéeAjouteLigne(ZR_FINITION , sdREQ.FINITION ,...
sdREQ.DESIGN_FR,sFichierImage)
FIN
HLibèreRequête(sdREQ)
SINON
Erreur(HErreurInfo())
FIN

---
Cet email a fait l'objet d'une analyse antivirus par AVG.
http://www.avg.com
Romain PETIT
Le #26438099
Laurent Paris a présenté l'énoncé suivant :
Entre temps j'ai trouvé une solution pas propre du tout.

Je viens de tester (je vais en avoir besoin prochainement)
Ca marche de mon côté (WD22-63k)
- Fichier F_IMAGE d'une base HF classic ou SQL
- Rubriques : BIN_IMAGE (mémo image) + libellé Image (texte)
- ZR avec 1 libellé et un champ image, attribut 1 sur libellé, attribut
2 sur champ image
******
sTexteRequete est une chaîne
sdReq est un Source de Données
sTexteRequete=[
SELECT *
FROM F_IMAGE
]
ZoneRépétéeSupprimeTout(ZR_Images)
SI HExécuteRequêteSQL(sdReq,sTexteRequete) ALORS
POUR TOUT sdReq
ZoneRépétéeAjouteLigne(ZR_Images , sdReq.LIB_IMAGE,sdReq.BIN_IMAGE)
FIN
HLibèreRequête(sdReq)
SINON
Erreur(HErreurInfo())
FIN
=> J'ai bien les images qui s'affichent...
--
Romain PETIT
contact : rompetit chez free fr
+-+ posté sur Usenet avec MesNews et non depuis un forum web +-+
news:fr.comp.developpement.agl.windev
http://www.mesnews.net/
http://fr.wikipedia.org/wiki/Newsgroup
Publicité
Poster une réponse
Anonyme