Lien réseau erroné après enregistrement

Le
Jéjé
Bonjour,

J'ai développé une macro qui réalise 2 liens c'est-à-dire que je lui précise
la fin d'un chemin (ex : "numdossiergestionfichier.pdf") et la macro
réalise 2 liens qui sont les suivants :

1 lien réseau :
\domaineepumdossiergestionfichier.pdf

1 lien local :
C:portabletestumdossiergestionfichier.pdf


Jusque là, la macro fonctionne très bien car les liens créés correspondent
bien au fichier réellement présent.

Par contre, lorsque j'enregistre mon fichier Excel, le lien local ne change
pas et fonctionne bien mais le lien réseau ne fonctionne plus et lorsque je
clique droit sur le lien puis "modifier", le chemin indiqué n'ai plus
"\domaineepumdossiergestionfichier.pdf" mais plutôt :

../../numdossier/gestion/fichier.pdf


A noter que cela se produit après l'enregistrement du fichier (avant, le
lien est cliqué plusieurs fois sans problème).
De plus, le lien erroné qui est mis à la place de celui que j'ai indiqué
dans ma macro remplace les antislaches par des slaches

Comment cela se fait-il que le lien change ?
Comment est-ce que je peux verrouiller ce lien ?
Et la macro peut-elle être modifiée pour verrouiller ce lien ?

Merci d'avance
Jéjé

P.S. : je peux copier la macro si cela peut aider
Vos réponses
Trier par : date / pertinence
Oliv'
Le #3588791
Bonjour,

J'ai développé une macro qui réalise 2 liens c'est-à-dire que je lui
précise la fin d'un chemin (ex : "numdossiergestionfichier.pdf") et
la macro réalise 2 liens qui sont les suivants :

1 lien réseau :
\domainerepnumdossiergestionfichier.pdf

1 lien local :
C:portabletestnumdossiergestionfichier.pdf


Jusque là, la macro fonctionne très bien car les liens créés
correspondent bien au fichier réellement présent.

Par contre, lorsque j'enregistre mon fichier Excel, le lien local ne
change pas et fonctionne bien mais le lien réseau ne fonctionne plus
et lorsque je clique droit sur le lien puis "modifier", le chemin
indiqué n'ai plus "\domainerepnumdossiergestionfichier.pdf" mais
plutôt :

../../numdossier/gestion/fichier.pdf


A noter que cela se produit après l'enregistrement du fichier (avant,
le lien est cliqué plusieurs fois sans problème).
De plus, le lien erroné qui est mis à la place de celui que j'ai
indiqué dans ma macro remplace les antislaches par des slaches...

Comment cela se fait-il que le lien change ?
Comment est-ce que je peux verrouiller ce lien ?
Et la macro peut-elle être modifiée pour verrouiller ce lien ?

Merci d'avance
Jéjé

P.S. : je peux copier la macro si cela peut aider ...



tu parles de liens hypertextes ?
j'ai déjà vu cela lorsque je faisais un "envoyer vers" /destinataire /en
tant que piece attachée.
mais après un enregistrement normal cela fonctionnait.


--
--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Have a nice day
Oliv'
Pour me joindre : http://cerbermail.com/?V8r2o1YHl4
les sites références:
Excel :http://www.excelabo.net http://xcell05.free.fr/
http://dj.joss.free.fr/
http://frederic.sigonneau.free.fr/ http://www.excel-vba-francais.com/
Word : http://faqword.free.fr/
Outlook :http://faq.outlook.free.fr/
Sql :http://sqlpro.developpez.com/
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

Jéjé
Le #3588191
Oui ce sont bien les liens hypertextes d'Excel qui me pose problème.



Bonjour,

J'ai développé une macro qui réalise 2 liens c'est-à-dire que je lui
précise la fin d'un chemin (ex : "numdossiergestionfichier.pdf") et
la macro réalise 2 liens qui sont les suivants :

1 lien réseau :
\domainerepnumdossiergestionfichier.pdf

1 lien local :
C:portabletestnumdossiergestionfichier.pdf


Jusque là, la macro fonctionne très bien car les liens créés
correspondent bien au fichier réellement présent.

Par contre, lorsque j'enregistre mon fichier Excel, le lien local ne
change pas et fonctionne bien mais le lien réseau ne fonctionne plus
et lorsque je clique droit sur le lien puis "modifier", le chemin
indiqué n'ai plus "\domainerepnumdossiergestionfichier.pdf" mais
plutôt :

../../numdossier/gestion/fichier.pdf


A noter que cela se produit après l'enregistrement du fichier (avant,
le lien est cliqué plusieurs fois sans problème).
De plus, le lien erroné qui est mis à la place de celui que j'ai
indiqué dans ma macro remplace les antislaches par des slaches...

Comment cela se fait-il que le lien change ?
Comment est-ce que je peux verrouiller ce lien ?
Et la macro peut-elle être modifiée pour verrouiller ce lien ?

Merci d'avance
Jéjé

P.S. : je peux copier la macro si cela peut aider ...



tu parles de liens hypertextes ?
j'ai déjà vu cela lorsque je faisais un "envoyer vers" /destinataire /en
tant que piece attachée.
mais après un enregistrement normal cela fonctionnait.


--
--
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Have a nice day
Oliv'
Pour me joindre : http://cerbermail.com/?V8r2o1YHl4
les sites références:
Excel :http://www.excelabo.net http://xcell05.free.fr/
http://dj.joss.free.fr/
http://frederic.sigonneau.free.fr/ http://www.excel-vba-francais.com/
Word : http://faqword.free.fr/
Outlook :http://faq.outlook.free.fr/
Sql :http://sqlpro.developpez.com/
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~








Publicité
Poster une réponse
Anonyme