liens qui ne s'ouvrent pas....

Le
Fran=c3=a7ois Patte
Bonjour,

J'ai un problème avec des liens hypertextes sur un site (expérimental):
on voit que ces liens sont "clicables" (le pointeur de la souris
l'indique) mais quand on clique, rien ne se passe. Un "clic droit" pour
copier l'adresse et l'ouvrir dans un nouvel onglet fonctionne.

Ceci sous linux (fedora, centos, debian, pas d'ubuntu à ma disposition)
avec firefox, opera, google-chrome, vivaldi.

J'ai testé sur une machine virtuelle avec win7: même problème avec
firefox, ça marche avec IE.

Il paraît que ça marche sous mac.

Je me demande si le développeur du site n'utilise pas des procédures qui
ne fonctionneraient que sous windows.

Quelqu'un a-t-il une suggestion pour corriger le problème.

Merci
--
François Patte
Université Paris Descartes
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Sergio
Le #26449095
Le 25/10/2017 à 19:25, François Patte a écrit :
J'ai un problème avec des liens hypertextes sur un site (expérimental):
on voit que ces liens sont "clicables" (le pointeur de la souris
l'indique) mais quand on clique, rien ne se passe. Un "clic droit" pour
copier l'adresse et l'ouvrir dans un nouvel onglet fonctionne.
Ceci sous linux (fedora, centos, debian, pas d'ubuntu à ma disposition)
avec firefox, opera, google-chrome, vivaldi.
J'ai testé sur une machine virtuelle avec win7: même problème avec
firefox, ça marche avec IE.
Il paraît que ça marche sous mac....
Je me demande si le développeur du site n'utilise pas des procédures qui
ne fonctionneraient que sous windows.
Quelqu'un a-t-il une suggestion pour corriger le problème.
Merci

Je précise que j'ai démarré FF sans modules activés....

Pas ça alors, un peu plus haut, j'avais le même problème sur le site du Monde (sujet "Liens sur les pages du "Monde"), du au bloqueur de pub.
Clic-droit, "ouvrir dans un nouvel onglet" ça ne marche pas non plus ?
--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Droger Jean-Paul
Le #26449099
François Patte vient de nous annoncer :
Le 25/10/2017 à 19:21, François Patte a écrit :
Bonjour,
J'ai un problème avec des liens hypertextes sur un site (expérimental):
on voit que ces liens sont "clicables" (le pointeur de la souris
l'indique) mais quand on clique, rien ne se passe. Un "clic droit" pour
copier l'adresse et l'ouvrir dans un nouvel onglet fonctionne.
Ceci sous linux (fedora, centos, debian, pas d'ubuntu à ma disposition)
avec firefox, opera, google-chrome, vivaldi.
J'ai testé sur une machine virtuelle avec win7: même problème avec
firefox, ça marche avec IE.
Il paraît que ça marche sous mac....
Je me demande si le développeur du site n'utilise pas des procédures qui
ne fonctionneraient que sous windows.
Quelqu'un a-t-il une suggestion pour corriger le problème.
Merci


Je précise que j'ai démarré FF sans modules activés....

Bonsoir,
sous win il faut souvent faire CTRL et cliquer gauche pour ouvrir un
lien!!
Bonne soirée.
--
Pour m'envoyer un mail, remplacer anti par droger , fruit par wanadoo
et supprimer .invalid; to send me directly a mail replace anti with
droger, fruit with wanadoo and delete .invalid;

Jo Engo
Le #26449193
Le Wed, 25 Oct 2017 19:21:28 +0200, François Patte a écrit :
Quelqu'un a-t-il une suggestion pour corriger le problème.


Avoir le source de la page peut aider
--
Un sage se distingue des autres hommes, non par moins de folie, mais par
plus de raison.
-+- Émile Chartier, dit Alain (1868-1951), Idées -+-
zeLittle
Le #26449243
Le Fri, 27 Oct 2017 15:55:58 +0200, Jo Engo
Le Wed, 25 Oct 2017 19:21:28 +0200, François Patte a écrit :
Quelqu'un a-t-il une suggestion pour corriger le problème.

Avoir le source de la page peut aider


Effectivement, une ancre HTML <url> est basique depuis des dizaines
d'années. Elle a la même grammaire pour tous les navigateurs.
Si elle ne comporte différemment selon le navigateur, c'est qu'il d oit y
avoir une surcouche logiciel. Hyothèse: une sur-couche de javascrip t - qui
peut par exemple (mal?) coder l'appel à l'ancre différemment s elon le
navigateur (mal?) détecté par le code javascript.
Tu ne pourras trouver qu'en analysant le code source de la page.
Denis Beauregard
Le #26449592
Le Thu, 26 Oct 2017 18:15:59 +0200, Droger Jean-Paul
fr.comp.infosystemes.www.navigateurs:
sous win il faut souvent faire CTRL et cliquer gauche pour ouvrir un
lien!!

J'utilise Windows 7 et plusieurs navigateurs (SM, FF et Chrome) et je
n'ai pas ce problème.
Par contre, il m'est arrivé de tomber sur des liens qui ne répondaient
pas directement et j'ai contourné en recopiant le lien.
Ceci dit, je génère des pages sur mon ordi et je ne peux cliquer sur
un lien externe que si j'ai suivi une certaine procédure pour
permettre au navigateur de lire une page externe depuis une page
locale. Il est possible que la page de départ soit perçue comme locale
(il faudrait qu'on ait l'URL pour vérifier).
Denis
Sergio
Le #26449593
Le 30/10/2017 à 17:00, Denis Beauregard a écrit :
Le Thu, 26 Oct 2017 18:15:59 +0200, Droger Jean-Paul
sous win il faut souvent faire CTRL et cliquer gauche pour ouvrir un
lien!!

J'utilise Windows 7 et plusieurs navigateurs (SM, FF et Chrome) et je
n'ai pas ce problème.
Par contre, il m'est arrivé de tomber sur des liens qui ne répondaient
pas directement et j'ai contourné en recopiant le lien.

La question que j'ai posé précédemment dans ce fil : Clic-droit "Ouvrir dans un onglet" fonctionne ?
Ceci dit, je génère des pages sur mon ordi et je ne peux cliquer sur
un lien externe que si j'ai suivi une certaine procédure pour
permettre au navigateur de lire une page externe depuis une page
locale. Il est possible que la page de départ soit perçue comme locale
(il faudrait qu'on ait l'URL pour vérifier).

??? Depuis des lustres, j'utilise une page en locale (avec plein de liens) sur l'ordi, jamais vu ce genre de problème...
--
Serge http://leserged.online.fr/
Mon blog: http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Publicité
Poster une réponse
Anonyme