limiter valeurs

Le
Claude
Bonjour,

Dans mon principe "code postal" et "ville", j'ai la
cellule A2 avec les codes et la cellule A3 avec les villes.
J'utilise une zonne nomme 2 colonnes.
dans ma cellule A2, saisie manuelle, dans ma cellule A3,
la formule est =RECHERCHEV(A2;code_apac;2)
Mais comment limiter la saisie en cellule A2 (codes) aux
seules valeurs existantes pour ne pas avoir d'affichages
non conformes..
Merci de votre aide
Claude
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Simnet
Le #1268633
Bonjour,
Tu peux, par exemple, créer un menu déroulant qui va
chercher tes valeurs dans une autre feuille.
Ou créer une petite macro de vérification avec un select
case de ta cellule.

Simnet.
-----Message d'origine-----
Bonjour,

Dans mon principe "code postal" et "ville", j'ai la
cellule A2 avec les codes et la cellule A3 avec les
villes.

J'utilise une zonne nommée à 2 colonnes.
dans ma cellule A2, saisie manuelle, dans ma cellule A3,
la formule est =RECHERCHEV(A2;code_apac;2)...
Mais comment limiter la saisie en cellule A2 (codes) aux
seules valeurs existantes pour ne pas avoir d'affichages
non conformes..
Merci de votre aide
Claude
.



Claude
Le #1268630
Merci, mais je suis novice et je ne sais pas coder la
macro...

Claude
-----Message d'origine-----
Bonjour,
Tu peux, par exemple, créer un menu déroulant qui va
chercher tes valeurs dans une autre feuille.
Ou créer une petite macro de vérification avec un select
case de ta cellule.

Simnet.
-----Message d'origine-----
Bonjour,

Dans mon principe "code postal" et "ville", j'ai la
cellule A2 avec les codes et la cellule A3 avec les
villes.

J'utilise une zonne nommée à 2 colonnes.
dans ma cellule A2, saisie manuelle, dans ma cellule A3,
la formule est =RECHERCHEV(A2;code_apac;2)...
Mais comment limiter la saisie en cellule A2 (codes) aux
seules valeurs existantes pour ne pas avoir d'affichages
non conformes..
Merci de votre aide
Claude
.

.





Simnet
Le #1268625
La syntaxe du "select case" est la suivante :

Select Case cells(LigneDeTaCellule, ColonneDeTaCellule)
Case 1
Action à faire
Case 2
Action à faire
Case 3
Action à faire
Case else
Action à faire
End Select

J'espère que ça pourra t'aider.

Simnet.
-----Message d'origine-----
Merci, mais je suis novice et je ne sais pas coder la
macro...

Claude
-----Message d'origine-----
Bonjour,
Tu peux, par exemple, créer un menu déroulant qui va
chercher tes valeurs dans une autre feuille.
Ou créer une petite macro de vérification avec un select
case de ta cellule.

Simnet.
-----Message d'origine-----
Bonjour,

Dans mon principe "code postal" et "ville", j'ai la
cellule A2 avec les codes et la cellule A3 avec les
villes.

J'utilise une zonne nommée à 2 colonnes.
dans ma cellule A2, saisie manuelle, dans ma cellule
A3,



la formule est =RECHERCHEV(A2;code_apac;2)...
Mais comment limiter la saisie en cellule A2 (codes)
aux



seules valeurs existantes pour ne pas avoir
d'affichages



non conformes..
Merci de votre aide
Claude
.

.


.






Claude
Le #1268622
Merci
-----Message d'origine-----
La syntaxe du "select case" est la suivante :

Select Case cells(LigneDeTaCellule, ColonneDeTaCellule)
Case 1
Action à faire
Case 2
Action à faire
Case 3
Action à faire
Case else
Action à faire
End Select

J'espère que ça pourra t'aider.

Simnet.
-----Message d'origine-----
Merci, mais je suis novice et je ne sais pas coder la
macro...

Claude
-----Message d'origine-----
Bonjour,
Tu peux, par exemple, créer un menu déroulant qui va
chercher tes valeurs dans une autre feuille.
Ou créer une petite macro de vérification avec un
select



case de ta cellule.

Simnet.
-----Message d'origine-----
Bonjour,

Dans mon principe "code postal" et "ville", j'ai la
cellule A2 avec les codes et la cellule A3 avec les
villes.

J'utilise une zonne nommée à 2 colonnes.
dans ma cellule A2, saisie manuelle, dans ma cellule
A3,



la formule est =RECHERCHEV(A2;code_apac;2)...
Mais comment limiter la saisie en cellule A2 (codes)
aux



seules valeurs existantes pour ne pas avoir
d'affichages



non conformes..
Merci de votre aide
Claude
.

.


.


.







papou
Le #1268613
Bonjour Claude
Sans macro :
tu définis une zone nommée contenant tes codes postaux par Insertion Nom
Définir
dans ta colonne A à partir de A2 tu sélectionnes les cellules où tu veux
restreindre la saisie
Données, Validation, Autoriser = Liste, Source =TaZoneNommée
Cordialement
Pascal

"Claude" 340401c4291c$058b87f0$
Bonjour,

Dans mon principe "code postal" et "ville", j'ai la
cellule A2 avec les codes et la cellule A3 avec les villes.
J'utilise une zonne nommée à 2 colonnes.
dans ma cellule A2, saisie manuelle, dans ma cellule A3,
la formule est =RECHERCHEV(A2;code_apac;2)...
Mais comment limiter la saisie en cellule A2 (codes) aux
seules valeurs existantes pour ne pas avoir d'affichages
non conformes..
Merci de votre aide
Claude
Claude
Le #1268588
Super Pascal, un grand merci
Claude
-----Message d'origine-----
Bonjour Claude
Sans macro :
tu définis une zone nommée contenant tes codes postaux
par Insertion Nom

Définir
dans ta colonne A à partir de A2 tu sélectionnes les
cellules où tu veux

restreindre la saisie
Données, Validation, Autoriser = Liste, Source
=TaZoneNommée

Cordialement
Pascal

"Claude" news:

340401c4291c$058b87f0$
Bonjour,

Dans mon principe "code postal" et "ville", j'ai la
cellule A2 avec les codes et la cellule A3 avec les
villes.

J'utilise une zonne nommée à 2 colonnes.
dans ma cellule A2, saisie manuelle, dans ma cellule A3,
la formule est =RECHERCHEV(A2;code_apac;2)...
Mais comment limiter la saisie en cellule A2 (codes) aux
seules valeurs existantes pour ne pas avoir d'affichages
non conformes..
Merci de votre aide
Claude


.



Publicité
Poster une réponse
Anonyme