Linux Mint 19 erreur au boot : couldn't get size

Le
Pierre www.aribaut.com
Hello, c'est la 1ère fois que cela m'arrive avec Linux Mint.
L'historique : à un moment donné, je ne pouvais plus cliquer sur rien,
aucun menu, rien ne répond, je peux bouger le curseur mais au clic aucun
menu ne réagit, un appui court bouton power ne propose pas d'éteindre,
ne pouvant rien faire d'autre, j'appuie donc plusieurs secondes sur
power pour forcer l'extinction de l'ordinateur.
Je redémarre et là j'ai le menu pour lancer linux mint puis un message
d'erreur au boot "couldn't get size", le logo mint qui clignote et toute
une série d'erreurs, de trucs, une longue série de commandes qui se fait
J'ai enfin la main, la session remarche.
Je relance et là c'est le drame, il n'arrive plus à booter, de nouveau
l'erreur, logo qui clignote puis cela tourne en rond avec sa série de
commandes, et cela foire deux fois de suite
Je commence à prendre peur pour les quelques fichiers que j'avais sur le
disque dur, je reboot et j'essaie de lancer un live usb linux et il
plante aussi (menu qui apparaît et disparaît en permanence, pas moyen de
faire quelque chose), je coupe l'ordinateur plus longtemps, je relance
et linux mint arrive à se lancer, j'en profite pour sauvegarder les
quelques fichiers sur disque usb.
Je fais les mises à jour, entre autres une mise à jour du noyau qui
m'est proposée.
De nouveau je ferme tout et je redémarre, et là cela redémarre bien,
sans erreur, sans logo qui tremble etc..
J'ai redémarré plusieurs fois depuis, et l'erreur n'est pas revenue.
Qu'est-ce que cela pouvait être cette erreur "couldn't get size" ? Un
problème de noyau ? De bios ? Du boot grub ?
J'ai pas compris ce qu'il s'est passé
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Vos réponses Page 1 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Pierre www.aribaut.com
Le #26493835
Le 26/10/2018 à 18:51, Pierre www.aribaut.com a écrit :
Hello, c'est la 1ère fois que cela m'arrive avec Linux Mint.
L'historique : à un moment donné, je ne pouvais plus cliquer sur rien,
aucun menu, rien ne répond, je peux bouger le curseur mais au clic aucun
menu ne réagit, un appui court bouton power ne propose pas d'éteindre,
ne pouvant rien faire d'autre, j'appuie donc plusieurs secondes sur
power pour forcer l'extinction de l'ordinateur.
Je redémarre et là j'ai le menu pour lancer linux mint puis un message
d'erreur au boot "couldn't get size", le logo mint qui clignote et toute
une série d'erreurs, de trucs, une longue série de commandes qui se fait...
J'ai enfin la main, la session remarche.
Je relance et là c'est le drame, il n'arrive plus à booter, de nouveau
l'erreur, logo qui clignote puis cela tourne en rond avec sa série de
commandes, et cela foire deux fois de suite...
Je commence à prendre peur pour les quelques fichiers que j'avais sur le
disque dur, je reboot et j'essaie de lancer un live usb linux et il
plante aussi (menu qui apparaît et disparaît en permanence, pas moyen de
faire quelque chose), je coupe l'ordinateur plus longtemps, je relance
et linux mint arrive à se lancer, j'en profite pour sauvegarder les
quelques fichiers sur disque usb.
Je fais les mises à jour, entre autres une mise à jour du noyau qui
m'est proposée.
De nouveau je ferme tout et je redémarre, et là cela redémarre bien,
sans erreur, sans logo qui tremble etc..
J'ai redémarré plusieurs fois depuis, et l'erreur n'est pas revenue.
Qu'est-ce que cela pouvait être cette erreur "couldn't get size" ? Un
problème de noyau ? De bios ? Du boot grub ?
J'ai pas compris ce qu'il s'est passé...

Autre chose, je cherche dans quel fichier se trouverait les erreurs
qu'il y avait au boot. Je cherche dans var/log, mais pas vu, dans boot
non plus etc... cela se situe où ce fichier de log ?
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Pierre www.aribaut.com
Le #26493836
Le 26/10/2018 à 19:13, Pierre www.aribaut.com a écrit :
Autre chose, je cherche dans quel fichier se trouverait les erreurs
qu'il y avait au boot. Je cherche dans var/log, mais pas vu, dans boot
non plus etc... cela se situe où ce fichier de log ?

A priori dans var/log/syslog je vois l'erreur de ce matin :
Oct 26 10:30:46 zetrader kernel: [ 4.762937] Couldn't get size:
0x800000000000000e
Oct 26 10:30:46 zetrader kernel: [ 4.762988] MODSIGN: Couldn't get
UEFI MokListRT
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
denis.paris
Le #26493989
Le 26/10/2018 à 18:51, Pierre www.aribaut.com a écrit :
Hello, c'est la 1ère fois que cela m'arrive avec Linux Mint.
L'historique : à un moment donné, je ne pouvais plus cliquer sur rien,
aucun menu, rien ne répond, je peux bouger le curseur mais au clic aucun
menu ne réagit, un appui court bouton power ne propose pas d'éteindre,
ne pouvant rien faire d'autre, j'appuie donc plusieurs secondes sur
power pour forcer l'extinction de l'ordinateur.
Je redémarre et là j'ai le menu pour lancer linux mint puis un message
d'erreur au boot "couldn't get size", le logo mint qui clignote et toute
une série d'erreurs, de trucs, une longue série de commandes qui se fait...
J'ai enfin la main, la session remarche.
Je relance et là c'est le drame, il n'arrive plus à booter, de nouveau
l'erreur, logo qui clignote puis cela tourne en rond avec sa série de
commandes, et cela foire deux fois de suite...
Je commence à prendre peur pour les quelques fichiers que j'avais sur le
disque dur, je reboot et j'essaie de lancer un live usb linux et il
plante aussi (menu qui apparaît et disparaît en permanence, pas moyen de
faire quelque chose), je coupe l'ordinateur plus longtemps, je relance
et linux mint arrive à se lancer, j'en profite pour sauvegarder les
quelques fichiers sur disque usb.
Je fais les mises à jour, entre autres une mise à jour du noyau qui
m'est proposée.
De nouveau je ferme tout et je redémarre, et là cela redémarre bien,
sans erreur, sans logo qui tremble etc..
J'ai redémarré plusieurs fois depuis, et l'erreur n'est pas revenue.
Qu'est-ce que cela pouvait être cette erreur "couldn't get size" ? Un
problème de noyau ? De bios ? Du boot grub ?
J'ai pas compris ce qu'il s'est passé...

J'ai d'abord pensé à un espace disque saturé, mais alors la version
"live" aurait dû se lancer.
Ça semble être un problème hardware. Je n'ai jamais vu système un linux
planter spontanément (sauf parfois l'interface graphique, mais on peut
reprendre la main en console). Vérifie le disque et surtout la mémoire
(avec testmem).
Pierre www.aribaut.com
Le #26494037
Le 28/10/2018 à 00:26, denis.paris a écrit :
Le 26/10/2018 à 18:51, Pierre www.aribaut.com a écrit :
Hello, c'est la 1ère fois que cela m'arrive avec Linux Mint.
L'historique : à un moment donné, je ne pouvais plus cliquer sur rien,
aucun menu, rien ne répond, je peux bouger le curseur mais au clic
aucun menu ne réagit, un appui court bouton power ne propose pas
d'éteindre, ne pouvant rien faire d'autre, j'appuie donc plusieurs
secondes sur power pour forcer l'extinction de l'ordinateur.
Je redémarre et là j'ai le menu pour lancer linux mint puis un message
d'erreur au boot "couldn't get size", le logo mint qui clignote et
toute une série d'erreurs, de trucs, une longue série de commandes qui
se fait...
J'ai enfin la main, la session remarche.
Je relance et là c'est le drame, il n'arrive plus à booter, de nouveau
l'erreur, logo qui clignote puis cela tourne en rond avec sa série de
commandes, et cela foire deux fois de suite...
Je commence à prendre peur pour les quelques fichiers que j'avais sur
le disque dur, je reboot et j'essaie de lancer un live usb linux et il
plante aussi (menu qui apparaît et disparaît en permanence, pas moyen
de faire quelque chose), je coupe l'ordinateur plus longtemps, je
relance et linux mint arrive à se lancer, j'en profite pour
sauvegarder les quelques fichiers sur disque usb.
Je fais les mises à jour, entre autres une mise à jour du noyau qui
m'est proposée.
De nouveau je ferme tout et je redémarre, et là cela redémarre bien,
sans erreur, sans logo qui tremble etc..
J'ai redémarré plusieurs fois depuis, et l'erreur n'est pas revenue.
Qu'est-ce que cela pouvait être cette erreur "couldn't get size" ? Un
problème de noyau ? De bios ? Du boot grub ?
J'ai pas compris ce qu'il s'est passé...

J'ai d'abord pensé à un espace disque saturé, mais alors la version
"live" aurait dû se lancer.
Ça semble être un problème hardware. Je n'ai jamais vu système un linux
planter spontanément (sauf parfois l'interface graphique, mais on peut
reprendre la main en console).  Vérifie le disque et surtout la mémoire
(avec testmem).

À noter que cela ne s'est pas reproduit en une dizaine de reboot pour le
moment, comme dirait l'autre "jusqu'ici tout va bien", mais c'est
inquiétant la piste matérielle.
J'ai pensé aussi à des erreurs sur le disque dur, des secteurs
défecteux, à vérifier, pour la RAM j'ai des doutes.
Je viens de tester un peu la RAM avec ces instructions :
https://linuxhint.com/check-ram-ubuntu/
Avec d'abord "sudo memtester 100M 2" (test d'une portion de 100 Mb de
RAM 2 fois), aucun message d'erreur tout était ok.
Puis j'y suis allé plus franco avec "sudo memtester 1G 1" (test d'une
portion de 1 Gb de RAM une fois), le test a mis pas mal plus de temps
(10 fois plus de mémoire à soumettre à différents tests) mais tout était
ok aussi :
"memtester version 4.3.0 (64-bit)
Copyright (C) 2001-2012 Charles Cazabon.
Licensed under the GNU General Public License version 2 (only).
pagesize is 4096
pagesizemask is 0xfffffffffffff000
want 1024MB (1073741824 bytes)
got 1024MB (1073741824 bytes), trying mlock ...locked.
Loop 1/1:
Stuck Address : ok
Random Value : ok
Compare XOR : ok
Compare SUB : ok
Compare MUL : ok
Compare DIV : ok
Compare OR : ok
Compare AND : ok
Sequential Increment: ok
Solid Bits : ok
Block Sequential : ok
Checkerboard : ok
Bit Spread : ok
Bit Flip : ok
Walking Ones : ok
Walking Zeroes : ok
8-bit Writes : ok
16-bit Writes : ok
Done."
A priori ok côté RAM.
Je vais voir ce qu'il y a comme utilitaire sous linux pour tester le
disque dur.
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Pierre www.aribaut.com
Le #26494039
Le 28/10/2018 à 10:35, Pierre www.aribaut.com a écrit :
Le 28/10/2018 à 00:26, denis.paris a écrit :
Le 26/10/2018 à 18:51, Pierre www.aribaut.com a écrit :
Hello, c'est la 1ère fois que cela m'arrive avec Linux Mint.
L'historique : à un moment donné, je ne pouvais plus cliquer sur
rien, aucun menu, rien ne répond, je peux bouger le curseur mais au
clic aucun menu ne réagit, un appui court bouton power ne propose pas
d'éteindre, ne pouvant rien faire d'autre, j'appuie donc plusieurs
secondes sur power pour forcer l'extinction de l'ordinateur.
Je redémarre et là j'ai le menu pour lancer linux mint puis un
message d'erreur au boot "couldn't get size", le logo mint qui
clignote et toute une série d'erreurs, de trucs, une longue série de
commandes qui se fait...
J'ai enfin la main, la session remarche.
Je relance et là c'est le drame, il n'arrive plus à booter, de
nouveau l'erreur, logo qui clignote puis cela tourne en rond avec sa
série de commandes, et cela foire deux fois de suite...
Je commence à prendre peur pour les quelques fichiers que j'avais sur
le disque dur, je reboot et j'essaie de lancer un live usb linux et
il plante aussi (menu qui apparaît et disparaît en permanence, pas
moyen de faire quelque chose), je coupe l'ordinateur plus longtemps,
je relance et linux mint arrive à se lancer, j'en profite pour
sauvegarder les quelques fichiers sur disque usb.
Je fais les mises à jour, entre autres une mise à jour du noyau qui
m'est proposée.
De nouveau je ferme tout et je redémarre, et là cela redémarre bien,
sans erreur, sans logo qui tremble etc..
J'ai redémarré plusieurs fois depuis, et l'erreur n'est pas revenue.
Qu'est-ce que cela pouvait être cette erreur "couldn't get size" ? Un
problème de noyau ? De bios ? Du boot grub ?
J'ai pas compris ce qu'il s'est passé...

J'ai d'abord pensé à un espace disque saturé, mais alors la version
"live" aurait dû se lancer.
Ça semble être un problème hardware. Je n'ai jamais vu système un
linux planter spontanément (sauf parfois l'interface graphique, mais
on peut reprendre la main en console).  Vérifie le disque et surtout
la mémoire (avec testmem).

À noter que cela ne s'est pas reproduit en une dizaine de reboot pour le
moment, comme dirait l'autre "jusqu'ici tout va bien", mais c'est
inquiétant la piste matérielle.
J'ai pensé aussi à des erreurs sur le disque dur, des secteurs
défecteux, à vérifier, pour la RAM j'ai des doutes.
Je viens de tester un peu la RAM avec ces instructions :
https://linuxhint.com/check-ram-ubuntu/
Avec d'abord  "sudo memtester 100M 2" (test d'une portion de 100 Mb de
RAM 2 fois), aucun message d'erreur tout était ok.
Puis j'y suis allé plus franco avec "sudo memtester 1G 1" (test d'une
portion de 1 Gb de RAM une fois), le test a mis pas mal plus de temps
(10 fois plus de mémoire à soumettre à différents tests) mais tout était
ok aussi :
"memtester version 4.3.0 (64-bit)
Copyright (C) 2001-2012 Charles Cazabon.
Licensed under the GNU General Public License version 2 (only).
pagesize is 4096
pagesizemask is 0xfffffffffffff000
want 1024MB (1073741824 bytes)
got  1024MB (1073741824 bytes), trying mlock ...locked.
Loop 1/1:
  Stuck Address       : ok
  Random Value        : ok
  Compare XOR         : ok
  Compare SUB         : ok
  Compare MUL         : ok
  Compare DIV         : ok
  Compare OR          : ok
  Compare AND         : ok
  Sequential Increment: ok
  Solid Bits          : ok
  Block Sequential    : ok
  Checkerboard        : ok
  Bit Spread          : ok
  Bit Flip            : ok
  Walking Ones        : ok
  Walking Zeroes      : ok
  8-bit Writes        : ok
  16-bit Writes       : ok
Done."
A priori ok côté RAM.
Je vais voir ce qu'il y a comme utilitaire sous linux pour tester le
disque dur.

Pour le test du disque dur, de ce que j'ai compris ça se passe du côté
de "smartmontools", je l'ai installé donc :
https://doc.ubuntu-fr.org/smartmontools
J'ai fait les quelques commandes de base citées, puis le test rapide de
disque dur : "sudo smartctl -t short /dev/sdX" (en remplaçant le X par
la lettre de mon disque dur interne).
Pas eu de messages d'erreurs, tout est correct jusqu'ici.
J'hésite à faire le test long, car justement...il est long ;)
Mais c'est peut-être nécessaire pour en savoir plus et écarter
complètement l'hypothèse de secteurs défectueux ?
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Pierre www.aribaut.com
Le #26494074
Le 28/10/2018 à 10:59, Pierre www.aribaut.com a écrit :
Le 28/10/2018 à 10:35, Pierre www.aribaut.com a écrit :
Le 28/10/2018 à 00:26, denis.paris a écrit :
J'ai d'abord pensé à un espace disque saturé, mais alors la version
"live" aurait dû se lancer.
Ça semble être un problème hardware. Je n'ai jamais vu système un
linux planter spontanément (sauf parfois l'interface graphique, mais
on peut reprendre la main en console).  Vérifie le disque et surtout
la mémoire (avec testmem).

À noter que cela ne s'est pas reproduit en une dizaine de reboot pour
le moment, comme dirait l'autre "jusqu'ici tout va bien", mais c'est
inquiétant la piste matérielle.
J'ai pensé aussi à des erreurs sur le disque dur, des secteurs
défecteux, à vérifier, pour la RAM j'ai des doutes.
Je viens de tester un peu la RAM avec ces instructions :
https://linuxhint.com/check-ram-ubuntu/
Avec d'abord  "sudo memtester 100M 2" (test d'une portion de 100 Mb de
RAM 2 fois), aucun message d'erreur tout était ok.
Puis j'y suis allé plus franco avec "sudo memtester 1G 1" (test d'une
portion de 1 Gb de RAM une fois), le test a mis pas mal plus de temps
(10 fois plus de mémoire à soumettre à différents tests) mais tout
était ok aussi :
"memtester version 4.3.0 (64-bit)
Copyright (C) 2001-2012 Charles Cazabon.
Licensed under the GNU General Public License version 2 (only).
pagesize is 4096
pagesizemask is 0xfffffffffffff000
want 1024MB (1073741824 bytes)
got  1024MB (1073741824 bytes), trying mlock ...locked.
Loop 1/1:
   Stuck Address       : ok
   Random Value        : ok
   Compare XOR         : ok
   Compare SUB         : ok
   Compare MUL         : ok
   Compare DIV         : ok
   Compare OR          : ok
   Compare AND         : ok
   Sequential Increment: ok
   Solid Bits          : ok
   Block Sequential    : ok
   Checkerboard        : ok
   Bit Spread          : ok
   Bit Flip            : ok
   Walking Ones        : ok
   Walking Zeroes      : ok
   8-bit Writes        : ok
   16-bit Writes       : ok
Done."
A priori ok côté RAM.
Je vais voir ce qu'il y a comme utilitaire sous linux pour tester le
disque dur.

Pour le test du disque dur, de ce que j'ai compris ça se passe du côté
de "smartmontools", je l'ai installé donc :
https://doc.ubuntu-fr.org/smartmontools
J'ai fait les quelques commandes de base citées, puis le test rapide de
disque dur : "sudo smartctl -t short /dev/sdX" (en remplaçant le X par
la lettre de mon disque dur interne).
Pas eu de messages d'erreurs, tout est correct jusqu'ici.
J'hésite à faire le test long, car justement...il est long ;)
Mais c'est peut-être nécessaire pour en savoir plus et écarter
complètement l'hypothèse de secteurs défectueux ?

Bon j'ai fait le test plus long (cela a duré 100 minutes), idem pas
d'erreur :
sudo smartctl -t long /dev/sdX
Résultat :
"smartctl 6.6 2016-05-31 r4324 [x86_64-linux-4.15.0-38-generic] (local
build)
Copyright (C) 2002-16, Bruce Allen, Christian Franke, www.smartmontools.org
=== START OF READ SMART DATA SECTION == SMART Self-test log structure revision number 1
Num Test_Description Status Remaining
LifeTime(hours) LBA_of_first_error
# 1 Extended offline Completed without error 00% 6143
-
# 2 Short offline Completed without error 00% 6141
-"
La commande "sudo smartctl -q errorsonly -H -l selftest /dev/sdX" ne
retourne aucune erreur.
Donc pas d'erreur physique du disque normalement vu que j'ai fait le
test court et test long et aucune erreur pour les deux.
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
denis.paris
Le #26494099
Ça peut aussi être un blocage du processeur à cause d'une surchauffe.
Comme memtester" stresse très fortement la CPU (100%) ça serait une
bonne idée de le faire tourner pendant plusieurs heures, voire une nuit.
Quand j'installais des serveurs hosts destinés à faire de la
virtualisation de très nombreuses machines, le protocole était de tester
la machine neuve avec un "testmem" pendant 72 heures (et ça chauffait
beaucoup!)
Et teste aussi la totalité de la RAM, un défaut peut être localisé.
Lulu
Le #26494216
Le 28-10-2018, denis.paris
Ça peut aussi être un blocage du processeur à cause d'une surchauffe.
Comme memtester" stresse très fortement la CPU (100%) ça serait une
bonne idée de le faire tourner pendant plusieurs heures, voire une
nuit.
Quand j'installais des serveurs hosts destinés à faire de la
virtualisation de très nombreuses machines, le protocole était de
tester la machine neuve avec un "testmem" pendant 72 heures (et ça
chauffait beaucoup!)
Et teste aussi la totalité de la RAM, un défaut peut être localisé.

Je ne suis pas sûr qu'il comprenne "localisé"...
Pierre www.aribaut.com
Le #26494259
Le 28/10/2018 à 22:48, Lulu a écrit :
Le 28-10-2018, denis.paris
Ça peut aussi être un blocage du processeur à cause d'une surchauffe.
Comme memtester" stresse très fortement la CPU (100%) ça serait une
bonne idée de le faire tourner pendant plusieurs heures, voire une
nuit.
Quand j'installais des serveurs hosts destinés à faire de la
virtualisation de très nombreuses machines, le protocole était de
tester la machine neuve avec un "testmem" pendant 72 heures (et ça
chauffait beaucoup!)
Et teste aussi la totalité de la RAM, un défaut peut être localisé.


Si je n'ai pas testé la totalité c'est aussi parce que je me dis que
pendant qu'on tourne, la totalité n'est pas disponible, les processus
lancés prennent pas loin d'1 Go, et a priori fonctionnent bien si c'est
lancé. Pas de risque de plantage ou de refus d'accès à demander à tester
la totalité de la RAM ?
Mettons j'ai 4 go de RAM, 1Go occupé par les applications et le système,
il reste 3 Go disponible. Je peux demander à tester les 4 Go ?
Je ne suis pas sûr qu'il comprenne "localisé"...

Pourquoi donc ? A priori c'est comme pour le disque dur, un défaut peut
être localisé.
--
http://zetrader.info & http://zetrader.fr
http://aribaut.com - http://zeforums.com
Sergio
Le #26494262
Le 29/10/2018 à 07:59, Pierre www.aribaut.com a écrit :
Si je n'ai pas testé la totalité c'est aussi parce que je me dis que pendant qu'on tourne, la totalité n'est pas disponible, les processus lancés prennent pas loin d'1 Go, et a priori fonctionnent
bien si c'est lancé. Pas de risque de plantage ou de refus d'accès à demander à tester la totalité de la RAM ?
Mettons j'ai 4 go de RAM, 1Go occupé par les applications et le système, il reste 3 Go disponible. Je peux demander à tester les 4 Go ?

Le test se déroule en autonome (lancé par grub à la place du système). Donc *toute* la mémoire sera testée.
Je ne suis pas sûr qu'il comprenne "localisé"...

Pourquoi donc ? A priori c'est comme pour le disque dur, un défaut peut être localisé.

Tu peux voir :
1) s'il y a des problèmes dans la mémoire et localiser la barrette défectueuse
2) si le test "plante" au bout d'un moment, il y a des chances que le processeur chauffe trop. Là, vérifier les ventilateurs, si les radiateurs CPU sont suffisants etc.
--
Serge http://cahierdesergio.free.fr/
Soutenez le libre: http://www.framasoft.org
Publicité
Poster une réponse
Anonyme