Twitter iPhone pliant OnePlus 11 PS5 Disney+ Orange Livebox Windows 11

Liste déroulante avec saisie semi automatique pour EXCEL pour les nombres

6 réponses
Avatar
Voici une procédure publié gbinforme que je remercie en passant qui marche
parfaitement pour les lettres

la première valeur de la liste se nomme "d_noms"
la colonne de la liste se nomme "c_noms".

formule nommée, afin de délimiter la zone renseignée de la liste : "l_noms"
la formule =DECALER(d_noms;0;0;NBVAL(c_noms)-1;1)

formule dans l'onglet de validation :
=SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMME((STXT(l_noms;1;NBCAR(A1))=TEXTE(A1;"0"))*1));l_noms)

Je ne suis pas arrivé à transformer cette formule pour que la solution soit
aussi pour une liste de nombres.

Auriez vous une idée ? Merci

6 réponses

Avatar
JB
Bonjour,

Formatter la colonne en texte

CALER(Nombres;EQUIV(A2&"*";Nombres;0)-1;;NB.SI(Nombres;A2&"*"))

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#premlettres" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#premlettres
http://boisgontierjacques.free.fr/fichiers/DonneesValidation/DVPremiersChif" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://boisgontierjacques.free.fr/fichiers/DonneesValidation/DVPremiersChif fres.xls

JB
http://boisgontierjacques.free.fr

On 23 mar, 10:52, wrote:
Voici une procédure publié gbinforme que je remercie en passant qui m arche
parfaitement pour les lettres

la première valeur de la liste se nomme "d_noms"
la colonne de la liste se nomme "c_noms".

formule nommée, afin de délimiter la zone renseignée de la liste  : "l_noms"
la formule CALER(d_noms;0;0;NBVAL(c_noms)-1;1)

formule dans l'onglet de validation :
=SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMME((STXT(l_noms; 1;NB­CAR(A1))=TEXTE(A1;"0"))*1));l_noms)

Je ne suis pas arrivé à transformer cette formule pour que la solutio n soit
aussi pour une liste de nombres.

Auriez vous une idée ? Merci


Avatar
Merci

"JB" a écrit dans le message de news:

Bonjour,

Formatter la colonne en texte

ÞCALER(Nombres;EQUIV(A2&"*";Nombres;0)-1;;NB.SI(Nombres;A2&"*"))

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#premlettres" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#premlettres
http://boisgontierjacques.free.fr/fichiers/DonneesValidation/DVPremiersChiffres.xls" target="_blank" class="text-blue hover:opacity-90 " style="word-break: break-all;" rel="noopener nofollow">http://boisgontierjacques.free.fr/fichiers/DonneesValidation/DVPremiersChiffres.xls

JB
http://boisgontierjacques.free.fr

On 23 mar, 10:52, wrote:
Voici une procédure publié gbinforme que je remercie en passant qui marche
parfaitement pour les lettres

la première valeur de la liste se nomme "d_noms"
la colonne de la liste se nomme "c_noms".

formule nommée, afin de délimiter la zone renseignée de la liste :
"l_noms"
la formule ÞCALER(d_noms;0;0;NBVAL(c_noms)-1;1)

formule dans l'onglet de validation :
=SI(A1<>"";DECALER(d_noms;EQUIV(A1&"*";l_noms;0)-1;;SOMME((STXT(l_noms;1;NB­CAR(A1))=TEXTE(A1;"0"))*1));l_noms)

Je ne suis pas arrivé à transformer cette formule pour que la solution
soit
aussi pour une liste de nombres.

Auriez vous une idée ? Merci


Avatar
Bonjour,

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#premlettres

cette méthode ne semble fonctionner qu'à la condition d'être dans ma même
feuille.

Est-ce exact ? et si oui, comment faire pour que la liste soit dans une
feuille que la validation
Avatar
JB
Bonsoir,

Naturellement, cette méthode fonctionne aussi lorsque la liste est
dans une autre feuille.

http://cjoint.com/?dAtde5vM2S

JB
On 24 mar, 16:26, wrote:
Bonjour,

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#preml...

cette méthode ne semble fonctionner qu'à la condition d'être dans m a même
feuille.

Est-ce exact ? et si oui, comment faire pour que la liste soit dans une
feuille que la validation


Avatar
Merci,

"JB" a écrit dans le message de news:

Bonsoir,

Naturellement, cette méthode fonctionne aussi lorsque la liste est
dans une autre feuille.

http://cjoint.com/?dAtde5vM2S

JB
On 24 mar, 16:26, wrote:
Bonjour,

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#preml...

cette méthode ne semble fonctionner qu'à la condition d'être dans ma même
feuille.

Est-ce exact ? et si oui, comment faire pour que la liste soit dans une
feuille que la validation


Avatar
Puis-je vous poser une question toujours en rapport avec les listes.

Sur votre site il y une méthode pour élargir la colonne de la liste mais je
suis incapable de la comprendre .

Pour obtenir une liste plus large que la colonne
-Elargir la colonne
-Faire la liste
-Rétrécir la colonne

Merci

"JB" a écrit dans le message de news:

Bonsoir,

Naturellement, cette méthode fonctionne aussi lorsque la liste est
dans une autre feuille.

http://cjoint.com/?dAtde5vM2S

JB
On 24 mar, 16:26, wrote:
Bonjour,

http://boisgontierjacques.free.fr/pages_site/listes_cascade.htm#preml...

cette méthode ne semble fonctionner qu'à la condition d'être dans ma même
feuille.

Est-ce exact ? et si oui, comment faire pour que la liste soit dans une
feuille que la validation