Twitter iPhone pliant OnePlus 11 PS5 Disney+ Orange Livebox Windows 11

MacCafé v 2.09

9 réponses
Avatar
Gilbert OLIVIER
Bonjour

La version 2.09 de MacCafé est disponible, ainsi que la documentation
mise Í  jour.
Seules les versions 2.09 et 2.09 (4D18) sont disponibles. La version (4D
19) n’est pas disponible pour les mêmes raison que pour la v 2.08.
En tout état de cause, mis Í  part le message d’erreur en quittant
MacCafé, elle semble donner entière satisfaction sous Monterey Í  ceux
qui l’utilisent.

Au programme:
Quelques corrections de bugs et améliorations diverses. Vous en
trouverez la liste dans l’historique, et reportez-vous Í  la
documentation pour leur utilisation.

Nouveautés et améliorations majeures:
- La documentation de MacCafé
À partir de cette version, chaque version de MacCafé affichera la
documentation en ligne lui correspondant.

- Recherche en ligne d’un message par son M-ID
Si vous activez cette possibilité, vous pouvez désormais désactiver la
recherche sur certains serveurs NNTP (évite entre autres un message
d’erreur dans le cas d’un serveur en panne), ainsi que de classer
l’ordre d’interrogation de ces serveurs.

- Adresses mail
Une fonction de test des adresses mail Í  été mise en place.
Elle teste la syntaxe et dans les cas utiles, l’existence du domaine.
Ce test n’assure pas que l’adresse existe réellement, juste que sa
syntaxe est correcte et que le domaine existe.
Elle est utilisée principalement dans les préférences de façon Í  rendre
vos paramètres de compte conforme avec les rfc, ainsi que dans tous les
cas ou vous devez vous servir ou saisir une adresse mail.
La lecture de la documentation est indispensable pour comprendre toutes
les implications de cette fonction dans l’utilisation des commandes qui
l’utilisent.

Tous les détails des corrections et améliorations dans l’historique, et
la documentation pour le fonctionnement détaillé de ces commandes.

Je vous rappelle, comme conseillé avant toute mise Í  jour, qu’il est
prudent d’avoir une sauvegarde de vos données (le dossier des bases).

Bonne mise Í  jour.

--
Gilbert
<https://maccafe-osx.pagesperso-orange.fr>

9 réponses

Avatar
mic8
Le 15 septembre 2022 vers 11:20, Gilbert OLIVIER nous a fait part de :
Bonjour
La version 2.09 de MacCafé est disponible, ainsi que la documentation
mise Í  jour.

Bonjour,
Plante Í  la relève chez moi (MacOS Monterey 12.6 - MacCafé 4D18)
Message d'erreur copié:
"Erreur lors de l’exécution de la méthode "ServeurLogIn" Í  la ligne 37
Routine externe introuvable. (4D Internet Commands)
Error code: -9939 (4DRT)
Routine externe introuvable. (4D Internet Commands)
component: '4DRT'
task -6, name: 'ReleveMessages'
Call chain:
[
{
"type": "projectMethod",
"name": "ServeurLogIn",
"line": 37,
"database": "MacCafé"
},
{
"type": "projectMethod",
"name": "Pro_Releve",
"line": 71,
"database": "MacCafé"
}
]
--
Micaël
Observez ce qui se passe au-dessus de vos têtes : www.mic8.ch/satobserver
Avatar
mic8
Le 15 septembre 2022 vers 12:00, mic8 nous a fait part de :
Le 15 septembre 2022 vers 11:20, Gilbert OLIVIER nous a fait part de :
Bonjour
La version 2.09 de MacCafé est disponible, ainsi que la documentation
mise Í  jour.

Bonjour,
Plante Í  la relève chez moi (MacOS Monterey 12.6 - MacCafé 4D18)

J'ai comparé le contenu du paquet entre la v2.08 et la v2.09: dans cette
dernière, le dossier plugins est vide, alors que dans la 2.09 il
contient "4D InternetCommands.bundle"
Il se pourrait bien que cela soit la source de l'erreur rencontrée.
--
Micaël
Observez ce qui se passe au-dessus de vos têtes : www.mic8.ch/satobserver
Avatar
mic8
Le 15 septembre 2022 vers 14:17, mic8 nous a fait part de :
J'ai comparé le contenu du paquet entre la v2.08 et la v2.09: dans cette
dernière, le dossier plugins est vide, alors que dans la 2.09 il
contient "4D InternetCommands.bundle"

Lire "alors que dans la 2.08 il contient "4D InternetCommands.bundle"
Désolé
--
Micaël
Observez ce qui se passe au-dessus de vos têtes : www.mic8.ch/satobserver
Avatar
M.V.
Dans le message <tfv55d$ppg$, mic8 a écrit le 15
septembre 2022 ͠ 14 h 17 :
J'ai comparé le contenu du paquet entre la v2.08 et la v2.09: dans cette
dernière, le dossier plugins est vide, alors que dans la 2.09 il
contient "4D InternetCommands.bundle"
Il se pourrait bien que cela soit la source de l'erreur rencontrée.

Je teste cette version (sous Mojave) et l'absence de « 4D
InternetCommands.bundle » semble en effet perturber MacCafé 2.09 (4D18)
Je viens de récupérer celui de la version précédente pour voir… Si ce
message part, ce sera déjÍ  une avancée.
--
🇺🇦 Michel Vauquois - <http://michelvauquois.fr&gt; 🇺🇦
Si la pierre tombe sur l'oeuf, malheur Í  l'oeuf ! Si l'oeuf tombe sur la pierre,
malheur Í  l'oeuf ! (Proverbe chinois)
Avatar
M.V.
Dans le message <tfv8lb$b6n$, j'ai écrit le 15
septembre 2022 ͠ 15 h 17 :
Si ce message part, ce sera déjÍ  une avancée.

Le message est parti et arrivé mais j'ai eu ça lors de la relève :
<https://www.dropbox.com/s/pg0lvmeipxea4on/Ecran%2012.png?dl=0&gt;
--
🇺🇦 Michel Vauquois - <http://michelvauquois.fr&gt; 🇺🇦
Avatar
M.V.
Dans le message <tfv8pi$bd6$, j'ai écrit le 15
septembre 2022 ͠ 15 h 19 :
Le message est parti et arrivé mais j'ai eu ça lors de la relève :
<https://www.dropbox.com/s/pg0lvmeipxea4on/Ecran%2012.png?dl=0&gt;

et j'ai ce message d'erreur Í  chaque fois.
Donc cette version → corbeille
--
🇺🇦 Michel Vauquois - <http://michelvauquois.fr&gt; 🇺🇦
Si ON veut, ON peut. C'est qui, ON?
(Brèves de comptoir - Jean-Marie Gourio)
Avatar
Gilbert OLIVIER
le 15 septembre 2022; mic8 m'a confié :
Le 15 septembre 2022 vers 14:17, mic8 nous a fait part de :
J'ai comparé le contenu du paquet entre la v2.08 et la v2.09: dans cette
dernière, le dossier plugins est vide, alors que dans la 2.09 il
contient "4D InternetCommands.bundle"

Lire "alors que dans la 2.08 il contient "4D InternetCommands.bundle"
Désolé

Exact, et pourtant dans mes notes pour passer en 4D18 et 4D19 j'avais
noté cette manip :-(
Mais c'est en effet la cause du problème.
Version corrigée disponible annoncée sur un autre fil.
--
Gilbert
<https://maccafe-osx.pagesperso-orange.fr&gt;
Avatar
mic8
En réponse Í  Gilbert OLIVIER qui, le 15 septembre 2022 vers 17:55 tenait
l'extrait suivant:
le 15 septembre 2022; mic8 m'a confié :
Le 15 septembre 2022 vers 14:17, mic8 nous a fait part de :
Lire "alors que dans la 2.08 il contient "4D InternetCommands.bundle"
Désolé

Exact, et pourtant dans mes notes pour passer en 4D18 et 4D19 j'avais
noté cette manip :-(
Mais c'est en effet la cause du problème.
Version corrigée disponible annoncée sur un autre fil.

Je confirme, problème réglé avec cette version corrigée.
Merci beaucoup, tant pour la réactivité de la correction que pour
l'ensemble de l'oeuvre MacCafé.
--
Micaël
Observez ce qui se passe au-dessus de vos têtes : www.mic8.ch/satobserver
Avatar
Gilbert OLIVIER
le 15 septembre 2022; mic8 m'a confié :
Je confirme, problème réglé avec cette version corrigée.
Merci beaucoup, tant pour la réactivité de la correction que pour
l'ensemble de l'oeuvre MacCafé.

Merci et il faut dire merci aussi Í  ceux qui supportent les bugs et
problèmes divers des versions beta.
Mais merci Í  toi aussi du détail du rapport du problème qui m'a tout de
suite fait comprendre ou était le problème.
--
Gilbert
<https://maccafe-osx.pagesperso-orange.fr&gt;