Masquerade à pile ou face

Le
Charles Plessy
Bonjour à tous,

J'ai un problème de réseau dont j'ignore s'il est lié à Debian, mais
comme la machine en question n'a pas de lecteur de disque amovibles, je ne peux
pas faire de tests avec une distribution sur disque autonome.

Ma machine est un petit "sans-ventilateur" ITX avec deux ports ethernet :

0000:00:0f.0 Ethernet controller: VIA Technologies, Inc. VT6105 [Rhine-III] (rev 8b)
0000:00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)

J'y ai installé une Sarge l'année dernière, m'en sers comme d'une
petite passerelle pour mon réseau interne et y abrite quelques services du type
web, mails, ssh.

J'ai l'ADSL en pppoe, et je partage la connexion avec la ligne suivante :

iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -o ppp0 -j MASQUERADE

Jusqu'ici, rien de bien particulier, sauf que parfois la connexion
"masqueradée" se bloque lorsqu'une connexion directe s'établit. Par exemple, je
peux écouter de la musique sur un macintosh derrière la passerelle, mais si
depuis la console de la passerelle je pinge une machine à l'extérieur, la
musique s'arrête, pour se rétablir quelques dizaines de secondes après l'arrêt
du ping.

Là où ça devient moins drôle, c'est que ce n'est pas que le trafic
http qui est concerné, mais aussi tout le reste : une connexion ssh entre mon
mac et ma passerelle est un cauchemar sans nom, car elle se gèle une ou deux
minutes à chaque fois que je reçois un mail (la principale source de connexions
extérieures, et je suis abonné à beaucoup de listes de diffusion).

Pour finir, ce problème est intermittent, ce qui signifie que cela peut
marcher un mois ou deux, puis me pourrir un dimanche, puis recommencer à
marcher. (là, ça m'a aussi pourri mon lundi matin)

Je me demande si cela vient du fait que les deux ports ethernet
utilisent le même module le noyau peut-il s'emmêler les pinceaux ? Ah, à
propos de noyau :

Linux kunpuu 2.6.8-1-386 #1 Mon Sep 13 23:29:55 EDT 2004 i686 GNU/Linux

J'attends avec impatience vos avis éclairés, en particulier, je ne sais
pas quoi utiliser pour diagnostiquer le problème : j'en suis à "ah, le ping
passe plus", puis "ah, ça repasse". Il n'y a rien dans les logs

--
Charles


--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to debian-user-french-REQUEST@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
louis31
Le #8939221
Salut;

Alors enfait je n'y connais pas grand chose à ton problème mais à tu
fais essayé d'analyser les trames qui circule entre ta passerelles et
ton Mac par exemples pour voire si il n'y avait pas des requêtes non
sollicités ou un truc comme ça ?
Je peux me tromper mais ça pourrait ralentir un ordinateur si ont reçoit
un paquet de requête non voulu via le réseau.
Pour analyser le trafic le programme qui devrait faire l'affaire c'est
Ethereal. (promis il est pas trop compliquer à faire fonctionner par
contre après pour l'analyse du résultat c'est sur faut connaître un peu
les protocoles mais bon ya du monde qui pourra aider au pire :-) . Ha et
sinon le mieux c'est de faire une analyse pendant une heure environs
quand ça merde pas et une analyse quand ça merde pour comparé et voire
les différences.

Voilu voilu dsl si ça t'aide po.

Charles Plessy a écrit :

Bonjour à tous,

J'ai un problème de réseau dont j'ignore s'il est lié à Debian, mais
comme la machine en question n'a pas de lecteur de disque amovibles, je ne peux
pas faire de tests avec une distribution sur disque autonome.

Ma machine est un petit "sans-ventilateur" ITX avec deux ports ethernet :

0000:00:0f.0 Ethernet controller: VIA Technologies, Inc. VT6105 [Rhine-III] (rev 8b)
0000:00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)

J'y ai installé une Sarge l'année dernière, m'en sers comme d'une
petite passerelle pour mon réseau interne et y abrite quelques services du type
web, mails, ssh.

J'ai l'ADSL en pppoe, et je partage la connexion avec la ligne suivante :

iptables -t nat -A POSTROUTING -s 192.168.0.0/24 -o ppp0 -j MASQUERADE

Jusqu'ici, rien de bien particulier, sauf que parfois la connexion
"masqueradée" se bloque lorsqu'une connexion directe s'établit. Par exemple, je
peux écouter de la musique sur un macintosh derrière la passerelle, mais si
depuis la console de la passerelle je pinge une machine à l'extérieur, la
musique s'arrête, pour se rétablir quelques dizaines de secondes après l'arrêt
du ping.

Là où ça devient moins drôle, c'est que ce n'est pas que le trafic
http qui est concerné, mais aussi tout le reste : une connexion ssh entre mon
mac et ma passerelle est un cauchemar sans nom, car elle se gèle une ou deux
minutes à chaque fois que je reçois un mail (la principale source de connexions
extérieures, et je suis abonné à beaucoup de listes de diffusion...).

Pour finir, ce problème est intermittent, ce qui signifie que cela peut
marcher un mois ou deux, puis me pourrir un dimanche, puis recommencer à
marcher. (là, ça m'a aussi pourri mon lundi matin...)

Je me demande si cela vient du fait que les deux ports ethernet
utilisent le même module... le noyau peut-il s'emmêler les pinceaux ? Ah, à
propos de noyau :

Linux kunpuu 2.6.8-1-386 #1 Mon Sep 13 23:29:55 EDT 2004 i686 GNU/Linux

J'attends avec impatience vos avis éclairés, en particulier, je ne sais
pas quoi utiliser pour diagnostiquer le problème : j'en suis à "ah, le ping
passe plus", puis "ah, ça repasse". Il n'y a rien dans les logs...









--
Pensez à lire la FAQ de la liste avant de poser une question :
http://wiki.debian.net/?DebianFrench

Pensez à rajouter le mot ``spam'' dans vos champs "From" et "Reply-To:"

To UNSUBSCRIBE, email to
with a subject of "unsubscribe". Trouble? Contact
Publicité
Poster une réponse
Anonyme