MIN, MAX, Matricielles et les heures ...

Le
Microsoft
Bonjour,


je cherche à extraire la "plus petite" heure et la "plus grande" heure d'une
grille horaire au format hh:mm (07:00, 12:15, etc).

Comme c'est une sorte de feuille de pointage, en gros le but final est
d'obtenir une la première heure d'arrivée et la dernière heure de départ
pour telle ou telle personne.

3 colonnes sont donc utilisées :

Nom / H.arr. / H départ
Albert / 07:18 / 12:40
Jean / 06:00 / 09:29
Albert / 13:01 / 13:57
etc

Naïvement je comptais m'en sortir avec une matricielle du genre :

{=MIN((A2:A4="Albert")*(B2:B5))} pour obtenir 07:18

ou

{=MAX((A2:A4="Albert")*(C2:C5))} pour obtenir 13:57

Ben j'obtiens un lamentable : 00:00 dans les deux cas !!!

Je pense que ça viens du format de cellule car même en essayant :

{=SOMME((A2:A4="Albert")*(B2:B5))} j'obtiens le même 00:00 !!!

Merci d'avance pour votre aide !

Serge
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
isabelle
Le #1336829
bonjour Serge,

il faut que les plages soient de dimantion égal,
{=MIN((A2:A5="Albert")*(B2:B5))}
ou
{=MIN((A2:A4="Albert")*(B2:B4))}

isabelle


Bonjour,

je cherche à extraire la "plus petite" heure et la "plus grande" heure d'une
grille horaire au format hh:mm (07:00, 12:15, etc).

Comme c'est une sorte de feuille de pointage, en gros le but final est
d'obtenir une la première heure d'arrivée et la dernière heure de départ
pour telle ou telle personne.

3 colonnes sont donc utilisées :

Nom / H.arr. / H départ
Albert / 07:18 / 12:40
Jean / 06:00 / 09:29
Albert / 13:01 / 13:57
etc

Naïvement je comptais m'en sortir avec une matricielle du genre :

{=MIN((A2:A4="Albert")*(B2:B5))} pour obtenir 07:18

ou

{=MAX((A2:A4="Albert")*(C2:C5))} pour obtenir 13:57

Ben j'obtiens un lamentable : 00:00 dans les deux cas !!!

Je pense que ça viens du format de cellule car même en essayant :

{=SOMME((A2:A4="Albert")*(B2:B5))} j'obtiens le même 00:00 !!!

Merci d'avance pour votre aide !

Serge


Microsoft
Le #1331966
Merci pour votre contribution rapide Isabelle, mais l'erreur de Dimmension
de plage est en fait une erreur de transcription sur le message mais pas
dans ma feuille Excel.

Il font donc Lire que mon problème se pose bien avec des plages de
dimensions identiques soit :

Naïvement je comptais m'en sortir avec une matricielle du genre :

{=MIN((A2:A4="Albert")*(B2:B4))} pour obtenir 07:18

ou

{=MAX((A2:A4="Albert")*(C2:C4))} pour obtenir 13:57

Ben j'obtiens un lamentable : 00:00 dans les deux cas !!!

Je pense que ça viens du format de cellule car même en essayant :

{=SOMME((A2:A4="Albert")*(B2:B4))} j'obtiens le même 00:00 !!!



Merci encore et désolé pour les "coquilles"

Serge



"isabelle" news:
bonjour Serge,

il faut que les plages soient de dimantion égal,
{=MIN((A2:A5="Albert")*(B2:B5))}
ou
{=MIN((A2:A4="Albert")*(B2:B4))}

isabelle


Bonjour,

je cherche à extraire la "plus petite" heure et la "plus grande" heure
d'une


grille horaire au format hh:mm (07:00, 12:15, etc).

Comme c'est une sorte de feuille de pointage, en gros le but final est
d'obtenir une la première heure d'arrivée et la dernière heure de départ
pour telle ou telle personne.

3 colonnes sont donc utilisées :

Nom / H.arr. / H départ
Albert / 07:18 / 12:40
Jean / 06:00 / 09:29
Albert / 13:01 / 13:57
etc

Naïvement je comptais m'en sortir avec une matricielle du genre :

{=MIN((A2:A4="Albert")*(B2:B5))} pour obtenir 07:18

ou

{=MAX((A2:A4="Albert")*(C2:C5))} pour obtenir 13:57

Ben j'obtiens un lamentable : 00:00 dans les deux cas !!!

Je pense que ça viens du format de cellule car même en essayant :

{=SOMME((A2:A4="Albert")*(B2:B5))} j'obtiens le même 00:00 !!!

Merci d'avance pour votre aide !

Serge




Daniel.M
Le #1336823
Hello,

{=MIN(SI(A2:A4="Albert";B2:B4))}

Un problème était que les cas faux (pour A2:A4) produisaient 0. Or 0 est plus
petit que tes nombres en B2:B4.

Salutations,

Daniel M.

"Microsoft" news:%
Merci pour votre contribution rapide Isabelle, mais l'erreur de Dimmension
de plage est en fait une erreur de transcription sur le message mais pas
dans ma feuille Excel.

Il font donc Lire que mon problème se pose bien avec des plages de
dimensions identiques soit :

Naïvement je comptais m'en sortir avec une matricielle du genre :

{=MIN((A2:A4="Albert")*(B2:B4))} pour obtenir 07:18

ou

{=MAX((A2:A4="Albert")*(C2:C4))} pour obtenir 13:57

Ben j'obtiens un lamentable : 00:00 dans les deux cas !!!

Je pense que ça viens du format de cellule car même en essayant :

{=SOMME((A2:A4="Albert")*(B2:B4))} j'obtiens le même 00:00 !!!



Merci encore et désolé pour les "coquilles"

Serge



"isabelle" news:
bonjour Serge,

il faut que les plages soient de dimantion égal,
{=MIN((A2:A5="Albert")*(B2:B5))}
ou
{=MIN((A2:A4="Albert")*(B2:B4))}

isabelle


Bonjour,

je cherche à extraire la "plus petite" heure et la "plus grande" heure
d'une


grille horaire au format hh:mm (07:00, 12:15, etc).

Comme c'est une sorte de feuille de pointage, en gros le but final est
d'obtenir une la première heure d'arrivée et la dernière heure de départ
pour telle ou telle personne.

3 colonnes sont donc utilisées :

Nom / H.arr. / H départ
Albert / 07:18 / 12:40
Jean / 06:00 / 09:29
Albert / 13:01 / 13:57
etc

Naïvement je comptais m'en sortir avec une matricielle du genre :

{=MIN((A2:A4="Albert")*(B2:B5))} pour obtenir 07:18

ou

{=MAX((A2:A4="Albert")*(C2:C5))} pour obtenir 13:57

Ben j'obtiens un lamentable : 00:00 dans les deux cas !!!

Je pense que ça viens du format de cellule car même en essayant :

{=SOMME((A2:A4="Albert")*(B2:B5))} j'obtiens le même 00:00 !!!

Merci d'avance pour votre aide !

Serge








isabelle
Le #1336815
bonjour Serge,

=MIN(SI(A2:A4="Albert";B2:B4))
=MAX(SI(A2:A4="Albert";C2:C4))
à valider en matriciel

isabelle


Merci pour votre contribution rapide Isabelle, mais l'erreur de Dimmension
de plage est en fait une erreur de transcription sur le message mais pas
dans ma feuille Excel.

Il font donc Lire que mon problème se pose bien avec des plages de
dimensions identiques soit :

Naïvement je comptais m'en sortir avec une matricielle du genre :

{=MIN((A2:A4="Albert")*(B2:B4))} pour obtenir 07:18

ou

{=MAX((A2:A4="Albert")*(C2:C4))} pour obtenir 13:57

Ben j'obtiens un lamentable : 00:00 dans les deux cas !!!

Je pense que ça viens du format de cellule car même en essayant :

{=SOMME((A2:A4="Albert")*(B2:B4))} j'obtiens le même 00:00 !!!



Merci encore et désolé pour les "coquilles"

Serge

"isabelle" news:
bonjour Serge,

il faut que les plages soient de dimantion égal,
{=MIN((A2:A5="Albert")*(B2:B5))}
ou
{=MIN((A2:A4="Albert")*(B2:B4))}

isabelle


Bonjour,

je cherche à extraire la "plus petite" heure et la "plus grande" heure
d'une


grille horaire au format hh:mm (07:00, 12:15, etc).

Comme c'est une sorte de feuille de pointage, en gros le but final est
d'obtenir une la première heure d'arrivée et la dernière heure de départ
pour telle ou telle personne.

3 colonnes sont donc utilisées :

Nom / H.arr. / H départ
Albert / 07:18 / 12:40
Jean / 06:00 / 09:29
Albert / 13:01 / 13:57
etc

Naïvement je comptais m'en sortir avec une matricielle du genre :

{=MIN((A2:A4="Albert")*(B2:B5))} pour obtenir 07:18

ou

{=MAX((A2:A4="Albert")*(C2:C5))} pour obtenir 13:57

Ben j'obtiens un lamentable : 00:00 dans les deux cas !!!

Je pense que ça viens du format de cellule car même en essayant :

{=SOMME((A2:A4="Albert")*(B2:B5))} j'obtiens le même 00:00 !!!

Merci d'avance pour votre aide !

Serge






Microsoft
Le #1336814
SUPER ça marche,

merci à vous deux pour votre aide .... et avec quelle célérité !

Bravo

Serge


"isabelle" news:
bonjour Serge,

=MIN(SI(A2:A4="Albert";B2:B4))
=MAX(SI(A2:A4="Albert";C2:C4))
à valider en matriciel

isabelle


Merci pour votre contribution rapide Isabelle, mais l'erreur de
Dimmension


de plage est en fait une erreur de transcription sur le message mais pas
dans ma feuille Excel.

Il font donc Lire que mon problème se pose bien avec des plages de
dimensions identiques soit :

Naïvement je comptais m'en sortir avec une matricielle du genre :

{=MIN((A2:A4="Albert")*(B2:B4))} pour obtenir 07:18

ou

{=MAX((A2:A4="Albert")*(C2:C4))} pour obtenir 13:57

Ben j'obtiens un lamentable : 00:00 dans les deux cas !!!

Je pense que ça viens du format de cellule car même en essayant :

{=SOMME((A2:A4="Albert")*(B2:B4))} j'obtiens le même 00:00 !!!



Merci encore et désolé pour les "coquilles"

Serge

"isabelle" news:
bonjour Serge,

il faut que les plages soient de dimantion égal,
{=MIN((A2:A5="Albert")*(B2:B5))}
ou
{=MIN((A2:A4="Albert")*(B2:B4))}

isabelle


Bonjour,

je cherche à extraire la "plus petite" heure et la "plus grande"
heure




d'une
grille horaire au format hh:mm (07:00, 12:15, etc).

Comme c'est une sorte de feuille de pointage, en gros le but final
est




d'obtenir une la première heure d'arrivée et la dernière heure de
départ




pour telle ou telle personne.

3 colonnes sont donc utilisées :

Nom / H.arr. / H départ
Albert / 07:18 / 12:40
Jean / 06:00 / 09:29
Albert / 13:01 / 13:57
etc

Naïvement je comptais m'en sortir avec une matricielle du genre :

{=MIN((A2:A4="Albert")*(B2:B5))} pour obtenir 07:18

ou

{=MAX((A2:A4="Albert")*(C2:C5))} pour obtenir 13:57

Ben j'obtiens un lamentable : 00:00 dans les deux cas !!!

Je pense que ça viens du format de cellule car même en essayant :

{=SOMME((A2:A4="Albert")*(B2:B5))} j'obtiens le même 00:00 !!!

Merci d'avance pour votre aide !

Serge








Publicité
Poster une réponse
Anonyme