mknod

Le
Paul Pygeon
Bonjour,

Je tente d'installer une manette de jeu conventionnelle et pour cela je dois
créer des fichiers dans /dev/input. Toutes mes tentatives se soldent par le
message suivant:

root@Galactica flipper]# mknod /dev/input/js0 c 13 0
mknod: relocation error: mknod: symbol gnu_dev_makedev, version GLIBC_2.3.3
not defined in file libc.so.6 with link time reference

Quelqu'un pourrait me dire où chercher.

Merci
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
TiChou
Le #1522264
Dans le message *Paul Pygeon* tapota sur f.c.o.l.configuration :

Bonjour,


Bonsoir,

Je tente d'installer une manette de jeu conventionnelle et pour cela je
dois créer des fichiers dans /dev/input. Toutes mes tentatives se soldent
par le message suivant:

flipper]# mknod /dev/input/js0 c 13 0
mknod: relocation error: mknod: symbol gnu_dev_makedev, version
GLIBC_2.3.3

not defined in file libc.so.6 with link time reference


La commande 'mknod' appartenant au paquetage coreutils a été compilée sur
une version de la librairie C (la « glibc ») qui diffère de celle installée
sur votre système.
Autant dire qu'il y a un sérieux problème de cohésion sur votre système !

Quelqu'un pourrait me dire où chercher.


Quelle distribution ? Parce qu'il faudrait peut être songer à en changer.
;-)

Plus sérieusement, vérifiez que la version de la glibc utilisée sur votre
système est la bonne et mettez à jour le paquetage coreutils ou le paquetage
fileutils si votre distribution est ancienne.

Pensez peut être aussi à migrer votre système pour qu'il utilise devfs vous
évitant alors de créer manuellement les devices manquant dans vore /dev.

Merci


De rien.

--
TiChou

Paul Pygeon
Le #1522250
Le 26 Avril 2004 17:05 TiChou a écrit en cette journée dans
fr.comp.os.linux.configuration:

Quelle distribution ? Parce qu'il faudrait peut être songer à en changer.
;-)
Mandrake, mais extrêmement personnalisée. Je n'aime pas la nouvelle version

10 et en plus j'installe un bon paquet de programmes en .gz ou en .bz2
puisque les rpms ne sont pas disponibles.

Pour ce qui est d'en changer, j'ai aussi une Debian, une Fedora et une
Gentoo en parallèle sur mon système, question de bidouiller un peu :)

Plus sérieusement, vérifiez que la version de la glibc utilisée sur votre
système est la bonne et mettez à jour le paquetage coreutils ou le
paquetage fileutils si votre distribution est ancienne.
C'était bien ça. J'avais installé une partie des rpms de la 10 mais j'avais

oublié de mettre la glibc à jour.

Pensez peut être aussi à migrer votre système pour qu'il utilise devfs
vous évitant alors de créer manuellement les devices manquant dans vore
/dev.
J'utilise déjà devfs mais avec un kernel 2.4. Je trouve le 2.6 encore trop

jeune et la lecture de certains forums m'a incité à ne pas l'installer tout
de suite.

Merci pour la réponse.

Publicité
Poster une réponse
Anonyme