Modprobe

Le
Jo Engo
Bonjour,

Suite et pas fin de mes aventures sonores :

J'ai rebooté (oui bon, que les maniaque d'uptime ne me jettent pas la
preière pierre :) et je m'aperçois (j'ai testé immédiatement pensez donc)
que je n'avais de nouveau pas de son. Je réitère le modprobe kivabien et
tout roule de nouveau. Mon interrogation est la suivante : je croyais que
le modprobe était fait une fois pour toute, visiblement non. Je présume
que la solution est du côté d'udev, mais comme je ne connais pas trop ça
me semble un vaste sujet. Quelqu'un peut il m'indiquer le début du
chemin ? merci.



--

16:31 Surtout que le bobun, c'ets pas dur, tu mets n'importe quoi dedans
16:33 16:31 Ben, si tu mets du béton, c'est dur.
Vos réponses Page 2 / 2
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Th.A.C
Le #26462847
Le 01/02/2018 à 19:41, Jo Engo a écrit :
Le Thu, 01 Feb 2018 19:14:17 +0100, Th.A.C a écrit :
regarde déja dans la liste retournée par:
sudo modprobe -c | more

je préfère less :)
si ta carte son n'est pas blacklistée

Elle est blacklistée, qu'est-ce que ça signifie ?

que le module n'est pas chargé automatiquement
D'habitude, c'est plutot pcspkr qui est blacklisté
grep intel /etc/modprobe.d/*
/etc/modprobe.d/oss4-base_noALSA.conf:blacklist snd-hda-intel
et alors que dois-je faire pour la white-lister ? Je la vire tout
simplement de la blacklist ?

http://robots.mobilerobots.com/wiki/Linux_Audio_Drivers
tu n'aurais pas installé "oss4" et consorts?
Jo Engo
Le #26462854
Le Thu, 01 Feb 2018 19:52:32 +0100, Th.A.C a écrit :
Le 01/02/2018 à 19:41, Jo Engo a écrit :
Le Thu, 01 Feb 2018 19:14:17 +0100, Th.A.C a écrit :
regarde déja dans la liste retournée par:
sudo modprobe -c | more

je préfère less :)
si ta carte son n'est pas blacklistée

Elle est blacklistée, qu'est-ce que ça signifie ?

que le module n'est pas chargé automatiquement D'habitude, c'est plutot
pcspkr qui est blacklisté

C'est ce que j'avais compris. Ce que je voudrais saboir c'est la cause du
blacklistage, mais il n'y a pas de commentaire dans etc/modprobe.d/oss4-
base_noALSA.conf:blacklist
et alors que dois-je faire pour la white-lister ? Je la vire tout
simplement de la blacklist ?

http://robots.mobilerobots.com/wiki/Linux_Audio_Drivers

je vais voir ça
tu n'aurais pas installé "oss4" et consorts?

J'/avais/ oss4-dkms et oss4-base, je les vire et je regarde si ma carte
est toujours dans la blacklist. J'ai envie de la virer tout simplement,
le son fonctionne bien.
Il y a quelque chose qui cloche là-dedans, j'y retourne immédiatement…
--
Vexez psy à Ulm. Bon jerk à Wight. CQFD
-- Zalmanski, Alain
Jo Engo
Le #26462853
Le Thu, 01 Feb 2018 19:52:32 +0100, Th.A.C a écrit :
http://robots.mobilerobots.com/wiki/Linux_Audio_Drivers
tu n'aurais pas installé "oss4" et consorts?


To revert back to ALSA after installing OSS4, remove the oss4-base and
oss4-dkms packages, and also delete the file oss4-base_noALSA.conf from
the /etc/modprobe.d/ directory
bon. ça concerne ubuntu mais le conseil vaut probablement, il faut que je
vire le fichier manuellement, donc.
--
ASTUCIEUX
M : Un bousier dans chaque narine... et plus besoin... de se mettre les
doigts dans le nez...
Jo Engo
Le #26462988
Le Thu, 01 Feb 2018 19:28:31 +0000, Jo Engo a écrit :
To revert back to ALSA after installing OSS4, remove the oss4-base and
oss4-dkms packages, and also delete the file oss4-base_noALSA.conf from
the /etc/modprobe.d/ directory

Apparemment la purge de oss4* a eu raison du fichier oss4-base_noALSA.conf
par contre il reste un fichier osspd.conf qui blackliste 3 modules :
blacklist snd-pcm-oss
blacklist snd-mixer-oss
blacklist snd-seq-oss
Bon, tout baigne, il me reste à rebooter sans /etc/modprobe.d/sons.conf
et avec si nécessaire
--
La femme ne voit jamais ce qu'on fait pour elle,
elle ne voit que ce qu'on ne fait pas.
-+- Georges Courteline -+-
Jo Engo
Le #26463020
Le Fri, 02 Feb 2018 16:45:40 +0000, Jo Engo a écrit :
Bon, tout baigne, il me reste à rebooter sans /etc/modprobe.d/sons.conf
et avec si nécessaire

Tout baigne sans. C'est udev qui fait bien son boulot ?
Bon maintenant c'est pulseaudio du moins je suppose qui me cause un
souci : problème de micro.
Est-ce que je peux (facilement) m'en passer (de pulse) ?
--
Je me sers d'animaux pour instruire les hommes.
-+- Jean de La Fontaine (1621-1695),
Dédicace à Monseigneur de Dauphin (Fables I.) -+-
Eric Belhomme
Le #26463396
Le Fri, 02 Feb 2018 18:36:25 +0000, Jo Engo a écrit :
Est-ce que je peux (facilement) m'en passer (de pulse) ?

Ca dépend de ton Windows Manager. Si tu utilises Gnome ou un WM dérivé de
Gnome, oublies. Sauf à vouloir recompiler tout le Core de gnome en
désactivant explicitement Pulse.
--
Rico
Jo Engo
Le #26463408
Le Mon, 05 Feb 2018 08:41:52 +0000, Eric Belhomme a écrit :
Est-ce que je peux (facilement) m'en passer (de pulse) ?

Ca dépend de ton Windows Manager. Si tu utilises Gnome ou un WM dérivé
de Gnome, oublies. Sauf à vouloir recompiler tout le Core de gnome en
désactivant explicitement Pulse.

J'ai été voir ce que le solver me disait si je virais pulse, il me
faudrait supprimer paquets. De combien me sers-je, je ne sais pas.
J'utilise lxsde, il est (complètement) silencieux, donc ça ne me manquera
pas au niveau du window manager... Mais vu le nombre de paquests
impliqués, je préfère surseoir. Il faut que je teste mon micro interne,
un programme pour ça ? Pas sûr non plus que ce soit pulseaudio le
coupable s'il y a un problème.

--
BLAGUE
M : Oooh !
P : Quoi ?
M : J'avais jamais su que t'avais un grain de beauté là...
P : Où ça ?
M : Là...
P : CONNAAARD !
Proutch !
Jo Engo
Le #26463426
Le Mon, 05 Feb 2018 08:41:52 +0000, Eric Belhomme a écrit :
Est-ce que je peux (facilement) m'en passer (de pulse) ?

Ca dépend de ton Windows Manager. Si tu utilises Gnome ou un WM dérivé
de Gnome, oublies. Sauf à vouloir recompiler tout le Core de gnome en
désactivant explicitement Pulse.

J'ai été voir ce que le solver me disait si je virais pulse, il me
faudrait supprimer environ 142 paquets. De combien me sers-je, je ne
sais pas.
J'utilise lxsde, il est (complètement) silencieux, donc ça ne me manquera
pas au niveau du window manager... Mais vu le nombre de paquests
impliqués, je préfère surseoir. Il faut que je teste mon micro interne, un
programme pour ça ? Pas sûr non plus que ce soit pulseaudio le coupable
s'il y a un problème.


--
Toute théorie scientifique contient un coeur que l'on ne peut
remettre en question sans renoncer à la théorie elle-même.
-+- Thomas Kuhn -+-
Yliur
Le #26463441
Le 02 Feb 2018 18:36:25 GMT
Jo Engo
Le Fri, 02 Feb 2018 16:45:40 +0000, Jo Engo a écrit :
Bon, tout baigne, il me reste à rebooter
sans /etc/modprobe.d/sons.conf et avec si nécessaire

Tout baigne sans. C'est udev qui fait bien son boulot ?
Bon maintenant c'est pulseaudio du moins je suppose qui me cause un
souci : problème de micro.
Est-ce que je peux (facilement) m'en passer (de pulse) ?

Je pense que Firefox dépend de Pulseaudio.
Publicité
Poster une réponse
Anonyme