Moyenne sur zone comptenant des messages d'erreur de type #N/A

Le
ciboulette
J'aimerai faire la moyenne d'une colonne comptenant des messages d'erreur de
type #N/A sans avoir a faire de matrice.

Comment faire pour que ma formule moyenne ne prenne en compte que les
cellules qui ne contiennent pas ce message d'erreur ?

Merci
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
ru-th
Le #1255019
Salut

sans faire de matricielle ?
et pourtant
=MOYENNE(SI(NON(ESTNA(A1:A7));A1:A7))
valider par ctrl+shift+entrée
devrait correspondre à ton besoin

a+
rural thierry
"ciboulette" BCAC1B01.2C92%
J'aimerai faire la moyenne d'une colonne comptenant des messages d'erreur
de

type #N/A sans avoir a faire de matrice.

Comment faire pour que ma formule moyenne ne prenne en compte que les
cellules qui ne contiennent pas ce message d'erreur ?

Merci



ciboulette
Le #1264896
Salut« ru-th »,

Merci pour ta reponse.

Je viens de decouvrir qu'on peut aussi le faire avec
=MOYENNE(SI(ESTERREUR(A1:A7);"";A1:A7))
Et ctrl-shift-entrée bien sur

C'est bien ca ?

Salut

sans faire de matricielle ?
et pourtant
=MOYENNE(SI(NON(ESTNA(A1:A7));A1:A7))
valider par ctrl+shift+entrée
devrait correspondre à ton besoin

a+
rural thierry
"ciboulette" BCAC1B01.2C92%
J'aimerai faire la moyenne d'une colonne comptenant des messages d'erreur
de

type #N/A sans avoir a faire de matrice.

Comment faire pour que ma formule moyenne ne prenne en compte que les
cellules qui ne contiennent pas ce message d'erreur ?

Merci





Benead
Le #1261073
Salut ciboulette,

Et ctrl-shift-entrée bien sur
Non, non, tu n'es pas obligée...


A+
Benead
Bretagne
Xl97
-------- ;-)

ciboulette a écrit:
Salut« ru-th »,

Merci pour ta reponse.

Je viens de decouvrir qu'on peut aussi le faire avec
=MOYENNE(SI(ESTERREUR(A1:A7);"";A1:A7))
Et ctrl-shift-entrée bien sur

C'est bien ca ?


Salut

sans faire de matricielle ?
et pourtant
=MOYENNE(SI(NON(ESTNA(A1:A7));A1:A7))
valider par ctrl+shift+entrée
devrait correspondre à ton besoin

a+
rural thierry
"ciboulette" BCAC1B01.2C92%

J'aimerai faire la moyenne d'une colonne comptenant des messages d'erreur


de

type #N/A sans avoir a faire de matrice.

Comment faire pour que ma formule moyenne ne prenne en compte que les
cellules qui ne contiennent pas ce message d'erreur ?

Merci










AV
Le #1261058
Hum.....hum....
Les 2 solutions proposées (validation matricielle obligatoire) prennent en
compte les cellules vides pour le calcul de la moyenne !
Ex : 10;vide;10;#N/A
--> résultat attendu : 10
--> résultat renvoyé : 6.6666

Une soluce (matricielle) :
=MOYENNE(SI(ESTERREUR(A1:A4);"";SI(A1:A4="";"";A1:A4)))

AV
Publicité
Poster une réponse
Anonyme