[Mozilla] Sortie de la version 1.7.6

Le
Frederic Bezies
Bonjour.

Pour les nombreux fans de la suite, Mozilla.org vient de sortir la
version 1.7.6 du lézard.

En anglais pour le moment, les notes de publications :

http://www.mozilla.org/releases/mozilla1.7.6/README.html#new

En gros, une sortie corrigeant des bugs de sécurité, rien de bien
"transcendant".

http://www.mozilla.org/projects/security/known-vulnerabilities.html#Mozilla

"
MFSA 2005-29 Internationalized Domain Name (IDN) homograph spoofing
MFSA 2005-28 Unsafe /tmp/plugtmp directory exploitable to erase user's files
MFSA 2005-27 Plugins can be used to load privileged content
MFSA 2005-26 Cross-site scripting by dropping javascript: link on tab
MFSA 2005-25 Image drag and drop executable spoofing
MFSA 2005-24 HTTP auth prompt tab spoofing
MFSA 2005-23 Download dialog source spoofing
MFSA 2005-21 Overwrite arbitrary files downloading .lnk twice
MFSA 2005-20 XSLT can include stylesheets from arbitrary hosts
MFSA 2005-18 Memory overwrite in string library
MFSA 2005-17 Install source spoofing with user:pass@host
MFSA 2005-16 Spoofing download and security dialogs with overlapping windows
MFSA 2005-15 Heap overflow possible in UTF8 to Unicode conversion
MFSA 2005-14 SSL "secure site" indicator spoofing
MFSA 2005-13 Window Injection Spoofing"

Beaucoup de corrections liées au spoofing, tiens ;)

Et le "changelog" brut de pommes, seulement 70 modifications depuis la 1.7.5

http://www.mozilla.org/releases/mozilla1.7.6/changelog.html

--
Frédéric Béziès - fredbezies@gmail.com

Site Perso : http://perso.wanadoo.fr/frederic.bezies/
Weblog : http://fredbezies.jexiste.fr/dotclear/
Fourre-tout : http://perso.wanadoo.fr/frederic.bezies/pratique/
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Steph
Le #10956811
Le 22/03/2005 07:48, Frederic Bezies écrivait :

Bonjour.

Pour les nombreux fans de la suite, Mozilla.org vient de sortir la
version 1.7.6 du lézard.



Plus besoin de désinstaller l'ancienne ?

--
Steph
Enlever l'.adressebidon.invalid pour m'écrire
Aph
Le #10885071
Frederic Bezies a écrit :
Bonjour.

Pour les nombreux fans de la suite, Mozilla.org vient de sortir la
version 1.7.6 du lézard.

En anglais pour le moment, les notes de publications :

http://www.mozilla.org/releases/mozilla1.7.6/README.html#new

En gros, une sortie corrigeant des bugs de sécurité, rien de bien
"transcendant".



Surtout que vu le temps de réaction qu'ils ont depuis qu'ils font du
marketing pour leur machinfox , on a intérêt à aller se servir soi-même
dans les divers endroits où on trouve les patches et recompiler une
1.4.x ou une 1.7.x. quand on utilise un système stable de travail ; de
plus ça élimine les problèmes de dépendances.

Vivement la version 1.8 ;-)

--
> Non, la population n'est pas infinie. Mais c'est plutôt comme un segment
> de droite : le nombre de points est infini.
et les segments de gauche, alors ? ils sont formés d'un point et d'une
infinité d'extrémités ? -+- MS in GFA : Géométrie non euclidienne -+-
Aph
Le #10885061
Steph a écrit :
Le 22/03/2005 07:48, Frederic Bezies écrivait :

Bonjour.

Pour les nombreux fans de la suite, Mozilla.org vient de sortir la
version 1.7.6 du lézard.



Plus besoin de désinstaller l'ancienne ?



Il n'y a jamais eu besoin de désinstaller une ancienne version pour en
mettre une nouvelle depuis la version M8 au moins ; c'est plutôt des
problèmes liés à une config de windows ou à des éléments perturbateurs
type certaines versions de firefox ou netscape. De plus, ce n'est pas à
proprement parler une nouvelle version, mais plutôt une mise à jour.

Le xpi fr fonctionne avec la 1.7.6.

--
WD> On ne discute pas avec les brouettes, on les pousse.
VD> Tiens il est de mauvais poil.
Vous n'y êtes pas du tout, je pêche le thon.
-+- WoD in
Julien Queinnec
Le #10885051
Aph a écrit dans news::

Surtout que vu le temps de réaction qu'ils ont depuis qu'ils font du
marketing pour leur machinfox , on a intérêt à aller se servir soi-même
dans les divers endroits où on trouve les patches et recompiler une
1.4.x ou une 1.7.x. quand on utilise un système stable de travail ; de
plus ça élimine les problèmes de dépendances.

Vivement la version 1.8 ;-)




Qui n'existera a priori pas (du moins en version stable) : il y aura sabs
doute des beta, puis une 1.9alpha (outil de test de gecko).

Par contre il y aura sans doute une version "seamonkey 1.0" ou "mozilla
Application 1.0" ou ... équivalent à la 1.8 de Mozilla mais non validé par
la Mozilla Fondation, seulement par une communauté de développeur.

Julien Queinnec
--
Je ne dis pas que c'est pas injuste, je t'ai dis que ça soulage !
Steph
Le #10884821
Le 22/03/2005 10:45, Aph écrivait :

Steph a écrit :

Le 22/03/2005 07:48, Frederic Bezies écrivait :

Bonjour.

Pour les nombreux fans de la suite, Mozilla.org vient de sortir la
version 1.7.6 du lézard.




Plus besoin de désinstaller l'ancienne ?



Il n'y a jamais eu besoin de désinstaller une ancienne version pour en
mettre une nouvelle depuis la version M8 au moins ; c'est plutôt des



ben voyons... et c'est quoi cette M8 ?

--
Steph
Enlever l'.adressebidon.invalid pour m'écrire
Frederic Bezies
Le #10884811
Le 3/22/05 4:43 PM, Steph a écrit :

Le 22/03/2005 10:45, Aph écrivait :

Steph a écrit :

Le 22/03/2005 07:48, Frederic Bezies écrivait :

Bonjour.

Pour les nombreux fans de la suite, Mozilla.org vient de sortir la
version 1.7.6 du lézard.





Plus besoin de désinstaller l'ancienne ?



Il n'y a jamais eu besoin de désinstaller une ancienne version pour en
mettre une nouvelle depuis la version M8 au moins ; c'est plutôt des




ben voyons... et c'est quoi cette M8 ?




M8 comme Milestone 8. Des pré-versions de mozilla qui date de 1998-1999,
avant la sortie de Netscape 6 alias Mozilla 0.6

--
Frédéric Béziès -

Site Perso : http://perso.wanadoo.fr/frederic.bezies/
Weblog : http://fredbezies.jexiste.fr/dotclear/
Fourre-tout : http://perso.wanadoo.fr/frederic.bezies/pratique/
Steph
Le #10884801
Le 22/03/2005 07:48, Frederic Bezies écrivait :

Bonjour.

Pour les nombreux fans de la suite, Mozilla.org vient de sortir la
version 1.7.6 du lézard.



Donc je viens de passer de la 1.5 à la 1.6 et... :(

- la Googlebar crée le bug
- Quand je veux ouvrir un .wmp --> j'ai le source qui s'affiche:
0&²uŽfϦÙ...

1ère fois que çà m'arrive ces binz

--
Steph
Enlever l'.adressebidon.invalid pour m'écrire
Will
Le #10884611
Le 22/03/2005 10:45 (à peu de choses près), Aph a intelligemment dit...
Il n'y a jamais eu besoin de désinstaller une ancienne version pour en
mettre une nouvelle depuis la version M8 au moins



ouais, enfin ça coute pas plus cher de faire ça proprement...

par ailleurs, il me semble bien que ce soit fortement conseillé sur
mozillazine-fr (je pense l'avoir lu là).

--
Will
Will
Le #10884601
Le 22/03/2005 16:58 (à peu de choses près), Steph a intelligemment dit...
Donc je viens de passer de la 1.5 à la 1.6 et... :(



tu veux dire 1.7.5 à 1.7.6 ?

- la Googlebar crée le bug


il faut (mozilla éteint) supprimer le fichier XUL.mfl dans ton dossier
profil.

- Quand je veux ouvrir un .wmp --> j'ai le source qui s'affiche:
0&²uŽfϦÙ...



vérifie, qqpart dans les options, que tu ouvres bien les .wmp avec le
plugin qui va bien. et aussi que tu as ce plugin : tape about:plugins
dans ta barre d'adresse. si tu l'as pas, regarde ici :
http://plugindoc.mozdev.org/fr-FR/windows.html

--
Will
Steph
Le #10884421
Le 23/03/2005 01:47, :
Le 22/03/2005 16:58 (à peu de choses près), Steph a intelligemment dit...

Donc je viens de passer de la 1.5 à la 1.6 et... :(




tu veux dire 1.7.5 à 1.7.6 ?



oui, enfin comme c'est marqué dans about mozilla, je n'ai pas fait gaffe

- la Googlebar crée le bug



il faut (mozilla éteint) supprimer le fichier XUL.mfl dans ton dossier
profil.



essayé, çà marche pas
j'ai testé la soluce donnée sur cette page
(
- Quand je veux ouvrir un .wmp --> j'ai le source qui s'affiche:
0&²uŽfϦÙ...




vérifie, qqpart dans les options, que tu ouvres bien les .wmp avec le
plugin qui va bien. et aussi que tu as ce plugin : tape about:plugins
dans ta barre d'adresse. si tu l'as pas, regarde ici :
http://plugindoc.mozdev.org/fr-FR/windows.html




fait aussi et que dalle (je sauvegarde toujours le dossier plugin entre
chaque migration)
bon... ben je crois que c'est le moment de passer à FF+TB :)

--
Steph
Enlever l'.adressebidon.invalid pour m'écrire
Publicité
Poster une réponse
Anonyme