Mystère en édition vidéo .ts

Le
JeanPaulo
Bonjour.

Depuis la TNT, j'enregistre pas mal de choses et j'élimine les 'marges'
et les Pubs en éditant le fichier .ts avec Smart Cutter ou Ffmpeg.

A part quelques plantages sur des parasites visibles, cela se passe
plutôt bien.

Si j'examine le fichier obtenu avec MediaInfo (ou ffmpeg); les 3 audio
d'origine sont là, ainsi que les sous-titres (pas toujours remplis).

Le format .ts est d'ailleurs 'auto-réparable', ce qui permet à la
réception TNT de toujours trouver les infos correctement. Ceci est
confirmé par le fait que l'on peut très bien lire un segment (coupé par
le décodeur à 2Go ou 4Go précisément) par lui-même.

J'utilise 2 décodeurs, un Elap et un Etimo. (la télé elle-même ne connait
que le Mpeg sur clé USB)

Pour visionner sur PC, j'ai le choix entre Win 10 (beurk) VLC (plutôt
mauvais) AVS (moins sensible aux problèmes) et Smplayer, et Tmpgenc DVD
6.

Mon problème (et je ne suis pas seul), dont j'aimerais avoir une
explication, est que chacun de ces outils ne reçonnait plus les fichiers
édités (même ceux que Mediainfo reconnaît sans problème).

Elap. Refuse les sous-titres systématiquement, parfois aussi le fichier
lui-même, ou l'audio. (il accepte un .srt du même nom, alors que VLC
plante si un fichier similaire existe!)

Etimo. Refuse parfois le fichier totalement, ou l'audio, ou une seule
audio. (nota, pour les deux, la lecture du fichier original est sans
défaut)

VLC, AVS montrent tous des symptomes fréquents :

Refus total de lire
Durée du clip farfelue, ou refus de lire tout le fichier.
Pas d'audio, ou une seule piste.
Pas de sous-titres, ou décalage du son et st pendant le clip.

Les différents programmes sont souvent d'un avis différent !

Tmpgenc, qui n'est pas un player, mais un générateur de DVD présente
beaucoup moins d'erreurs.

Parfois il suffit de couper 1 seconde de moins ou de plus dans l'original
pour que ça remarche(parfois juste une ou deux images). Parfois il
faut passer par Ffmpeg.

Mon idée, que j'aimerait confirmer, c'est que tout ces programmes se
contentent de vérifier la premier paquet reçu et d'en déduire la suite,
sans vérifier la validité de ce premier paquet.

Alors que Mediainfo cherche la validité des streams.

Quelqu'un à t'il une opinion à ce sujet, merci d'avance.

JeanPaulo
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Alf92
Le #26445757
JeanPaulo :
Bonjour.
Depuis la TNT, j'enregistre pas mal de choses et j'élimine les 'marges'
et les Pubs en éditant le fichier .ts avec Smart Cutter ou Ffmpeg.
A part quelques plantages sur des parasites visibles, cela se passe
plutôt bien.
Si j'examine le fichier obtenu avec MediaInfo (ou ffmpeg); les 3 audio
d'origine sont là, ainsi que les sous-titres (pas toujours remplis).
Le format .ts est d'ailleurs 'auto-réparable', ce qui permet à la
réception TNT de toujours trouver les infos correctement. Ceci est
confirmé par le fait que l'on peut très bien lire un segment (coupé par
le décodeur à 2Go ou 4Go précisément) par lui-même.
J'utilise 2 décodeurs, un Elap et un Etimo. (la télé elle-même ne connait
que le Mpeg sur clé USB)
Pour visionner sur PC, j'ai le choix entre Win 10 (beurk) VLC (plutôt
mauvais) AVS (moins sensible aux problèmes) et Smplayer, et Tmpgenc DVD
6.
Mon problème (et je ne suis pas seul), dont j'aimerais avoir une
explication, est que chacun de ces outils ne reçonnait plus les fichiers
édités (même ceux que Mediainfo reconnaît sans problème).
Elap. Refuse les sous-titres systématiquement, parfois aussi le fichier
lui-même, ou l'audio. (il accepte un .srt du même nom, alors que VLC
plante si un fichier similaire existe!)
Etimo. Refuse parfois le fichier totalement, ou l'audio, ou une seule
audio. (nota, pour les deux, la lecture du fichier original est sans
défaut)
VLC, AVS... montrent tous des symptomes fréquents :
Refus total de lire...
Durée du clip farfelue, ou refus de lire tout le fichier.
Pas d'audio, ou une seule piste.
Pas de sous-titres, ou décalage du son et st pendant le clip.
Les différents programmes sont souvent d'un avis différent !
Tmpgenc, qui n'est pas un player, mais un générateur de DVD présente
beaucoup moins d'erreurs.
Parfois il suffit de couper 1 seconde de moins ou de plus dans l'original
pour que ça remarche...(parfois juste une ou deux images). Parfois il
faut passer par Ffmpeg.
Mon idée, que j'aimerait confirmer, c'est que tout ces programmes se
contentent de vérifier la premier paquet reçu et d'en déduire la suite,
sans vérifier la validité de ce premier paquet.
Alors que Mediainfo cherche la validité des streams.
Quelqu'un à t'il une opinion à ce sujet, merci d'avance.

t'es fichiers ne sont visibmlement pas d'aplomb.
une fois édité change-les de container avec MKVmerge.
le MKV est simple, libre et robuste...
JeanPaulo
Le #26445871
Alf92
JeanPaulo :
Bonjour.
Depuis la TNT, j'enregistre pas mal de choses et j'élimine les
'marges' et les Pubs en éditant le fichier .ts avec Smart Cutter ou
Ffmpeg.

Quelqu'un à t'il une opinion à ce sujet, merci d'avance.

t'es fichiers ne sont visibmlement pas d'aplomb.
une fois édité change-les de container avec MKVmerge.
le MKV est simple, libre et robuste...

Hello.
Bien que ce ne soit pas vraiment le sujet de la question, j'ai testé
cette suggestion sur un fichier (épisode TF1) qui posait des problèmes
(Pas de VO, pas de st).
Le MKV ne semble pas avoir de problèmes sur le PC (sauf les st), mais je
ne regarde presque jamais une vidéo sur un petit écran.
Sur ma télé Sony:
en direct: Rien. le fichier n'existe pas ! (un .ts est présent, mais pas
lisible)
Sur l'Etimo : Il y a bien la vo (St ?) mais l'image est deux fois la
hauteur de l'écran, avec des sauts permanent... Illisible, donc.
Sur l'Elap : La vo est bien là, mais pas de sous-titres, et l'image est
saccadée. Difficile à supporter.
Echec total, donc.
J'avais pensé a m'équiper d'un PC spécifique, mais il n'y a pas de modèle
tout prêt et pas ruineux.
Dommage...
Alf92
Le #26446061
JeanPaulo :
Alf92
JeanPaulo :
Bonjour.
Depuis la TNT, j'enregistre pas mal de choses et j'élimine les
'marges' et les Pubs en éditant le fichier .ts avec Smart Cutter ou
Ffmpeg.

Quelqu'un à t'il une opinion à ce sujet, merci d'avance.

tes fichiers ne sont visibmlement pas d'aplomb.
une fois édité change-les de container avec MKVmerge.
le MKV est simple, libre et robuste...

Hello.
Bien que ce ne soit pas vraiment le sujet de la question, j'ai testé
cette suggestion sur un fichier (épisode TF1) qui posait des problèmes
(Pas de VO, pas de st).
Le MKV ne semble pas avoir de problèmes sur le PC (sauf les st), mais je
ne regarde presque jamais une vidéo sur un petit écran.
Sur ma télé Sony:
en direct: Rien. le fichier n'existe pas ! (un .ts est présent, mais pas
lisible)
Sur l'Etimo : Il y a bien la vo (St ?) mais l'image est deux fois la
hauteur de l'écran, avec des sauts permanent... Illisible, donc.
Sur l'Elap : La vo est bien là, mais pas de sous-titres, et l'image est
saccadée. Difficile à supporter.
Echec total, donc.
J'avais pensé a m'équiper d'un PC spécifique, mais il n'y a pas de modèle
tout prêt et pas ruineux.
Dommage...

à mon avis le pb vient de l'encodage/codec, pas du container.
pour tout ce qui vient d'un enregistrement direct en .TS (freebox ou
autre) j'utilise (j'utilisais) VideoRedo (Windows) pour convertir (sans
réencodage) les vidéos TS (transport stream) en vidéos PS (program
stream).
JeanPaulo
Le #26446082
Alf92
JeanPaulo :
Alf92
JeanPaulo :
Bonjour.
Depuis la TNT, j'enregistre pas mal de choses et j'élimine les
'marges' et les Pubs en éditant le fichier .ts avec Smart Cutter ou
Ffmpeg.



à mon avis le pb vient de l'encodage/codec, pas du container.
pour tout ce qui vient d'un enregistrement direct en .TS (freebox ou
autre) j'utilise (j'utilisais) VideoRedo (Windows) pour convertir
(sans réencodage) les vidéos TS (transport stream) en vidéos PS
(program stream).


Toujours hors sujet.
L'original est en .ts (AVC). C'est le découpage qui cause le problème, il
n'y a pas de conversion. De plus VideoRedo refuse d'ouvrir le stream
original (audio invalide).
Alf92
Le #26446142
JeanPaulo :
L'original est en .ts (AVC). C'est le découpage qui cause le problème, il
n'y a pas de conversion. De plus VideoRedo refuse d'ouvrir le stream
original (audio invalide).

tu n'as pas une petite video à mettre sur un coin de cloud pour tester
?
JeanPaulo
Le #26446200
Alf92
JeanPaulo :
L'original est en .ts (AVC). C'est le découpage qui cause le
problème, il n'y a pas de conversion. De plus VideoRedo refuse
d'ouvrir le stream original (audio invalide).

tu n'as pas une petite video à mettre sur un coin de cloud pour tester
?

OK, je vais refaire la découpe d'un petit extrait, et le poster sur
dl.free. Celui que j'ai fait déjà 1.3 Go
JeanPaulo
Le #26446321
Alf92
JeanPaulo :
L'original est en .ts (AVC). C'est le découpage qui cause le
problème, il n'y a pas de conversion. De plus VideoRedo refuse
d'ouvrir le stream original (audio invalide).

tu n'as pas une petite video à mettre sur un coin de cloud pour tester
?


Je n'ai pas réussi à reproduire le pb sur une petite section. Le defaut est
parfois à une ou deux images près. Je n'ai pas conservé le clip en défaut,
en lui ajoutant 1 seconde avant le début, il est bon.
Publicité
Poster une réponse
Anonyme