NB.JOURS.OUVRES + Office 2000 + Office XP

Le
Hugues
Bonjour,

J'ai un petit problme depuis aujourd'hui. Nous
changeons un fichier excel qui utilise la fonction
NB.JOURS.OUVRES

Avant aujourd'hui, tous les PC taient sous
Windows2000/Office2000

Nous avons pass certains PC sous WindowsXP/OfficeXP et
il n'est plus possible d'changer ce fichier.

Nos XP sont en anglais natifs aces le pack Franais par
dessus, ce qui fait que la fonction NB.JOURS.OUVRES n'est
plus reconnue. Nous avons tent de la remplacer par
NETWORKDAYS.

Cela fonctionne parfaitement sur le PC qui "cr" le
fichier qu'il soit sous 2000 ou sous XP, mais si un autre
PC avec une autre version tente de l'ouvrir, cela pose
les problmes suivantes

XP-->2000 : les formules passent en erreur alors qu'un
simple [F2] [Entre] permet de les ractiver (quelques
centaines de cellules a faire une par une.)

2000-->XP : Lors de l'enregistrements du fichier en
environnement 2000, excel attache la fonction NETWORKDAYS
au XLA correspondant avec son path complet
("c:progra"). Ce qui fait que quand on essaye de
l'ouvrir sous XP, il nous dclare un lien impossible vers
un autre fichier (l'emplacement du XLA n'est pas le mme
sous 2000 et sous XP).

Voila si quelqu'un a une ide.
Vos réponses
Gagnez chaque mois un abonnement Premium avec GNT : Inscrivez-vous !
Trier par : date / pertinence
Rom1
Le #1358543
Bonjour

Une solution serait de tester si le classeur est ouvert sous 2000 ou XP

Voici une formule possible:

=SI(ESTERREUR(NB.JOURS.OUVRES(A1;A2));Networkdays(A1:A2);NB.JOURS.OUVRES(A1;
A2))

Sinon pourquoi pas créer une fonction dans ce classeur en VB qui calcule

le nombre de jour ouvrés et donc ne pas utiliser les fonctions par défaut
d'excel.

Bon courage

Romain

"Hugues" news:89ef01c432b6$eb0b75d0$
Bonjour,

J'ai un petit problème depuis aujourd'hui. Nous
échangeons un fichier excel qui utilise la fonction
NB.JOURS.OUVRES

Avant aujourd'hui, tous les PC étaient sous
Windows2000/Office2000

Nous avons passé certains PC sous WindowsXP/OfficeXP et
il n'est plus possible d'échanger ce fichier.

Nos XP sont en anglais natifs aces le pack Français par
dessus, ce qui fait que la fonction NB.JOURS.OUVRES n'est
plus reconnue. Nous avons tenté de la remplacer par
NETWORKDAYS.

Cela fonctionne parfaitement sur le PC qui "créé" le
fichier qu'il soit sous 2000 ou sous XP, mais si un autre
PC avec une autre version tente de l'ouvrir, cela pose
les problèmes suivantes

XP-->2000 : les formules passent en erreur alors qu'un
simple [F2] [Entrée] permet de les réactiver (quelques
centaines de cellules a faire une par une....)

2000-->XP : Lors de l'enregistrements du fichier en
environnement 2000, excel attache la fonction NETWORKDAYS
au XLA correspondant avec son path complet
("c:progra..."). Ce qui fait que quand on essaye de
l'ouvrir sous XP, il nous déclare un lien impossible vers
un autre fichier (l'emplacement du XLA n'est pas le même
sous 2000 et sous XP).

Voila si quelqu'un a une idée....
Jinroh
Le #1358542
C'est bien la raison pour laquelle on conseille toujours
de travailler exclusivement avec des logiciels dans leur
langue native (l'anglais pour tous!)

Je vous rassure au niveau des problèmes de traduction
entre 2000 et XP/2003 vous allez encore en voir d'autres
et même ailleurs que dans Excel (je vous laisse les
découvrirs)
-----Message d'origine-----
Bonjour

Une solution serait de tester si le classeur est ouvert
sous 2000 ou XP


Voici une formule possible:

=SI(ESTERREUR(NB.JOURS.OUVRES(A1;A2));Networkdays
(A1:A2);NB.JOURS.OUVRES(A1;

A2))

Sinon pourquoi pas créer une fonction dans ce classeur en
VB qui calcule


le nombre de jour ouvrés et donc ne pas utiliser les
fonctions par défaut

d'excel.

Bon courage

Romain

"Hugues" message de

news:89ef01c432b6$eb0b75d0$
Bonjour,

J'ai un petit problème depuis aujourd'hui. Nous
échangeons un fichier excel qui utilise la fonction
NB.JOURS.OUVRES

Avant aujourd'hui, tous les PC étaient sous
Windows2000/Office2000

Nous avons passé certains PC sous WindowsXP/OfficeXP et
il n'est plus possible d'échanger ce fichier.

Nos XP sont en anglais natifs aces le pack Français par
dessus, ce qui fait que la fonction NB.JOURS.OUVRES n'est
plus reconnue. Nous avons tenté de la remplacer par
NETWORKDAYS.

Cela fonctionne parfaitement sur le PC qui "créé" le
fichier qu'il soit sous 2000 ou sous XP, mais si un autre
PC avec une autre version tente de l'ouvrir, cela pose
les problèmes suivantes

XP-->2000 : les formules passent en erreur alors qu'un
simple [F2] [Entrée] permet de les réactiver (quelques
centaines de cellules a faire une par une....)

2000-->XP : Lors de l'enregistrements du fichier en
environnement 2000, excel attache la fonction NETWORKDAYS
au XLA correspondant avec son path complet
("c:progra..."). Ce qui fait que quand on essaye de
l'ouvrir sous XP, il nous déclare un lien impossible vers
un autre fichier (l'emplacement du XLA n'est pas le même
sous 2000 et sous XP).

Voila si quelqu'un a une idée....




.



Clément Marcotte
Le #1358539
C'est bien la raison pour laquelle on conseille toujours
de travailler exclusivement avec des logiciels dans leur
langue native (l'anglais pour tous!)


Une vraie réaction de colonisé ou de multinationale sans respect pour
les langues locale. L'anglais n'est pas la langue dominante dans le
monde.

Tant qu'à y être le chinois pout tous.

Publicité
Poster une réponse
Anonyme